Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 707862 - dev-libs/xapian-bindings-1.4.7 - configure: error: Couldn't import sphinx module and call sphinx.main() for Python3 - try package python3-sphinx
Summary: dev-libs/xapian-bindings-1.4.7 - configure: error: Couldn't import sphinx mod...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Anthony Basile
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-02 06:45 UTC by nE0sIghT
Modified: 2020-02-02 13:04 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info dev-libs/xapian-bindings (emerge-info.txt,8.46 KB, text/plain)
2020-02-02 06:46 UTC, nE0sIghT
Details
build.log (build.log,10.71 KB, text/plain)
2020-02-02 06:46 UTC, nE0sIghT
Details
config.log (config.log,41.12 KB, text/plain)
2020-02-02 13:04 UTC, nE0sIghT
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nE0sIghT 2020-02-02 06:45:29 UTC
checking for python3 sphinx module... no
configure: error: Couldn't import sphinx module and call sphinx.main() for Python3 - try package python3-sphinx


Reproducible: Always
Comment 1 nE0sIghT 2020-02-02 06:46:00 UTC
Created attachment 610886 [details]
emerge --info dev-libs/xapian-bindings
Comment 2 nE0sIghT 2020-02-02 06:46:59 UTC
Created attachment 610888 [details]
build.log
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2020-02-02 11:08:50 UTC
Comment on attachment 610888 [details]
build.log

>!!! Please attach the following file when seeking support:
>!!! /var/tmp/portage/dev-libs/xapian-bindings-1.4.7/work/xapian-bindings-1.4.7-python3_6/config.log

So where is it?
Comment 4 nE0sIghT 2020-02-02 13:04:25 UTC
Created attachment 611022 [details]
config.log

dev-python/sphinx-2.0.1::gentoo was built with the following:
USE="-doc -latex -test" ABI_X86="(64)" PYTHON_TARGETS="python3_6 (-pypy3) (-python3_7) (-python3_8)"
FEATURES="binpkg-dostrip config-protect-if-modified binpkg-logs ipc-sandbox preserve-libs userpriv sandbox fixlafiles merge-sync sfperms usersync network-sandbox unmerge-orphans strict binpkg-docompress news ebuild-locks parallel-fetch fail-clean pid-sandbox userfetch xattr protect-owned unmerge-logs multilib-strict distlocks unknown-features-warn assume-digests parallel-install usersandbox"