Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 70730 - nvidia-kernel 1.0-6629 does not install right
Summary: nvidia-kernel 1.0-6629 does not install right
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-11-10 17:34 UTC by George Kraev
Modified: 2009-08-20 11:58 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
log of startx (Xorg.0.log,20.50 KB, text/plain)
2004-11-14 20:04 UTC, Doug McMillan
Details
xorg.conf (xorg.conf,14.79 KB, text/plain)
2004-11-14 20:05 UTC, Doug McMillan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description George Kraev 2004-11-10 17:34:43 UTC
The ebuild of the nvidia driver does not install right. After it compleates successfully (presumably) every time you try to run the xserver it is not able to find the module. At the same time modprobe nvidia give you no error. I have tried this on both kernel 2.6.9-rc3 and the final 2.6.9 and it happens on both. I have no such problem with the official nvidia release so it is not a configuration problem at all. 

Reproducible: Always
Steps to Reproduce:
1.emerge nvidia-kernel
2.startx


Actual Results:  
error message saying that module nvidia cannot be found. Xorg server fails.
Comment 1 Andrew Bevitt 2004-11-11 00:59:56 UTC
Please do the following

rmmod nvidia
emerge -C nvidia-kernel
emerge nvidia-kernel
modprobe nvidia

Then post the output of : dmesg |tail 
Comment 2 George Kraev 2004-11-11 13:48:55 UTC
here's the output. I uninstalled the nvidia (official) driver and then followed the directions posted. 

agpgart: Putting AGP V2 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V2 device at 0000:02:00.0 into 4x mode
NTFS volume version 3.1.
NTFS-fs error (device hdd1): load_system_files(): Volume is dirty.  Mounting read-only.  Run chkdsk and mount in Windows.
bttv0: PLL can sleep, using XTAL (28636363).
ACPI: PCI interrupt 0000:02:00.0[A] -> GSI 5 (level, low) -> IRQ 5
NVRM: loading NVIDIA Linux x86 NVIDIA Kernel Module  1.0-6629  Wed Nov  3 13:12:51 PST 2004
ACPI: PCI interrupt 0000:02:00.0[A] -> GSI 5 (level, low) -> IRQ 5
ACPI: PCI interrupt 0000:02:00.0[A] -> GSI 5 (level, low) -> IRQ 5
NVRM: loading NVIDIA Linux x86 NVIDIA Kernel Module  1.0-6629  Wed Nov  3 13:12:51 PST 2004

When you try to load X it still comes up with an error message that the nvidia module could not be found and xorg fails to load. Still have no problems using xorg with the official driver though. 
Comment 3 Andrew Bevitt 2004-11-11 13:58:28 UTC
Please post : emerge info 
Also run lsmod check the driver is listed.

This is weird.
Comment 4 George Kraev 2004-11-11 15:04:38 UTC
lsmod shows the module as present however the xserver says that the module is unavailable. This is probably the weirdest thing I have seen. 

I am not sure what you mean by the emerge info. Emerge finishes successfully. I'll post the actual output in a sec. 
Comment 5 Andrew Bevitt 2004-11-11 15:19:46 UTC
Run : emerge info
post its output
Comment 6 George Kraev 2004-11-11 15:33:47 UTC
ok here's emerge info:


Portage 2.0.51-r3 (default-linux/x86/2004.2, gcc-3.4.2, glibc-2.3.4.20041102-r0, 2.6.9-ck3 i686)
=================================================================
System uname: 2.6.9-ck3 i686 AMD Athlon(tm) XP
Gentoo Base System version 1.6.6
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-2.15.92.0.2-r1
Headers:  sys-kernel/linux26-headers-2.6.8.1-r1
Libtools: sys-devel/libtool-1.5.2-r7
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-march=athlon-xp -O2 -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/usr/X11R6/lib/X11/xkb /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/bind"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-xp -O2 -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="http://mirror.tucdemonic.org/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X alsa apm arts avi berkdb bitmap-fonts bonobo cdr crypt cups dvd encode esd f77 fam famd flac foomaticdb fortran gdbm gif gnome gpm gstreamer gtk gtk2 gtkhtml guile hal imagemagick imlib ithreads java jpeg junit ldap libg++ libwww mad mikmod mmx motif mozilla mpeg mysql ncurses nls oggvorbis opengl oss pam pdflib perl png postgres python qt quicktime readline ruby sdl slang spell sse ssl svga tcltk tcpd tetex tiff truetype udev x86 xml xml2 xmms xv zlib"


here's the result from emerge nvidia-kernel:

Calculating dependencies  x86
x86
x86
>>> Unpacking source...
 [32;01m*[0m /usr/src/linux is a symbolic link
 [32;01m*[0m Determining the real directory of the Linux kernel source code
 [32;01m*[0m Building for Linux 2.6.9-ck3 found in /usr/src/linux
Creating directory NVIDIA-Linux-x86-1.0-6629-pkg1
Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86 1.0-6629.........................................................................................................................................................................................................
 [32;01m*[0m Applying conftest_koutput_includes.patch ...
[A[121G  [34;01m[ [32;01mok[34;01m ][0m
 [32;01m*[0m Applying nv-pgd_offset.patch ...
[A[121G  [34;01m[ [32;01mok[34;01m ][0m
 [32;01m*[0m Applying nv-disable-preempt-on-smp_processor_id.patch ...
[A[121G  [34;01m[ [32;01mok[34;01m ][0m
 [32;01m*[0m Applying nv-shutup-warnings.patch ...
[A[121G  [34;01m[ [32;01mok[34;01m ][0m
>>> Source unpacked.
x86
 [32;01m*[0m Using /usr/src/linux as kernel output location


NVIDIA: calling KBUILD...
make CC=cc  KBUILD_VERBOSE=1 -C /usr/src/linux SUBDIRS=/var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv modules
mkdir -p /var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/.tmp_versions
make -f scripts/Makefile.build obj=/var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv
echo \#define NV_COMPILER \"`cc -v 2>&1 | tail -n 1`\" > /var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv_compiler.h
  cc -Wp,-MD,/var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/.nv.o.d -nostdinc -iwithprefix include -D__KERNEL__ -Iinclude  -Wall -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -O2 -fomit-frame-pointer -Wdeclaration-after-statement -pipe -msoft-float -mpreferred-stack-boundary=2 -fno-unit-at-a-time -march=athlon -Iinclude/asm-i386/mach-default -I/var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wno-multichar  -Werror -O -fno-common -MD   -Wno-cast-qual -Wno-error -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE  -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE  -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=6629  -DNV_UNIX   -DNV_LINUX   -DNV_INT64_OK   -DNVCPU_X86      -UDEBUG -U_DEBUG -DNDEBUG -DNV_REMAP_PAGE_RANGE_5 -DNV_CHANGE_PAGE_ATTR_PRESENT -DNV_PCI_DISABLE_DEVICE_PRESENT -DNV_CLASS_SIMPLE_CREATE_PRESENT  -DMODULE -DKBUILD_BASENAME=nv -DKBUILD_MODNAME=nvidia -c -o /var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv.o /var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv.c
  cc -Wp,-MD,/var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/.nv-vm.o.d -nostdinc -iwithprefix include -D__KERNEL__ -Iinclude  -Wall -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -O2 -fomit-frame-pointer -Wdeclaration-after-statement -pipe -msoft-float -mpreferred-stack-boundary=2 -fno-unit-at-a-time -march=athlon -Iinclude/asm-i386/mach-default -I/var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wno-multichar  -Werror -O -fno-common -MD   -Wno-cast-qual -Wno-error -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE  -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE  -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=6629  -DNV_UNIX   -DNV_LINUX   -DNV_INT64_OK   -DNVCPU_X86      -UDEBUG -U_DEBUG -DNDEBUG -DNV_REMAP_PAGE_RANGE_5 -DNV_CHANGE_PAGE_ATTR_PRESENT -DNV_PCI_DISABLE_DEVICE_PRESENT -DNV_CLASS_SIMPLE_CREATE_PRESENT  -DMODULE -DKBUILD_BASENAME=nv_vm -DKBUILD_MODNAME=nvidia -c -o /var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv-vm.o /var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv-vm.c
  cc -Wp,-MD,/var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/.os-agp.o.d -nostdinc -iwithprefix include -D__KERNEL__ -Iinclude  -Wall -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -O2 -fomit-frame-pointer -Wdeclaration-after-statement -pipe -msoft-float -mpreferred-stack-boundary=2 -fno-unit-at-a-time -march=athlon -Iinclude/asm-i386/mach-default -I/var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wno-multichar  -Werror -O -fno-common -MD   -Wno-cast-qual -Wno-error -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE  -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE  -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=6629  -DNV_UNIX   -DNV_LINUX   -DNV_INT64_OK   -DNVCPU_X86      -UDEBUG -U_DEBUG -DNDEBUG -DNV_REMAP_PAGE_RANGE_5 -DNV_CHANGE_PAGE_ATTR_PRESENT -DNV_PCI_DISABLE_DEVICE_PRESENT -DNV_CLASS_SIMPLE_CREATE_PRESENT  -DMODULE -DKBUILD_BASENAME=os_agp -DKBUILD_MODNAME=nvidia -c -o /var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.o /var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.c
  cc -Wp,-MD,/var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/.os-interface.o.d -nostdinc -iwithprefix include -D__KERNEL__ -Iinclude  -Wall -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -O2 -fomit-frame-pointer -Wdeclaration-after-statement -pipe -msoft-float -mpreferred-stack-boundary=2 -fno-unit-at-a-time -march=athlon -Iinclude/asm-i386/mach-default -I/var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wno-multichar  -Werror -O -fno-common -MD   -Wno-cast-qual -Wno-error -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE  -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE  -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=6629  -DNV_UNIX   -DNV_LINUX   -DNV_INT64_OK   -DNVCPU_X86      -UDEBUG -U_DEBUG -DNDEBUG -DNV_REMAP_PAGE_RANGE_5 -DNV_CHANGE_PAGE_ATTR_PRESENT -DNV_PCI_DISABLE_DEVICE_PRESENT -DNV_CLASS_SIMPLE_CREATE_PRESENT  -DMODULE -DKBUILD_BASENAME=os_interface -DKBUILD_MODNAME=nvidia -c -o /var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-interface.o /var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-interface.c
  cc -Wp,-MD,/var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/.os-registry.o.d -nostdinc -iwithprefix include -D__KERNEL__ -Iinclude  -Wall -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -O2 -fomit-frame-pointer -Wdeclaration-after-statement -pipe -msoft-float -mpreferred-stack-boundary=2 -fno-unit-at-a-time -march=athlon -Iinclude/asm-i386/mach-default -I/var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wno-multichar  -Werror -O -fno-common -MD   -Wno-cast-qual -Wno-error -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE  -DNTRM -D_GNU_SOURCE -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE  -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=6629  -DNV_UNIX   -DNV_LINUX   -DNV_INT64_OK   -DNVCPU_X86      -UDEBUG -U_DEBUG -DNDEBUG -DNV_REMAP_PAGE_RANGE_5 -DNV_CHANGE_PAGE_ATTR_PRESENT -DNV_PCI_DISABLE_DEVICE_PRESENT -DNV_CLASS_SIMPLE_CREATE_PRESENT  -DMODULE -DKBUILD_BASENAME=os_registry -DKBUILD_MODNAME=nvidia -c -o /var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-registry.o /var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-registry.c
  ld -m elf_i386  -r -o /var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nvidia.o /var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv-kernel.o /var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv.o /var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nv-vm.o /var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-agp.o /var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-interface.o /var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/os-registry.o
  Building modules, stage 2.
make -rR -f /usr/src/linux-2.6.9-ck3/scripts/Makefile.modpost
  scripts/mod/modpost  -i /usr/src/linux-2.6.9-ck3/Module.symvers vmlinux /var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nvidia.o
  cc -Wp,-MD,/var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/.nvidia.mod.o.d -nostdinc -iwithprefix include -D__KERNEL__ -Iinclude  -Wall -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -O2 -fomit-frame-pointer -Wdeclaration-after-statement -pipe -msoft-float -mpreferred-stack-boundary=2 -fno-unit-at-a-time -march=athlon -Iinclude/asm-i386/mach-default    -DKBUILD_BASENAME=nvidia -DKBUILD_MODNAME=nvidia -DMODULE -c -o /var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nvidia.mod.o /var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nvidia.mod.c
  ld -m elf_i386 -r -o /var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nvidia.ko /var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nvidia.o /var/tmp/portage/nvidia-kernel-1.0.6629/work/NVIDIA-Linux-x86-1.0-6629-pkg1/usr/src/nv/nvidia.mod.o
NVIDIA: left KBUILD.
x86
>>> Test phase [not enabled]: media-video/nvidia-kernel-1.0.6629
x86

>>> Install nvidia-kernel-1.0.6629 into /var/tmp/portage/nvidia-kernel-1.0.6629/image/ category media-video
man:
>>> Completed installing into /var/tmp/portage/nvidia-kernel-1.0.6629/image/

x86
x86

 [32;01m*[0m If you need to load the module automatically on boot up you need
 [32;01m*[0m to add "nvidia" to /etc/modules.autoload.d/kernel-2.6

 [32;01m*[0m This module will now work correctly under udev, you do not need to
 [32;01m*[0m manually create the devices anymore.

 [33;01m*[0m If you are using 2.6.10-r1-(bk|mm)[0-9]*, please note that you might have
 [33;01m*[0m to disable the kernel agp driver, and use NVAGP instead, as there are some
 [33;01m*[0m unresolved issues with some kernel agp drivers ...

 [32;01m*[0m Checking kernel module dependencies
 [32;01m*[0m Caching service dependencies ...
[A[121G  [34;01m[ [32;01mok[34;01m ][0m
x86
  ...done!
>>> emerge (1 of 1) media-video/nvidia-kernel-1.0.6629 to /
>>> md5 src_uri ;-) NVIDIA-Linux-x86-1.0-6629-pkg1.run
>>> Merging media-video/nvidia-kernel-1.0.6629 to /
--- /etc/
--- /etc/modules.d/
>>> /etc/modules.d/nvidia
--- /lib/
--- /lib/modules/
--- /lib/modules/2.6.9-ck3/
--- /lib/modules/2.6.9-ck3/video/
>>> /lib/modules/2.6.9-ck3/video/nvidia.ko
--- /usr/
--- /usr/share/
--- /usr/share/doc/
>>> /usr/share/doc/nvidia-kernel-1.0.6629/
>>> /usr/share/doc/nvidia-kernel-1.0.6629/README.gz
--- /sbin/
>>> /sbin/NVmakedevices.sh
>>> media-video/nvidia-kernel-1.0.6629 merged.
>>> Recording media-video/nvidia-kernel in "world" favorites file...

>>> clean: No packages selected for removal.

>>> Auto-cleaning packages ...

>>> No outdated packages were found on your system.


 * GNU info directory index is up-to-date.

Hope that helps.
Comment 7 Martin Schlemmer (RETIRED) gentoo-dev 2004-11-14 11:14:02 UTC
Do you have:

-----
$ ls /dev/nvidia*
/dev/nvidia  /dev/nvidia0  /dev/nvidiactl
-----

Comment 8 Andrew Bevitt 2004-11-14 15:25:54 UTC
Can we have Xorg.0.log and xorg.conf attached aswell please.
Comment 9 Doug McMillan 2004-11-14 18:09:34 UTC
I have what looks to be the same issue, have not tried the nvidia kernel.
I am on an amd64 and have keywords amd64 ~amd64
I am running a nptl, udev, hal, ivman
lsmod shows 
....
nvidia   4047452  0
....

$ ls /dev/nvidia* 
/dev/nvidia0  /dev/nvidiactl

no /dev/nvidia  showing
Comment 10 Doug McMillan 2004-11-14 18:14:16 UTC
I have what looks to be the same issue, have not tried the nvidia kernel.
I am on an amd64 and have keywords amd64 ~amd64
I am running a nptl, udev, hal, ivman
lsmod shows 
....
nvidia   4047452  0
....

$ ls /dev/nvidia* 
/dev/nvidia0  /dev/nvidiactl

no /dev/nvidia  showing
Comment 11 Doug McMillan 2004-11-14 18:16:44 UTC
Weird sorry for the double post
Comment 12 Doug McMillan 2004-11-14 20:04:18 UTC
Created attachment 43965 [details]
log of startx
Comment 13 Doug McMillan 2004-11-14 20:05:15 UTC
Created attachment 43966 [details]
xorg.conf
Comment 14 Doug McMillan 2004-11-14 20:09:42 UTC
Went to log when examining it i fouind something previously missed as I was only looking at the nvidia I missed that glx wasn't working switched back to xorg-x11 reisntalled nvidia-glx then opengl-update nvidia that seemed to get me further in here is where I got to
Comment 15 George Kraev 2004-11-14 21:28:20 UTC
My motherboard died and currently I am firced to work on another computer. So untill I sort this situation out I can't post any log files or anythign else like that. However, as far as the xorg.config file goes there is nothing wrong with it because Xorg starts just fine when I use the binary Nvidia release of the drivers instead of the ebuild (like I said). It is very possible that one of the devices does not get created for whever reason. However, the problem with this is that xorg would then quit saying that a device is missing and instead the error is that the module could not be loaded. Anyway, I will get some of the old hardware together and give it another shot and then post the log files. Meanwhile I have to deal with all the isues that come from using a radeon board kernel 2.6 and the ati-drivers which are compatible with nothing ...
Comment 16 George Kraev 2004-12-17 16:39:51 UTC
If anybody wants to deal with this in the future they are welcome to reopen the bug. For now though, I am closing the bug. 
Comment 17 Rémi Cardona gentoo-dev 2009-08-20 11:57:48 UTC
reopening
Comment 18 Rémi Cardona gentoo-dev 2009-08-20 11:58:03 UTC
Closing with the proper resolution.