Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 706818 - app-accessibility/speech-dispatcher-0.8.7-r3 : fails to build with -fno-common or gcc-10
Summary: app-accessibility/speech-dispatcher-0.8.7-r3 : fails to build with -fno-commo...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: William Hubbs
URL: https://github.com/brailcom/speechd/c...
Whiteboard:
Keywords: PATCH, UPSTREAM
: 728346 (view as bug list)
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-01-28 18:15 UTC by Toralf Förster
Modified: 2020-07-14 20:37 UTC (History)
17 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,14.95 KB, text/plain)
2020-01-28 18:15 UTC, Toralf Förster
Details
app-accessibility:speech-dispatcher-0.8.7-r3:20200127-213325.log (app-accessibility:speech-dispatcher-0.8.7-r3:20200127-213325.log,115.43 KB, text/plain)
2020-01-28 18:15 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,59.75 KB, text/plain)
2020-01-28 18:15 UTC, Toralf Förster
Details
environment (environment,97.68 KB, text/plain)
2020-01-28 18:15 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,12.38 KB, application/x-bzip)
2020-01-28 18:15 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,13.68 KB, application/x-bzip)
2020-01-28 18:15 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,26.89 KB, application/x-bzip)
2020-01-28 18:15 UTC, Toralf Förster
Details
speech-dispatcher-0.8.7-fno-common.patch (speech-dispatcher-0.8.7-fno-common.patch,10.11 KB, patch)
2020-05-26 03:49 UTC, Peter Levine
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-01-28 18:15:09 UTC
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../..  -I../../include/  -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include  -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include  -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include  -DSYS_CONF=\"/etc/speech-dispatcher\" -DSND_DATA=\"/usr/share/sounds/speech-dispatcher\" -DMODULEBINDIR=\"/usr/lib64/speech-dispatcher-modules\" -D_GNU_SOURCE -DDEFAULT_AUDIO_METHOD=\"oss\"  -Wall -O2 -pipe -march=native -fno-common -c -o speech_dispatcher-sem_functions.o `test -f 'sem_functions.c' || echo './'`sem_functions.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../..  -I../../include/  -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include  -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include  -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include  -DSYS_CONF=\"/etc/speech-dispatcher\" -DSND_DATA=\"/usr/share/sounds/speech-dispatcher\" -DMODULEBINDIR=\"/usr/lib64/speech-dispatcher-modules\" -D_GNU_SOURCE -DDEFAULT_AUDIO_METHOD=\"oss\"  -Wall -O2 -pipe -march=native -fno-common -c -o speech_dispatcher-index_marking.o `test -f 'index_marking.c' || echo './'`index_marking.c
/bin/sh ../../libtool  --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc -Wall -O2 -pipe -march=native -fno-common -rdynamic -Wl,-O1 -Wl,--as-needed -o speech-dispatcher speech_dispatcher-speechd.o speech_dispatcher-server.o speech_dispatcher-history.o speech_dispatcher-module.o speech_dispatcher-configuration.o speech_dispatcher-parse.o speech_dispatcher-set.o speech_dispatcher-alloc.o speech_dispatcher-compare.o speech_dispatcher-speaking.o speech_dispatcher-options.o speech_dispatcher-output.o speech_dispatcher-sem_functions.o speech_dispatcher-index_marking.o ../../src/common/libcommon.la -ldotconf  -lglib-2.0  -Wl,--export-dynamic -lgmodule-2.0 -pthread -lglib-2.0 -lglib-2.0  -lgthread-2.0 -pthread -lglib-2.0   -lltdl -lpthread -lm 
libtool: link: x86_64-pc-linux-gnu-gcc -Wall -O2 -pipe -march=native -fno-common -rdynamic -Wl,-O1 -Wl,--as-needed -o speech-dispatcher speech_dispatcher-speechd.o speech_dispatcher-server.o speech_dispatcher-history.o speech_dispatcher-module.o speech_dispatcher-configuration.o speech_dispatcher-parse.o speech_dispatcher-set.o speech_dispatcher-alloc.o speech_dispatcher-compare.o speech_dispatcher-speaking.o speech_dispatcher-options.o speech_dispatcher-output.o speech_dispatcher-sem_functions.o speech_dispatcher-index_marking.o -Wl,--export-dynamic -pthread -pthread  ../../src/common/.libs/libcommon.a //usr/lib64/libdotconf.so -lgmodule-2.0 -lgthread-2.0 -lglib-2.0 //usr/lib64/libltdl.so -ldl -lpthread -lm -pthread -Wl,-rpath -Wl,//usr/lib64
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: speech_dispatcher-server.o:(.bss+0x1c0): multiple definition of `element_free_mutex'; speech_dispatcher-speechd.o:(.bss+0x1e0): first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: speech_dispatcher-server.o:(.bss+0x120): multiple definition of `MessageQueue'; speech_dispatcher-speechd.o:(.bss+0x140): first defined here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_systemd-20200126-201521

  -------------------------------------------------------------------

  Please see the tracker bug for details.

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.2.0 *


llvm:
9.0.1
Available Python interpreters, in order of preference:
  [1]   python3.8
  [2]   python3.6
  [3]   python3.7 (fallback)
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *




repository:
==> /var/db/repos/gentoo/metadata/timestamp.chk <==
Mon, 27 Jan 2020 20:26:17 +0000

emerge -qpvO app-accessibility/speech-dispatcher
[ebuild  N    ] app-accessibility/speech-dispatcher-0.8.7-r3  USE="espeak -alsa -ao -flite -nas -pulseaudio -python" PYTHON_TARGETS="python3_6 -python3_7"
Comment 1 Toralf Förster gentoo-dev 2020-01-28 18:15:12 UTC
Created attachment 605914 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-01-28 18:15:16 UTC
Created attachment 605916 [details]
app-accessibility:speech-dispatcher-0.8.7-r3:20200127-213325.log
Comment 3 Toralf Förster gentoo-dev 2020-01-28 18:15:19 UTC
Created attachment 605918 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2020-01-28 18:15:21 UTC
Created attachment 605920 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2020-01-28 18:15:24 UTC
Created attachment 605922 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-01-28 18:15:27 UTC
Created attachment 605924 [details]
logs.tbz2
Comment 7 Toralf Förster gentoo-dev 2020-01-28 18:15:30 UTC
Created attachment 605926 [details]
temp.tbz2
Comment 8 Peter Levine 2020-05-26 03:49:37 UTC
Created attachment 641802 [details, diff]
speech-dispatcher-0.8.7-fno-common.patch

Backported from https://github.com/brailcom/speechd/commit/f1c01ccc0ca3f82313ebff3f336d808acee225c8
Comment 9 Silvio 2020-06-01 21:58:13 UTC
(In reply to Peter Levine from comment #8)
> Created attachment 641802 [details, diff] [details, diff]
> speech-dispatcher-0.8.7-fno-common.patch
> 
> Backported from
> https://github.com/brailcom/speechd/commit/
> f1c01ccc0ca3f82313ebff3f336d808acee225c8

works for me
Comment 10 Artemii 2020-06-08 21:17:44 UTC
(In reply to Peter Levine from comment #8)
> Created attachment 641802 [details, diff] [details, diff]
> speech-dispatcher-0.8.7-fno-common.patch
> 
> Backported from
> https://github.com/brailcom/speechd/commit/
> f1c01ccc0ca3f82313ebff3f336d808acee225c8

works for me too
Comment 11 Glen 2020-06-09 10:05:48 UTC
Also works for me. (~AMD64)
Comment 12 Jeroen Roovers gentoo-dev 2020-06-15 10:12:52 UTC
*** Bug 728346 has been marked as a duplicate of this bug. ***
Comment 13 Jeroen Roovers gentoo-dev 2020-06-15 10:21:37 UTC
This landed in 0.10.0_rc2. Compare bug #719014.
Comment 14 Larry the Git Cow gentoo-dev 2020-07-13 00:30:39 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d1c2c0c2580643616e30dd44485d7a19a6d284f5

commit d1c2c0c2580643616e30dd44485d7a19a6d284f5
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2020-07-10 16:56:59 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2020-07-13 00:29:08 +0000

    app-accessibility/speech-dispatcher: 0.9.1 version bump
    
    Bug: https://bugs.gentoo.org/719014
    Closes: https://bugs.gentoo.org/706818
    Package-Manager: Portage-2.3.103, Repoman-2.3.23
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 app-accessibility/speech-dispatcher/Manifest       |   1 +
 .../files/speech-dispatcher-0.9.1-fno-common.patch | 466 +++++++++++++++++++++
 .../speech-dispatcher-0.9.1.ebuild                 | 116 +++++
 3 files changed, 583 insertions(+)