Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 706396 - www-servers/gatling-0.15 : fails to build with -fno-common or gcc-10
Summary: www-servers/gatling-0.15 : fails to build with -fno-common or gcc-10
Status: RESOLVED DUPLICATE of bug 756847
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Patrick Lauer
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-01-26 08:29 UTC by Toralf Förster
Modified: 2020-11-27 06:19 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,14.92 KB, text/plain)
2020-01-26 08:29 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,76.82 KB, text/plain)
2020-01-26 08:29 UTC, Toralf Förster
Details
environment (environment,93.15 KB, text/plain)
2020-01-26 08:29 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,11.71 KB, application/x-bzip)
2020-01-26 08:29 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,22.99 KB, application/x-bzip)
2020-01-26 08:29 UTC, Toralf Förster
Details
www-servers:gatling-0.15:20200126-072616.log (www-servers:gatling-0.15:20200126-072616.log,13.20 KB, text/plain)
2020-01-26 08:30 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-01-26 08:29:43 UTC
if  x86_64-pc-linux-gnu-gcc -O2 -pipe -march=native -fno-common -I/usr/include/libowfat -o trycrypt trycrypt.c -lcrypt >/dev/null 2>&1; then echo "-lcrypt"; \
fi; fi > libcrypt
rm -f trycrypt
x86_64-pc-linux-gnu-gcc -Wl,-O1 -Wl,--as-needed gatling.o mime.o ftp.o http.o smb.o common.o connstat.o httpstream.o dirfd.o -o gatling -lowfat -lz `cat libsocket libiconv libcrypt` `cat md5lib`
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: http.o:(.bss+0x2090): multiple definition of `ifd'; gatling.o:(.bss+0x580): first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: common.o:(.bss+0x0): multiple definition of `ifd'; gatling.o:(.bss+0x580): first defined here

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_no-multilib-20200124-204141

  -------------------------------------------------------------------

  Please see the tracker bug for details.

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.2.0 *


llvm:
9.0.1
Available Python interpreters, in order of preference:
  [1]   python3.7
  [2]   python3.6
  [3]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.40.0 *



repository:
==> /var/db/repos/gentoo/metadata/timestamp.chk <==
Sun, 26 Jan 2020 07:06:11 +0000

emerge -qpvO www-servers/gatling
[ebuild  N    ] www-servers/gatling-0.15  USE="ssl -diet -libressl"
Comment 1 Toralf Förster gentoo-dev 2020-01-26 08:29:46 UTC
Created attachment 604484 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-01-26 08:29:49 UTC
Created attachment 604486 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-01-26 08:29:51 UTC
Created attachment 604488 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-01-26 08:29:54 UTC
Created attachment 604490 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-01-26 08:29:57 UTC
Created attachment 604492 [details]
temp.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-01-26 08:30:00 UTC
Created attachment 604494 [details]
www-servers:gatling-0.15:20200126-072616.log
Comment 7 Sebastian Pipping gentoo-dev 2020-01-26 13:41:37 UTC
If gcc -no-common is default with gcc 10, maybe we should have a chat with upstream how to best deal with that in a way they support.
Comment 8 Sam James archtester gentoo-dev Security 2020-10-31 04:49:58 UTC
(In reply to Sebastian Pipping from comment #7)
> If gcc -no-common is default with gcc 10, maybe we should have a chat with
> upstream how to best deal with that in a way they support.

Yes please.
Comment 9 Sebastian Pipping gentoo-dev 2020-11-03 10:27:06 UTC
I e-mailed upstream about it just now.
Comment 10 Larry the Git Cow gentoo-dev 2020-11-26 15:13:47 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c00abe05e686dff46288a9ae7c887d92b93c3cef

commit c00abe05e686dff46288a9ae7c887d92b93c3cef
Author:     Sebastian Pipping <sping@gentoo.org>
AuthorDate: 2020-11-26 15:10:25 +0000
Commit:     Sebastian Pipping <sping@gentoo.org>
CommitDate: 2020-11-26 15:13:14 +0000

    www-servers/gatling: Fix compile for GCC 10
    
    Closes: https://bugs.gentoo.org/706396
    Signed-off-by: Sebastian Pipping <sping@gentoo.org>
    Package-Manager: Portage-3.0.0, Repoman-2.3.23

 www-servers/gatling/files/gatling-0.15-gcc10.patch | 38 ++++++++++++++++++++++
 www-servers/gatling/gatling-0.15.ebuild            |  3 +-
 2 files changed, 40 insertions(+), 1 deletion(-)
Comment 11 Joonas Niilola gentoo-dev 2020-11-27 05:56:54 UTC
This still fails to me, with both gcc-9 AND gcc-10. 

x86_64-pc-linux-gnu-gcc -Wl,-O1 -Wl,--as-needed -Wl,--defsym=__gentoo_check_ldflags__=0 gatling.o mime.o ftp.o http.o smb.o common.o connstat.o httpstream.o dirfd.o -o gatling -lowfat -lz `cat libsocket libiconv libcrypt` `cat md5lib`
/usr/lib/gcc/x86_64-pc-linux-gnu/10.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/10.2.0/../../../../lib64/libowfat.a(io_fd.o):(.bss+0xb0): multiple definition of `first_deferred'; /usr/lib/gcc/x86_64-pc-linux-gnu/10.2.0/../../../../lib64/libowfat.a(io_close.o):(.data+0x0): first defined here
collect2: error: ld returned 1 exit status
make: *** [GNUmakefile:99: gatling] Error 1
make: *** Waiting for unfinished jobs....

/usr/lib/gcc/x86_64-pc-linux-gnu/10.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/10.2.0/../../../../lib64/libowfat.a(io_fd.o):(.bss+0xb0): multiple definition of `first_deferred'; /usr/lib/gcc/x86_64-pc-linux-gnu/10.2.0/../../../../lib64/libowfat.a(io_close.o):(.data+0x0): first defined here
collect2: error: ld returned 1 exit status
make: *** [GNUmakefile:87: tlsgatling] Error 1
 * ERROR: www-servers/gatling-0.15::gentoo failed (compile phase):
 *   emake failed

Patch does get applied, 
 * Applying gatling-0.13-compile.patch ...                                                   [ ok ]
 * Applying gatling-0.15-gcc10.patch ...                                                     [ ok ]
Comment 12 Joonas Niilola gentoo-dev 2020-11-27 06:19:29 UTC

*** This bug has been marked as a duplicate of bug 756847 ***