Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 706378 - dev-lang/lua-5.1.5-r5 doesn't install .so symlink
Summary: dev-lang/lua-5.1.5-r5 doesn't install .so symlink
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: William Hubbs
URL:
Whiteboard:
Keywords:
: 706254 706334 (view as bug list)
Depends on:
Blocks: 706492 706540
  Show dependency tree
 
Reported: 2020-01-26 00:05 UTC by Michael Cook
Modified: 2020-01-27 17:42 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Cook 2020-01-26 00:05:53 UTC
Commit message doesn't mention it going away, and downgrading to -r4 gives me it back.

Specifically it's missing /usr/lib64/liblua.so one without a version. Maybe someone is working on eselect-lua? Either way, that's clearly not ready and this breaks things for me.

Specifically a project is using a fairly standard cmake script to include lua, which ends up returning /usr/lib64/liblua.so, even though it's not installed

Reproducible: Always
Comment 1 Sergei Trofimovich gentoo-dev 2020-01-27 07:44:43 UTC
*** Bug 706254 has been marked as a duplicate of this bug. ***
Comment 2 Sergei Trofimovich gentoo-dev 2020-01-27 07:45:32 UTC
*** Bug 706334 has been marked as a duplicate of this bug. ***