Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 706298 - sys-apps/portage: Suppress /etc/portage/package.keywords warning for API consumers
Summary: sys-apps/portage: Suppress /etc/portage/package.keywords warning for API cons...
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Configuration (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks: 607852 706142
  Show dependency tree
 
Reported: 2020-01-25 12:19 UTC by Jeroen Roovers
Modified: 2020-09-06 16:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Roovers gentoo-dev 2020-01-25 12:19:41 UTC
When for temporary compatibility with existing tooling user_kwrds_path is a symlink to user_accept_kwrds_path, KeywordsManager.py should not emit a deprecation warning. The problem is known and has been temporarily resolved locally, and comparing two strings does not prevent the deprecation spam this causes in many cases where the importance of the migration for local system administration is not relevant, e.g. when running eshowkw from app-portage/gentoolkit.
Comment 1 Zac Medico gentoo-dev 2020-01-25 21:07:18 UTC
We can suppress the warning for API consumers like eshowkw since there's a portage._internal_caller variable that's useful for things like this.

I'm afraid to disable the warning based on a condition like the symlink since that could easily hide the issue. We really want to force things to migrate since that will allow us to eventually change the meaning of /etc/portage/package.keywords so that it matches the meaning in profiles (useful for local stabilization of packages as discussed in bug 491166).
Comment 2 Larry the Git Cow gentoo-dev 2020-01-28 05:03:59 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/proj/portage.git/commit/?id=af5b57ee4d3133d9a8ca2c16aa21b7176026c8cd

commit af5b57ee4d3133d9a8ca2c16aa21b7176026c8cd
Author:     Zac Medico <zmedico@gentoo.org>
AuthorDate: 2020-01-28 05:01:27 +0000
Commit:     Zac Medico <zmedico@gentoo.org>
CommitDate: 2020-01-28 05:02:36 +0000

    Suppress /etc/portage/package.keywords warning for API consumers
    
    Suggested-by: Jeroen Roovers <jer@gentoo.org>
    Bug: https://bugs.gentoo.org/706298
    Signed-off-by: Zac Medico <zmedico@gentoo.org>

 lib/portage/package/ebuild/_config/KeywordsManager.py | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)
Comment 3 Larry the Git Cow gentoo-dev 2020-01-28 05:23:22 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=34b349600f178ed252c125866c3c3fd731cfb2f4

commit 34b349600f178ed252c125866c3c3fd731cfb2f4
Author:     Zac Medico <zmedico@gentoo.org>
AuthorDate: 2020-01-28 05:18:53 +0000
Commit:     Zac Medico <zmedico@gentoo.org>
CommitDate: 2020-01-28 05:19:09 +0000

    sys-apps/portage: Bump to version 2.3.86
    
     #706278 Adjust || preference for slot upgrades
     #706298 Suppress package.keywords warning for API consumers
    
    Bug: https://bugs.gentoo.org/706142
    Bug: https://bugs.gentoo.org/480736
    Bug: https://bugs.gentoo.org/706278
    Bug: https://bugs.gentoo.org/706298
    Package-Manager: Portage-2.3.86, Repoman-2.3.20
    Signed-off-by: Zac Medico <zmedico@gentoo.org>

 sys-apps/portage/Manifest              |   1 +
 sys-apps/portage/portage-2.3.86.ebuild | 276 +++++++++++++++++++++++++++++++++
 2 files changed, 277 insertions(+)
Comment 4 Jeroen Roovers gentoo-dev 2020-01-28 09:48:31 UTC
(In reply to Zac Medico from comment #1)
> We can suppress the warning for API consumers like eshowkw since there's a
> portage._internal_caller variable that's useful for things like this.
> 
> I'm afraid to disable the warning based on a condition like the symlink
> since that could easily hide the issue. We really want to force things to
> migrate since that will allow us to eventually change the meaning of
> /etc/portage/package.keywords so that it matches the meaning in profiles
> (useful for local stabilization of packages as discussed in bug 491166).

Fair enough. Thanks.