Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 706126 - net-proxy/squid-4.9 : configure: error: Basic auth helper NIS found but cannot be built
Summary: net-proxy/squid-4.9 : configure: error: Basic auth helper NIS found but cann...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mikle Kolyada
URL:
Whiteboard:
Keywords:
: 871675 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-01-22 21:12 UTC by Toralf Förster
Modified: 2022-09-29 02:17 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.69 KB, text/plain)
2020-01-22 21:13 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,129.42 KB, text/plain)
2020-01-22 21:13 UTC, Toralf Förster
Details
environment (environment,126.08 KB, text/plain)
2020-01-22 21:13 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,13.44 KB, application/x-bzip)
2020-01-22 21:13 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,22.35 KB, application/x-bzip)
2020-01-22 21:13 UTC, Toralf Förster
Details
net-proxy:squid-4.9:20200122-210708.log (net-proxy:squid-4.9:20200122-210708.log,23.33 KB, text/plain)
2020-01-22 21:13 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,36.08 KB, application/x-bzip)
2020-01-22 21:13 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-01-22 21:12:57 UTC
checking for rpcsvc/yp_prot.h... no
checking for crypt.h... (cached) yes
configure: error: Basic auth helper NIS ... found but cannot be built

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/net-proxy/squid-4.9/work/squid-4.9/config.log

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_hardened-libressl-20200120-133340

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.2.0 *

clang:
clang version 9.0.1 
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/9/bin
llvm:
9.0.1
Available Python interpreters, in order of preference:
  [1]   python3.8
  [2]   python3.6
  [3]   python3.7 (fallback)
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *

java-config:
The following VMs are available for generation-2:
1)	AdoptOpenJDK 8.242_p08 [openjdk-bin-8]
*)	AdoptOpenJDK JRE 8.242_p08 [openjdk-jre-bin-8]
Available Java Virtual Machines:
  [1]   openjdk-bin-8 
  [2]   openjdk-jre-bin-8  system-vm

repository:
==> /var/db/repos/gentoo/metadata/timestamp.chk <==
Wed, 22 Jan 2020 19:46:07 +0000

emerge -qpvO net-proxy/squid
[ebuild  N    ] net-proxy/squid-4.9  USE="htcp ipv6 libressl nis pam ssl wccp wccpv2 -caps -ecap -esi -gnutls (-ipf-transparent) -kerberos (-kqueue) -ldap -logrotate -mysql -perl (-pf-transparent) -postgres -qos -radius -samba -sasl (-selinux) -snmp -sqlite -ssl-crtd -test -tproxy"
Comment 1 Toralf Förster gentoo-dev 2020-01-22 21:13:00 UTC
Created attachment 604006 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-01-22 21:13:03 UTC
Created attachment 604008 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2020-01-22 21:13:06 UTC
Created attachment 604010 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2020-01-22 21:13:09 UTC
Created attachment 604012 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2020-01-22 21:13:12 UTC
Created attachment 604014 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-01-22 21:13:14 UTC
Created attachment 604016 [details]
net-proxy:squid-4.9:20200122-210708.log
Comment 7 Toralf Förster gentoo-dev 2020-01-22 21:13:17 UTC
Created attachment 604018 [details]
temp.tbz2
Comment 8 Jeremy Stent 2022-01-07 00:52:01 UTC
This normally happens for me because the <rpc/rpc.h> include file is in the "wrong" place.  I do not know if that is because of split rpc, or why.  Adding:
CPPFLAGS=" -I/usr/include/tirpc"
to make.conf or somewhere similar normally fixes it.
Comment 9 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-09-28 00:39:26 UTC
*** Bug 871675 has been marked as a duplicate of this bug. ***
Comment 10 Larry the Git Cow gentoo-dev 2022-09-29 02:14:59 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=69e685162ba2ccf86cf04e7ba544718bc9ae41d4

commit 69e685162ba2ccf86cf04e7ba544718bc9ae41d4
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2022-09-24 06:19:24 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2022-09-29 02:14:37 +0000

    net-proxy/squid: add 5.7
    
    Bug: https://bugs.gentoo.org/858845
    Bug: https://bugs.gentoo.org/872551
    Closes: https://bugs.gentoo.org/706126
    Closes: https://bugs.gentoo.org/869968
    Signed-off-by: Sam James <sam@gentoo.org>

 net-proxy/squid/Manifest         |   1 +
 net-proxy/squid/squid-5.7.ebuild | 362 +++++++++++++++++++++++++++++++++++++++
 2 files changed, 363 insertions(+)