Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 706072 - dev-lang/perl-5.30.1::gentoo failed (compile phase) during stage 3
Summary: dev-lang/perl-5.30.1::gentoo failed (compile phase) during stage 3
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: Prefix Support (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Prefix
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-22 08:22 UTC by Alexey
Modified: 2021-01-18 20:08 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,124.60 KB, text/x-log)
2020-01-22 08:22 UTC, Alexey
Details
stage3-1000.log (stage3-1000.log,94.22 KB, text/x-log)
2020-01-23 00:54 UTC, Alexey
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey 2020-01-22 08:22:18 UTC
Created attachment 603938 [details]
build.log

/home/user/gentoo/bin/pwd: cannot open directory '../../../../../../../../../../..': Permission denied
Can't figure out your cwd! at /home/user/gentoo/var/tmp/portage/dev-lang/perl-5.30.1/work/perl-5.30.1/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MakeMaker.pm line 237.
Unsuccessful Makefile.PL(cpan/Encode): code=256 at make_ext.pl line 518.
make: *** [makefile:575: lib/auto/Encode/Encode.so] Error 2
Comment 1 Alexey 2020-01-23 00:54:53 UTC
Created attachment 604030 [details]
stage3-1000.log
Comment 2 Alexey 2020-01-23 20:40:10 UTC
user@host:~$ ls -lad / /home ~ ~/gentoo
drwxr-xr-x 69 root root 4096 Jul 25  2019 /
drw---x--x  5 root root 4096 Nov 10 11:35 /home
drwx------ 14 user user 4096 Jan 23 01:52 /home/user
drwxrwxr-x 10 user user 4096 Jan 22 09:19 /home/user/gentoo
Comment 3 Benda Xu gentoo-dev 2020-01-25 11:26:52 UTC
Hi Alexey,

(In reply to Alexey from comment #0)
> Created attachment 603938 [details]
> build.log
> 
> /home/user/gentoo/bin/pwd: cannot open directory
> '../../../../../../../../../../..': Permission denied
> Can't figure out your cwd! at
> /home/user/gentoo/var/tmp/portage/dev-lang/perl-5.30.1/work/perl-5.30.1/cpan/
> ExtUtils-MakeMaker/lib/ExtUtils/MakeMaker.pm line 237.
> Unsuccessful Makefile.PL(cpan/Encode): code=256 at make_ext.pl line 518.
> make: *** [makefile:575: lib/auto/Encode/Encode.so] Error 2

Welcome to Prefix and thank you for trying it out!

To help me understand this bug, could you please post the key factors of your environment for me to reproduce?  For example, your GNU/Linux distribution by the output of

  lsb_release -a

your filesystem mount options by,

  mount

and your glibc, gcc, binutils versions by,

  ldd --version
  gcc --version
  ld --version

Thanks!
Comment 4 Alexey 2020-01-25 14:37:24 UTC
Hi

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.6 LTS
Release:        16.04
Codename:       xenial

ldd (Ubuntu GLIBC 2.23-0ubuntu11) 2.23
gcc (Ubuntu 5.4.0-6ubuntu1~16.04.11) 5.4.0 20160609
GNU ld (GNU Binutils for Ubuntu) 2.26.1

sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime,hidepid=2)
udev on /dev type devtmpfs (rw,nosuid,relatime,size=132030824k,nr_inodes=33007706,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=26411080k,mode=755)
/dev/md0 on / type ext4 (rw,relatime,errors=remount-ro,data=ordered)
none on /sys/fs/cgroup type tmpfs (rw,relatime,size=4k,mode=755)
none on /sys/fs/fuse/connections type fusectl (rw,relatime)
none on /sys/kernel/debug type debugfs (rw,relatime)
none on /sys/kernel/security type securityfs (rw,relatime)
cgmfs on /run/cgmanager/fs type tmpfs (rw,relatime,size=100k,mode=755)
none on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
none on /run/shm type tmpfs (rw,nosuid,nodev,relatime)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,relatime,cpuset,release_agent=/run/cgmanager/agents/cgm-release-agent.cpuset,clone_children)
none on /run/user type tmpfs (rw,nosuid,nodev,noexec,relatime,size=102400k,mode=755)
none on /sys/fs/pstore type pstore (rw,relatime)
cgroup on /sys/fs/cgroup/cpu type cgroup (rw,relatime,cpu,release_agent=/run/cgmanager/agents/cgm-release-agent.cpu)
cgroup on /sys/fs/cgroup/cpuacct type cgroup (rw,relatime,cpuacct,release_agent=/run/cgmanager/agents/cgm-release-agent.cpuacct)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,relatime,blkio,release_agent=/run/cgmanager/agents/cgm-release-agent.blkio)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,relatime,devices,release_agent=/run/cgmanager/agents/cgm-release-agent.devices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,relatime,freezer,release_agent=/run/cgmanager/agents/cgm-release-agent.freezer)
cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,relatime,net_cls,release_agent=/run/cgmanager/agents/cgm-release-agent.net_cls)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,relatime,perf_event,release_agent=/run/cgmanager/agents/cgm-release-agent.perf_event)
cgroup on /sys/fs/cgroup/net_prio type cgroup (rw,relatime,net_prio,release_agent=/run/cgmanager/agents/cgm-release-agent.net_prio)
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,relatime,hugetlb,release_agent=/run/cgmanager/agents/cgm-release-agent.hugetlb)
cgroup on /sys/fs/cgroup/pids type cgroup (rw,relatime,pids,release_agent=/run/cgmanager/agents/cgm-release-agent.pids)
name=systemd on /sys/fs/cgroup/systemd type cgroup (rw,relatime,release_agent=/run/cgmanager/agents/cgm-release-agent.systemd,name=systemd)
/dev/sda1 on /home type ext4 (rw,noatime,nodiratime,block_validity,delalloc,user_xattr,acl,quota,usrquota)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,nosuid,nodev,noexec,relatime)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=26411080k,mode=700,uid=1000,gid=1000)
Comment 5 Benda Xu gentoo-dev 2020-01-27 00:35:59 UTC
$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.6 LTS
Release:        16.04
Codename:       xenial

I cannot reproduce this bug with my setup of Ubuntu 16.04, there might be some other causes we are not aware of.

Does the same error message appear when you run the bootstrap script again?
Comment 6 Benda Xu gentoo-dev 2020-01-27 00:54:56 UTC
Plus, change a location to install, for example: /opt/gentoo, /tmp/gentoo, etc.
Comment 7 Alexey 2020-01-27 01:01:38 UTC
Rerunning it didn't help, even with -j1 (via answering the question about number)

Trying a different path now.

Did you set your /home and /home/user permissions the same way?
Comment 8 Benda Xu gentoo-dev 2020-01-27 05:50:32 UTC
(In reply to Alexey from comment #7)
> Rerunning it didn't help, even with -j1 (via answering the question about
> number)
> 
> Trying a different path now.
> 
> Did you set your /home and /home/user permissions the same way?

Try another directory.  Otherwise I am not of ideas.
Comment 9 Michael Haubenwallner gentoo-dev 2020-01-27 07:25:26 UTC
(In reply to Alexey from comment #0)
> /home/user/gentoo/bin/pwd: cannot open directory
> '../../../../../../../../../../..': Permission denied

Feels like this error message is caused by ...

(In reply to Alexey from comment #2)
> user@host:~$ ls -lad / /home ~ ~/gentoo
> drwxr-xr-x 69 root root 4096 Jul 25  2019 /
> drw---x--x  5 root root 4096 Nov 10 11:35 /home

... 'user' not having read permission on /home.

> drwx------ 14 user user 4096 Jan 23 01:52 /home/user
> drwxrwxr-x 10 user user 4096 Jan 22 09:19 /home/user/gentoo
Comment 10 Alexey 2020-01-27 08:08:31 UTC
The other path worked.
Comment 11 Benda Xu gentoo-dev 2020-01-27 09:17:07 UTC
(In reply to Alexey from comment #10)
> The other path worked.

(In reply to Michael Haubenwallner from comment #9)
> (In reply to Alexey from comment #0)
> > /home/user/gentoo/bin/pwd: cannot open directory
> > '../../../../../../../../../../..': Permission denied
> 
> Feels like this error message is caused by ...
> 
> (In reply to Alexey from comment #2)
> > user@host:~$ ls -lad / /home ~ ~/gentoo
> > drwxr-xr-x 69 root root 4096 Jul 25  2019 /
> > drw---x--x  5 root root 4096 Nov 10 11:35 /home
> 
> ... 'user' not having read permission on /home.
> 
> > drwx------ 14 user user 4096 Jan 23 01:52 /home/user
> > drwxrwxr-x 10 user user 4096 Jan 22 09:19 /home/user/gentoo

Very nice, we solved the mystery. Thanks all.
Comment 12 Alexey 2020-01-27 10:56:56 UTC
Hi Benda, can the build be fixed to not rely on access to all parent directories?

While this workaround "works", it's far from a great solution. I'd need to reinstall Prefix after every reboot, since the other path is in tmpfs.
Comment 13 Fabian Groffen gentoo-dev 2021-01-18 20:08:27 UTC
we have no means to work around permission bits with Prefix