Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 705880 - =x11-base/xorg-server-1.20.7 fails to build with -fno-common or gcc-10
Summary: =x11-base/xorg-server-1.20.7 fails to build with -fno-common or gcc-10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL: https://gitlab.freedesktop.org/xorg/x...
Whiteboard:
Keywords:
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-01-19 20:06 UTC by Sergei Trofimovich
Modified: 2020-03-19 21:50 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.bz2 (build.log.bz2,27.86 KB, application/x-bzip)
2020-01-19 20:07 UTC, Sergei Trofimovich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sergei Trofimovich gentoo-dev 2020-01-19 20:06:04 UTC
Simple reproducer on older gcc is to add -fno-common:

# MAKEOPTS=-j1 LANG=C FEATURES='-strict -stricter -fail-clean -test' CFLAGS="$(portageq envvar CFLAGS) -fno-common" USE=-test emerge -v1 xorg-server

libtool: link: x86_64-pc-linux-gnu-gcc -DHAVE_DIX_CONFIG_H -Wall -Wpointer-arith -Wmissing-declarations -Wformat=2 -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -Wbad-function-cast -Wold-style-definition -Wdeclaration-after-statement -Wunused -Wuninitialized -Wshadow -Wmissing-noreturn -Wmissing-format-attribute -Wredundant-decls -Wlogical-op -Wimplicit -Wnonnull -Winit-self -Wmain -Wmissing-braces -Wsequence-point -Wreturn-type -Wtrigraphs -Warray-bounds -Wwrite-strings -Waddress -Wint-to-pointer-cast -Wpointer-to-int-cast -fno-strict-aliasing -fno-strict-aliasing -D_DEFAULT_SOURCE -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT -I/usr/include/libdrm -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/X11/dri -I../include -I../include -I../Xext -I../composite -I../damageext -I../xfixes -I../Xi -I../mi -I../miext/sync -I../miext/shadow -I../miext/damage -I../render -I../randr -I../fb -I../dbe -I../present -fvisibility=hidden -DHAVE_XORG_CONFIG_H -fvisibility=hidden -I/usr/include/libdrm -O2 -pipe -fdiagnostics-show-option -frecord-gcc-switches -fno-common -DGLAMOR_HAS_EGL_QUERY_DRIVER -pthread -Wl,-wrap -Wl,dixLookupWindow -Wl,-wrap -Wl,dixLookupClient -Wl,-wrap -Wl,WriteToClient -Wl,-wrap -Wl,dixLookupWindow -Wl,-wrap -Wl,XISetEventMask -Wl,-wrap -Wl,AddResource -Wl,-wrap -Wl,GrabButton -Wl,-O1 -Wl,--hash-style=gnu -Wl,-z -Wl,lazy -o tests tests-tests-common.o tests-list.o tests-string.o tests-tests.o tests-fixes.o tests-input.o tests-misc.o tests-signal-logging.o tests-touch.o tests-xfree86.o tests-test_xkb.o tests-xtest.o tests-hashtabletest.o tests-protocol-xchangedevicecontrol.o tests-protocol-common.o tests-protocol-xiqueryversion.o tests-protocol-xiquerydevice.o tests-protocol-xiselectevents.o tests-protocol-xigetselectedevents.o tests-protocol-xisetclientpointer.o tests-protocol-xigetclientpointer.o tests-protocol-xiquerypointer.o tests-protocol-xipassivegrabdevice.o tests-protocol-xiwarppointer.o tests-protocol-eventconvert.o tests-xi2.o tests-sdksyms.o  -Wl,--as-needed ../hw/xfree86/loader/.libs/libloader.a ../hw/xfree86/common/.libs/libcommon.a -ludev ../hw/xfree86/os-support/.libs/libxorgos.a ../hw/xfree86/parser/.libs/libxf86config.a ../hw/xfree86/dixmods/.libs/libdixmods.a ../hw/xfree86/modes/.libs/libxf86modes.a ../hw/xfree86/ramdac/.libs/libramdac.a ../hw/xfree86/ddc/.libs/libddc.a ../hw/xfree86/i2c/.libs/libi2c.a ../hw/xfree86/xkb/.libs/libxorgxkb.a ../Xext/.libs/libXvidmode.a ../dix/.libs/libdix.a ../mi/.libs/libmi.a ../composite/.libs/libcomposite.a ../xfixes/.libs/libxfixes.a ../Xext/.libs/libXext.a ../dbe/.libs/libdbe.a ../record/.libs/librecord.a ../randr/.libs/librandr.a ../render/.libs/librender.a ../damageext/.libs/libdamageext.a ../present/.libs/libpresent.a ../miext/sync/.libs/libsync.a ../miext/damage/.libs/libdamage.a ../Xi/.libs/libXi.a ../xkb/.libs/libxkb.a ../os/.libs/libos.a -lcrypto -ldl ../glx/.libs/libglxvnd.a ../hw/xfree86/dri/.libs/libdri.a ../hw/xfree86/dri2/.libs/libdri2.a ../dri3/.libs/libdri3.a -lpciaccess -ldrm -lpixman-1 -lXfont2 -lXau -lxshmfence -lXdmcp -lGL -lm -lbsd -pthread
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: tests-protocol-common.o:(.bss+0x748): multiple definition of `reply_handler'; tests-protocol-xchangedevicecontrol.o:(.bss+0xa0): first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: tests-protocol-xiqueryversion.o:(.bss+0xa0): multiple definition of `reply_handler'; tests-protocol-xchangedevicecontrol.o:(.bss+0xa0): first defined here
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: tests-protocol-xiqueryversion.o:(.bss+0x0): multiple definition of `client_window'; tests-protocol-xchangedevicecontrol.o:(.bss+0x0): first defined here

More details are at https://wiki.gentoo.org/wiki/Gcc_10_porting_notes/fno_common
Comment 1 Sergei Trofimovich gentoo-dev 2020-01-19 20:06:16 UTC
# emerge --info
Portage 2.3.81 (python 3.6.10-final-0, default/linux/amd64/17.0, gcc-9.2.0, glibc-2.30-r3, 5.4.0 x86_64)
=================================================================
System uname: Linux-5.4.0-x86_64-Intel-R-_Core-TM-_i7-2700K_CPU_@_3.50GHz-with-gentoo-2.6
KiB Mem:    31803948 total,   4774024 free
KiB Swap:          0 total,         0 free
sh dash 0.5.10.2
ld GNU ld (Gentoo 2.33.1 p1) 2.33.1
ccache version 3.7.7 [enabled]
app-shells/bash:          5.0_p11::gentoo
dev-lang/perl:            5.30.1::gentoo
dev-lang/python:          2.7.17-r1::gentoo, 3.6.10::gentoo, 3.7.5-r1::gentoo, 3.8.1::gentoo
dev-util/ccache:          3.7.7::gentoo
dev-util/cmake:           3.16.0::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.42.1::gentoo
sys-apps/sandbox:         2.18::gentoo
sys-devel/autoconf:       2.69-r5::gentoo
sys-devel/automake:       1.16.1-r2::gentoo
sys-devel/binutils:       2.33.1::gentoo
sys-devel/gcc:            6.5.0-r1::gentoo, 9.2.0-r2::gentoo
sys-devel/gcc-config:     2.2::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.30-r3::gentoo
Repositories:

gentoo
    location: /bound/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts:
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-jobs: 1

crossdev
    location: /co
    masters: gentoo
    priority: 0

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -fdiagnostics-show-option -frecord-gcc-switches"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/bound/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fail-clean fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms strict stricter test unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://192.168.1.69 http://distfiles.gentoo.org"
LANG="ru_RU.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/dev/shm"
USE="X acl amd64 berkdb bzip2 cairo cli crypt cups cxx dri fontconfig fortran gdbm glamor iconv icu ipv6 jpeg libtirpc minizip mmx multilib ncurses nls nptl openmp pam pcre pcre16 png python readline seccomp split-usr sqlite sse sse2 ssl tcpd test text truetype unicode xattr xkb xml xvfb zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby24 ruby25" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Sergei Trofimovich gentoo-dev 2020-01-19 20:07:25 UTC
Created attachment 603756 [details]
build.log.bz2
Comment 3 Piotr Karbowski archtester Gentoo Infrastructure gentoo-dev Security 2020-01-23 12:38:53 UTC
Hi slyfox,

Have you reported it upstream, or only here?
Comment 4 Sergei Trofimovich gentoo-dev 2020-01-23 19:54:38 UTC
(In reply to Piotr Karbowski from comment #3)
> Hi slyfox,
> 
> Have you reported it upstream, or only here?

Only here.
Comment 5 Sergei Trofimovich gentoo-dev 2020-03-07 09:44:36 UTC
Seems to be merged upstream. Worth backporting to current latest package?
Comment 6 Matt Turner gentoo-dev 2020-03-07 20:02:31 UTC
(In reply to Sergei Trofimovich from comment #5)
> Seems to be merged upstream. Worth backporting to current latest package?

I'm planning to make a 1.20.8 release soon, so I just cherry-picked the patch to that branch.
Comment 7 Larry the Git Cow gentoo-dev 2020-03-19 21:50:52 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ff6b355183abf835dc5355e01e6ca742eaff3a12

commit ff6b355183abf835dc5355e01e6ca742eaff3a12
Author:     Matt Turner <mattst88@gentoo.org>
AuthorDate: 2020-03-19 21:13:07 +0000
Commit:     Matt Turner <mattst88@gentoo.org>
CommitDate: 2020-03-19 21:50:43 +0000

    x11-base/xorg-server: Add patch to build with -fno-common
    
    Closes: https://bugs.gentoo.org/705880
    Signed-off-by: Matt Turner <mattst88@gentoo.org>

 ...erver-1.20.7-Fix-building-with-fno-common.patch | 254 +++++++++++++++++++++
 x11-base/xorg-server/xorg-server-1.20.7.ebuild     |   1 +
 2 files changed, 255 insertions(+)