Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 705730 - =sys-boot/syslinux-6.04_pre1 fails to build on gcc-10 due to -fno-common change
Summary: =sys-boot/syslinux-6.04_pre1 fails to build on gcc-10 due to -fno-common change
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Chí-Thanh Christopher Nguyễn
URL:
Whiteboard:
Keywords: PATCH
: 712414 744649 (view as bug list)
Depends on:
Blocks: -fno-common
  Show dependency tree
 
Reported: 2020-01-18 11:56 UTC by Sergei Trofimovich
Modified: 2020-09-27 13:38 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,921.21 KB, text/x-log)
2020-01-18 11:59 UTC, Sergei Trofimovich
Details
syslinux-6.04_pre1-fcommon.patch (syslinux-6.04_pre1-fcommon.patch,1.97 KB, patch)
2020-03-12 23:56 UTC, Sergei Trofimovich
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sergei Trofimovich gentoo-dev 2020-01-18 11:56:29 UTC
Simple reproducer on older gcc is to add -fno-common:

    # FEATURES='-strict -stricter' CFLAGS="$(portageq envvar CFLAGS) -fno-common" USE=custom-cflags emerge -v1 syslinux

The build fails as:
"""
x86_64-pc-linux-gnu-ld: /dev/shm/portage/sys-boot/syslinux-6.04_pre1/work/syslinux-6.04-pre1/efi64/efi/../core/fs/pxe/http_readdir.o:/dev/shm/portage/sys-boot/syslinux-6.04_pre1/work/syslinux-6.04-pre1/efi64/core/../../core/fs/pxe/pxe.h:268: multiple definition of `tcp_conn_ops'; /dev/shm/portage/sys-boot/syslinux-6.04_pre1/work/syslinux-6.04-pre1/efi64/efi/../core/fs/pxe/pxe.o:/dev/shm/portage/sys-boot/syslinux-6.04_pre1/work/syslinux-6.04-pre1/efi64/core/../../core/fs/pxe/pxe.h:268: first defined here
"""

More details are at https://wiki.gentoo.org/wiki/Gcc_10_porting_notes/fno_common
Comment 1 Sergei Trofimovich gentoo-dev 2020-01-18 11:57:23 UTC
# emerge --info
Portage 2.3.81 (python 3.6.10-final-0, default/linux/amd64/17.0, gcc-9.2.0, glibc-2.30-r3, 5.4.0 x86_64)
=================================================================
System uname: Linux-5.4.0-x86_64-Intel-R-_Core-TM-_i7-2700K_CPU_@_3.50GHz-with-gentoo-2.6
KiB Mem:    31803948 total,   4774024 free
KiB Swap:          0 total,         0 free
sh dash 0.5.10.2
ld GNU ld (Gentoo 2.33.1 p1) 2.33.1
ccache version 3.7.7 [enabled]
app-shells/bash:          5.0_p11::gentoo
dev-lang/perl:            5.30.1::gentoo
dev-lang/python:          2.7.17-r1::gentoo, 3.6.10::gentoo, 3.7.5-r1::gentoo, 3.8.1::gentoo
dev-util/ccache:          3.7.7::gentoo
dev-util/cmake:           3.16.0::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.42.1::gentoo
sys-apps/sandbox:         2.18::gentoo
sys-devel/autoconf:       2.69-r5::gentoo
sys-devel/automake:       1.16.1-r2::gentoo
sys-devel/binutils:       2.33.1::gentoo
sys-devel/gcc:            6.5.0-r1::gentoo, 9.2.0-r2::gentoo
sys-devel/gcc-config:     2.2::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.30-r3::gentoo
Repositories:

gentoo
    location: /bound/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts:
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-jobs: 1

crossdev
    location: /co
    masters: gentoo
    priority: 0

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -fdiagnostics-show-option -frecord-gcc-switches"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/bound/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fail-clean fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms strict stricter test unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://192.168.1.69 http://distfiles.gentoo.org"
LANG="ru_RU.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/dev/shm"
USE="X acl amd64 berkdb bzip2 cairo cli crypt cups cxx dri fontconfig fortran gdbm glamor iconv icu ipv6 jpeg libtirpc minizip mmx multilib ncurses nls nptl openmp pam pcre pcre16 png python readline seccomp split-usr sqlite sse sse2 ssl tcpd test text truetype unicode xattr xkb xml xvfb zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby24 ruby25" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Sergei Trofimovich gentoo-dev 2020-01-18 11:59:11 UTC
Created attachment 603644 [details]
build.log
Comment 3 Sergei Trofimovich gentoo-dev 2020-03-12 23:56:52 UTC
Created attachment 618170 [details, diff]
syslinux-6.04_pre1-fcommon.patch

syslinux-6.04_pre1-fcommon.patch sprinkles -fcommon around and allows me to build syslinux on gcc-10.
Comment 4 Toralf Förster gentoo-dev 2020-03-13 20:00:06 UTC
*** Bug 712414 has been marked as a duplicate of this bug. ***
Comment 5 Larry the Git Cow gentoo-dev 2020-04-06 22:49:58 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=8284530f4bd86a38b9867f847bd844f5d8d08e87

commit 8284530f4bd86a38b9867f847bd844f5d8d08e87
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2020-04-06 22:46:03 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2020-04-06 22:49:52 +0000

    sys-boot/syslinux: tweak for gcc-10, bug #705730
    
    Closes: https://bugs.gentoo.org/705730
    Package-Manager: Portage-2.3.96, Repoman-2.3.22
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 .../files/syslinux-6.04_pre1-fcommon.patch         |  54 +++++++++++
 sys-boot/syslinux/syslinux-6.04_pre1-r1.ebuild     | 107 +++++++++++++++++++++
 2 files changed, 161 insertions(+)
Comment 6 Jeroen Roovers gentoo-dev 2020-09-27 13:38:26 UTC
*** Bug 744649 has been marked as a duplicate of this bug. ***