Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 705280 - dev-lang/lazarus-1.8.4-r2 stable request
Summary: dev-lang/lazarus-1.8.4-r2 stable request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Amy Liffey
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks:
 
Reported: 2020-01-12 11:54 UTC by Grigor Lekarov
Modified: 2020-01-17 10:31 UTC (History)
1 user (show)

See Also:
Package list:
dev-lang/lazarus-1.8.4-r2
Runtime testing required: No
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Grigor Lekarov 2020-01-12 11:54:04 UTC
As the current stable version (dev-lang/lazarus-1.0.12) doesn't compile because of "Incompatible types" (most probably because of FPC update) it seems this one is a good candidate. It has a lot of resolved issues and some features as well. Also this version compiles successfully on amd64.

Reproducible: Always
Comment 1 Jonas Stein gentoo-dev 2020-01-12 13:58:37 UTC
I am a bit confused. 

There are 3 ebuilds in the tree
1.0.12 ~1.8.4-r2 ~2.0.2
Which of these versions have you tried?
https://packages.gentoo.org/packages/dev-lang/lazarus

Please create one ticket for the bug in dev-lang/lazarus-1.0.12
with full information. This means: 

Please recompile and 
*attach* the logfiles and 
paste the emerge info as described on
https://wiki.gentoo.org/wiki/Attach_the_logs_to_the_bug_ticket
We need to have all information at hand before ticket assignment, so that the maintainer can look after it in one session with minimal number of callbacks.

I see 1.8.4-r2 in the tree here, so I close the request for a version bump to 1.8.4.
Comment 2 Grigor Lekarov 2020-01-12 20:03:47 UTC
As I mentioned, current stable build is 1.0.12 which fails to compile because of "Incompatible types". 1.8.4 stays for a very long time in testing state. Why it can't be next stable lazarus version? Otherwise please fix the compile errors in 1.0.12.
Comment 3 Agostino Sarubbo gentoo-dev 2020-01-14 16:15:04 UTC
amd64 stable
Comment 4 Agostino Sarubbo gentoo-dev 2020-01-17 10:31:32 UTC
x86 stable. Closing.