Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 705126 - net-wireless/wpa_supplicant: dependency on net-wireless/cdra should consider kernel version
Summary: net-wireless/wpa_supplicant: dependency on net-wireless/cdra should consider ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Rick Farina (Zero_Chaos)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-10 20:44 UTC by Edward Kigwana
Modified: 2021-11-21 12:31 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Edward Kigwana 2020-01-10 20:44:16 UTC
CRDA is legacy for older kernels see https://git.kernel.org/pub/scm/linux/kernel/git/mcgrof/crda.git/commit/?id=f4ef2531698fb9ba006e8b31a223b3269be8bc7c

For newer kernels need to ensure that kernel is configured properly just like the  net-wireless/iwd ebuild does

Reproducible: Always

Steps to Reproduce:
1. Build wpa_supplicant on a system without python 2 and connect to WIFI

Actual Results:  
Build fails due to net-wireless/crda dependency on python2

Expected Results:  
Builds and connects to WIFI

With the sunsetting of python 2 https://www.python.org/doc/sunset-python-2 and crda in maintenance for legacy, it makes sense to drop the net-wireless/crda dependency for kernels greater than 4.15.0 and instead check that the kernel is configured properly.
Comment 1 Sam James archtester gentoo-dev Security 2021-11-21 12:31:51 UTC
I think this is essentially fixed now we've made it optional in bug 462032.