Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 704948 - media-libs/openimageio-1.8.17-r1 fails after upgrade to dev-cpp/yaml-cpp-0.6.3 due to an ABI break
Summary: media-libs/openimageio-1.8.17-r1 fails after upgrade to dev-cpp/yaml-cpp-0.6....
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Graphics Project
URL: https://bugzilla.redhat.com/show_bug....
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: 713464
  Show dependency tree
 
Reported: 2020-01-07 20:37 UTC by Attila Tóth
Modified: 2020-03-26 11:08 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
revert-774f2580.patch (revert-774f2580.patch,1.87 KB, patch)
2020-01-07 20:39 UTC, Attila Tóth
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Attila Tóth 2020-01-07 20:37:19 UTC
libOpenColorIO.so: undefined reference to `YAML::detail::node_data::empty_scalar[abi:cxx11]'

Downgrading to yaml-cpp-0.6.2 is a workaround.

Reproducible: Always
Comment 1 Attila Tóth 2020-01-07 20:39:43 UTC
Created attachment 602764 [details, diff]
revert-774f2580.patch

Fedora uses a patch to make blender and openimageio compile despite of the ABI break, reverting the relevant changes. Patch works for me!
https://src.fedoraproject.org/fork/thofmann/rpms/yaml-cpp/c/54066695bcc9381ddf7c147cd333705d569a6ca9?branch=f31
Comment 2 Attila Tóth 2020-01-07 20:40:06 UTC
blender may be also affected...
Comment 3 Andreas Sturmlechner gentoo-dev 2020-01-07 20:44:03 UTC
Also adding yaml-cpp maintainer in case there is something to be done there.
Comment 4 Larry the Git Cow gentoo-dev 2020-01-07 21:41:35 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=4f0b8303610a5eeefa5e4aa1127a27c1993372df

commit 4f0b8303610a5eeefa5e4aa1127a27c1993372df
Author:     Johannes Huber <johu@gentoo.org>
AuthorDate: 2020-01-07 21:40:11 +0000
Commit:     Johannes Huber <johu@gentoo.org>
CommitDate: 2020-01-07 21:41:23 +0000

    dev-cpp/yaml-cpp: fix ABI breakage
    
    Adds a patch used in fedora to fix ABI breakage. Patch and issue spotted
    by Attila Tóth <atoth@atoth.sote.hu>.
    
    Bug: https://bugs.gentoo.org/704948
    Thanks-to: Attila Tóth <atoth@atoth.sote.hu>
    Package-Manager: Portage-2.3.84, Repoman-2.3.20
    Signed-off-by: Johannes Huber <johu@gentoo.org>

 .../files/yaml-cpp-0.6.3-abi-breakage.patch        | 57 ++++++++++++++++++++++
 dev-cpp/yaml-cpp/yaml-cpp-0.6.3-r1.ebuild          | 45 +++++++++++++++++
 2 files changed, 102 insertions(+)
Comment 5 Johannes Huber gentoo-dev 2020-01-07 21:44:06 UTC
Please test and close if it is working now.
Comment 6 Johannes Huber gentoo-dev 2020-03-23 11:25:46 UTC
(In reply to Johannes Huber from comment #5)
> Please test and close if it is working now.

Any feedback would be nice.
Comment 7 Attila Tóth 2020-03-25 09:03:19 UTC
(In reply to Johannes Huber from comment #6)
> (In reply to Johannes Huber from comment #5)
> > Please test and close if it is working now.
> 
> Any feedback would be nice.

Currently compiles fine for me.