Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 70436 - Environment problem with gcc, resulting in possible failure of Firefox/Thunderbird with
Summary: Environment problem with gcc, resulting in possible failure of Firefox/Thunde...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo Toolchain Maintainers
Depends on:
Reported: 2004-11-08 01:25 UTC by Stefan de Konink
Modified: 2004-11-19 23:10 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Stefan de Konink 2004-11-08 01:25:31 UTC
After updating gcc lastnight the CURRENT value in /etc/env.d/gcc/config stays i686-pc-linux-gnu-3.4.2 instead of 3.4.3 as you can imagine the update script is going to behave strange. After the gcc update I (automatically) updated glibc and Firefox + Thunderbird. Both versions won't start anymore because of a non-existing

Reproducible: Always
Steps to Reproduce:
1. emerge sync
2. emerge portage gcc glibc mozilla-firebird mozilla-thunderbird
3. firefox -> /usr/lib/MozillaFirefox/firefox-bin: error while loading shared libraries: cannot open shared object file: No such file or directory
4. thunderbird -> /usr/lib/MozillaThunderbird/thunderbird-bin: error while loading shared libraries: cannot open shared object file: No such file or directory
Actual Results:  
The programs won't start anymore.

Expected Results:  
An working updated version of both packages.

Probably a correct environment in too, (my guess this must be noticeable for others too),  which is now:
# autogenerated by env-update; make all changes to
# contents of /etc/env.d directory

Portage 2.0.51-r3 (default-linux/x86/2004.0, gcc-3.4.3, glibc-,
 2.6.8-gentoo-r4 i686)
System uname: 2.6.8-gentoo-r4 i686 AMD Athlon(tm) processor
Gentoo Base System version 1.6.5
distcc 2.18 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-
Headers:  sys-kernel/linux26-headers-
Libtools: sys-devel/libtool-1.5.2-r6
CFLAGS="-O3 -march=athlon-tbird -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3/s
hare/config /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/
dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/c
onfig/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=athlon-tbird -pipe -fomit-frame-pointer"
FEATURES="autoaddcvs ccache distlocks sandbox sfperms"
GENTOO_MIRRORS=" ftp://ftp.easynet.
nl/mirror/gentoo/ ftp:/
USE="3dnow X alsa apm avi berkdb bitmap-fonts crypt cups dvd encode esd f77 fam 
flac foomaticdb fortran gdbm gif gnome gpm gtk gtk2 imlib java jpeg junit kde ld
ap libg++ libwww mad mikmod mmx motif mpeg ncurses nls nptl nptlonly oggvorbis o
pengl oss pam pdflib perl png python qt quicktime readline sdl slang speex spell
 ssl svga tcpd tetex tiff truetype x86 xml xml2 xmms xv zlib"
Comment 1 Stefan de Konink 2004-11-08 01:31:02 UTC
After manually changing to the latest version (3.4.3) and do ldconfig I can start both applications again. env-update changes everything back to the old version (3.4.2).
Comment 2 Ian Truelsen 2004-11-08 12:05:45 UTC
I had the same problems and this fix worked for me as well.
Comment 3 Wouter Deconinck 2004-11-09 12:13:37 UTC
Same problem here, but with other programs (kdeinit, pdflatex).  I solved this using 'gcc-config 3.4.3' and ' 3.4.3'.
Comment 4 Dylan Carlson (RETIRED) gentoo-dev 2004-11-10 05:55:15 UTC
running gcc-config fixed this for me.
Comment 5 filip 2004-11-10 15:13:33 UTC
Same problem here, though I didn't rebuild firefox - only gcc. Also, groff stopped working, so no man-pages.
Comment 6 Ian Ellis 2004-11-10 20:35:36 UTC
To get things working I had to run " 3.4.2" (yes, 3.4.2, NOT 3.4.3).  Before running that when I went to compile xine-lib it kept looking for one of the libstdc++ files in one of the old 3.4.2 directories.
Comment 7 nobody 2004-11-19 01:26:10 UTC
Problem comes from that file /etc/env.d/05gcc

Here's how i change it, then -> env-update -> working

diff 05gcc old05gcc
< PATH="/usr/i686-pc-linux-gnu/gcc-bin/3.4"
< ROOTPATH="/usr/i686-pc-linux-gnu/gcc-bin/3.4"
< MANPATH="/usr/share/gcc-data/i686-pc-linux-gnu/3.4/man"
< INFOPATH="/usr/share/gcc-data/i686-pc-linux-gnu/3.4/info"
> PATH="/usr/i686-pc-linux-gnu/gcc-bin/3.3"
> ROOTPATH="/usr/i686-pc-linux-gnu/gcc-bin/3.3"
> MANPATH="/usr/share/gcc-data/i686-pc-linux-gnu/3.3/man"
> INFOPATH="/usr/share/gcc-data/i686-pc-linux-gnu/3.3/info"
< LDPATH="/usr/lib/gcc-lib/i686-pc-linux-gnu/3.4.3"
> LDPATH="/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4:/usr/lib/gcc-lib/i686-pc-linu x-gnu/3.3.3"
Comment 8 SpanKY gentoo-dev 2004-11-19 23:10:15 UTC
this has been resolved in the gcc ebuild

to fix your machine, run `gcc-config <correct chost-ver>`