Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 703604 - app-dicts/sword-*: some of the packages have incorrect LICENSE
Summary: app-dicts/sword-*: some of the packages have incorrect LICENSE
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Theology Herd
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks: free-noncomm-license freedist-license
  Show dependency tree
 
Reported: 2019-12-23 11:04 UTC by Ulrich Müller
Modified: 2020-02-05 09:41 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich Müller gentoo-dev 2019-12-23 11:04:12 UTC
I don't know how LICENSE of the app-dicts/sword-* modules has originally been determined, but going by the information in the mods.d/*.conf files included with the individual zipballs, I arrive at a different result for several of them. See my findings below.

Disclaimer: IANAL, TINLA

----------------------------------------------------------------------

The following 110 packages have "DistributionLicense=Public Domain":

   sword-abbott
   sword-acv
   sword-alb
   sword-aleppo
   sword-amtract
   sword-arasvd
   sword-armeastern
   sword-armwestern
   sword-asv
   sword-barnes
   sword-bashautin
   sword-bbe
   sword-burjudson
   sword-byz
   sword-cbc
   sword-clarke
   sword-cro
   sword-czebkr
   sword-daily
   sword-darby
   sword-diaglott
   sword-drc
   sword-dtn
   sword-dutkant
   sword-dutsvv
   sword-easton
   sword-esperanto
   sword-finbiblia
   sword-finney
   sword-finpr
   sword-frecrampon
   sword-fremartin
   sword-fresegond
   sword-gerelb1871
   sword-gerelb1905
   sword-gerlut1545
   sword-heretics
   sword-hitchcock
   sword-hnv
   sword-hunkar
   sword-institutes
   sword-isbe
   sword-itadio
   sword-itarive
   sword-jfb
   sword-josephus
   sword-jps
   sword-jst
   sword-kjvd
   sword-klv
   sword-klven_iklingon
   sword-klviklingon_en
   sword-lightfoot
   sword-luther
   sword-mak
   sword-manxgaelic
   sword-mhc
   sword-mhcc
   sword-montgomery
   sword-murdock
   sword-nave
   sword-norsk
   sword-orthodoxy
   sword-packard
   sword-peshitta
   sword-pilgrim
   sword-pnt
   sword-practice
   sword-rkjnt
   sword-rnkjv
   sword-rotherham
   sword-rst
   sword-rusmakarij
   sword-rwebster
   sword-saoa
   sword-scofield
   sword-scotsgaelic
   sword-sme
   sword-smith
   sword-sparv
   sword-spasev
   sword-spavnt
   sword-spurious
   sword-strongsgreek
   sword-strongshebrew
   sword-swahili
   sword-tagalog
   sword-tcr
   sword-tdavid
   sword-tfg
   sword-tisch
   sword-torrey
   sword-tr
   sword-tsk
   sword-twenty
   sword-tyndale
   sword-ukjv
   sword-ukrainian
   sword-vulgate
   sword-vulgate_hebps
   sword-web
   sword-webster
   sword-webstersdict
   sword-wesley
   sword-weymouth
   sword-whnu
   sword-wlc
   sword-wulfila
   sword-wycliffe
   sword-ylt

----------------------------------------------------------------------

These 10 have an explicitly defined license in "DistributionLicense":

   sword-chamorro    -> freedist
   sword-common      -> free-noncomm
   sword-dan         -> free-noncomm
   sword-frebbb      -> free-noncomm
   sword-gersch      -> free-noncomm
   sword-greekhebrew -> free-noncomm
   sword-hebrewgreek -> free-noncomm
   sword-jubilee2000 -> free-noncomm
   sword-robinson    -> CC-BY-SA-3.0
   sword-uma         -> free-noncomm

----------------------------------------------------------------------

For 22 packages, there seems to be no license information at all.
Presumably, we have to use LICENSE="all-rights-reserved" for them,
plus RESTRICT="mirror bindist":

   sword-abs_essay_goodsam_swb
   sword-br_en
   sword-bulveren
   sword-bwe
   sword-chincvs
   sword-chincvt
   sword-chiun
   sword-chiuns
   sword-est
   sword-family
   sword-frecrl
   sword-geneva
   sword-geneva1599
   sword-hebmodern
   sword-icelandic
   sword-korean
   sword-la_en
   sword-latvian
   sword-maori
   sword-romcor
   sword-umgreek
   sword-xhosa

----------------------------------------------------------------------

Another 11 packages have:
DistributionLicense=Copyrighted; Permission to distribute granted to CrossWire

Permission has been granted to CrossWire, but not to us, therefore we
*don't* have permission to redistribute them.
LICENSE="all-rights-reserved", RESTRICT="mirror bindist"

   sword-ab
   sword-bulcarigradnt
   sword-czecep
   sword-czekms
   sword-czenkb
   sword-dbd
   sword-emtv
   sword-finpr92
   sword-hunuj
   sword-kekchi
   sword-sparvg2004

----------------------------------------------------------------------

The remaining 10 packages are special cases, going through them indiviually.

   sword-afr1953
   No DistributionLicense, but the About field says:
   "This copyright Bible has kindly been made available by the Bible Society
   of South Africa, strictly for non-commercial use with The SWORD Project."
   This looks like "free-noncomm" to me.

   sword-akjv
   DistributionLicense says "Free non-commercial distribution", but the
   About field is more free:
   "I am hereby putting the American King James version of the Bible into
   the public domain on November 8, 1999. You may use it in any manner you
   wish: copy it, sell it, modify it, etc. You can't copyright it or
   prevent others from using it. You can't claim that you created it,
   because you didn't."
   The same information is also on the original homepage of the source.
   IMHO this is "public-domain".

   sword-farsiopv
   DistributionLicense says "With Permission of the International Bible
   Society free for non commercial use only".
   In addition, there is this in the About field:
   "In all likelihood this text is now public domain simply due to its age,
   but we ask you to respect the International Bible Society's request to
   use this text only in non-commercial ways until full clarity on its
   legal status has been obtained."
   Seems that "free-noncomm" is the best we can do here.

   sword-frelsg
   About says: "Texte libre de droits"
   Does this qualify as "public-domain"?

   sword-isv
   DistributionLicense says: "Copyrighted; Permission to distribute granted
   to CrossWire", but there also is:
   "It may be distributed freely in its current form, without changes."
   If we go with the latter statement, it would be "freedist".

   sword-kjv
   DistributionLicense says: "General public license for distribution for
   any purpose" and in About there is:
   "It is in this spirit that we in turn offer the KJV2003 Project text
   freely for any purpose. Any copyright that might be obtained for this
   effort is held by CrossWire Bible Society (c) 2003 and CrossWire Bible
   Society hereby grants a general public license to use this text for any
   purpose."
   Permission to distribute, but not to modify, i.e., "freedist".

   sword-litv
   "All rights reserved. Permission to non-commercially distribute freely
   for use with The SWORD Project, granted by Jay P. Green, Jr.
   on Oct 3, 2002"
   Looks like "free-noncomm".

   sword-mkjv
   DistributionLicense says: "Copyrighted; Permission to distribute granted
   to CrossWire", but there is also:
   "All rights reserved. Permission to non-commercially distribute freely
   for use with The SWORD Project, granted by Jay P. Green, Jr.
   on Oct 3, 2002"
   Which is the same as for the previous one, so "free-noncomm" too?

   sword-personal
   "This module allows you to store your own commentary."
   This contains a big file filled with zero bytes.
   "public-domain"

   sword-rwp
   DistributionLicense says: "Copyrighted; Free non-commercial distribution"
   However, there also is:
   "Vol 1,2,3,4  Public Domain -- Copy Freely
   Volume 5 (c) 1932. Renewal 1960 Broadman Press. All rights reserved.
   Used by permission. [Copyright expires Dec. 31, 2006.]
   Volume 6 (c) 1933. Renewal 1960 Broadman Press. All rights reserved.
   Used by permission. [Copyright expires Dec. 31, 2007.]"
   If we believe their statement that copyright for volumes 5 and 6 has
   expired by now, then this is "public-domain".
Comment 1 Ulrich Müller gentoo-dev 2019-12-23 11:09:31 UTC
@Licenses team: Please review (especially whether my conclusions for the last 10 packages make sense).

@creffett: Long time ago, you gave me permission to fix license issues in KDE packages myself. If you like, I could update these sword-* packages too.
Comment 2 Ulrich Müller gentoo-dev 2020-01-06 15:06:16 UTC
(In reply to Ulrich Müller from comment #0)
> For 22 packages, there seems to be no license information at all.
> Presumably, we have to use LICENSE="all-rights-reserved" for them,
> plus RESTRICT="mirror bindist":

Going through this list again, I see updated information for two of the packages at http://www2.crosswire.org/sword/modules/ModInfo.jsp?modName=${SWORD_MODULE}:

>    sword-bulveren
"Copyrighted; Permission granted to distribute non-commercially in Sword format"
i.e. LICENSE="free-noncomm"

>    sword-geneva1599
"Public Domain"
Comment 3 Ulrich Müller gentoo-dev 2020-01-06 18:38:40 UTC
(In reply to Ulrich Müller from comment #0)
>    sword-sparvg2004

This actually has LICENSE="sword-sparvg2004", which seems to allow distribution:
"All Churches or organizations that want to print or reproduce it for free distribution have the clear liberty to do so without need to pay royalties, always and when they do not change any of the written words."
Comment 4 Ulrich Müller gentoo-dev 2020-01-06 20:33:56 UTC
All licenses updated, as outlined above.

I have also sent last rites for the packages that are not redistributable:

# Ulrich Müller <ulm@gentoo.org> (2020-01-06)
# No license, therefore we have no permission to redistribute
# these packages on Gentoo mirrors. Distfiles are unversioned
# zipballs, which are updated in place when a new version is
# released. Since this will break digests, mirror restriction
# is not feasible.
# Masked for removal in 30 days. Bug #703604.
app-dicts/sword-ab
app-dicts/sword-abs_essay_goodsam_swb
app-dicts/sword-br_en
app-dicts/sword-bulcarigradnt
app-dicts/sword-bwe
app-dicts/sword-chincvs
app-dicts/sword-chincvt
app-dicts/sword-chiun
app-dicts/sword-chiuns
app-dicts/sword-czecep
app-dicts/sword-czekms
app-dicts/sword-czenkb
app-dicts/sword-dbd
app-dicts/sword-emtv
app-dicts/sword-est
app-dicts/sword-family
app-dicts/sword-finpr92
app-dicts/sword-frecrl
app-dicts/sword-geneva
app-dicts/sword-hebmodern
app-dicts/sword-hunuj
app-dicts/sword-icelandic
app-dicts/sword-kekchi
app-dicts/sword-korean
app-dicts/sword-la_en
app-dicts/sword-latvian
app-dicts/sword-maori
app-dicts/sword-romcor
app-dicts/sword-umgreek
app-dicts/sword-xhosa
Comment 5 Duncan 2020-01-13 09:14:49 UTC
(In reply to Ulrich Müller from comment #4)

> app-dicts/sword-geneva

This one is translation notes for the Geneva1599 Bible (sword-geneva1599).  As such it/they should be loooong... out of copyright.

The history is that this Bible and these notes were written by Calvin and others during their exile to Geneva during the rein of Bloody Mary in England.  As such some of the notes have a political bent that later English monarchs including King James I didn't like, leading him to commission the King James Bible of 1611.  So they're controversial but are historical documents as well as Biblical commentary.

See https://genevabible.com/introduction/ (among others I found with a simple google).
Comment 6 Ulrich Müller gentoo-dev 2020-01-13 09:52:21 UTC
(In reply to Duncan from comment #5)
> (In reply to Ulrich Müller from comment #4)
> 
> > app-dicts/sword-geneva
> 
> This one is translation notes for the Geneva1599 Bible (sword-geneva1599). 
> As such it/they should be loooong... out of copyright.
> 
> The history is that this Bible and these notes were written by Calvin and
> others during their exile to Geneva during the rein of Bloody Mary in
> England.  As such some of the notes have a political bent that later English
> monarchs including King James I didn't like, leading him to commission the
> King James Bible of 1611.  So they're controversial but are historical
> documents as well as Biblical commentary.
> 
> See https://genevabible.com/introduction/ (among others I found with a
> simple google).

I see. You may want to file a bug upstream, so that they add that information to the module. I simply went by the metadata (geneva.conf in the zipball) which doesn't say anything about the license.

http://www.crosswire.org/sword/modules/ModInfo.jsp?modName=Geneva
Comment 7 Larry the Git Cow gentoo-dev 2020-01-13 09:52:55 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ff053209f023908237ad1b3808f79db5d1e14d72

commit ff053209f023908237ad1b3808f79db5d1e14d72
Author:     Ulrich Müller <ulm@gentoo.org>
AuthorDate: 2020-01-13 09:50:40 +0000
Commit:     Ulrich Müller <ulm@gentoo.org>
CommitDate: 2020-01-13 09:52:33 +0000

    profiles: Drop mask for app-dicts/sword-geneva.
    
    Bug: https://bugs.gentoo.org/703604#c5
    Signed-off-by: Ulrich Müller <ulm@gentoo.org>

 profiles/package.mask | 1 -
 1 file changed, 1 deletion(-)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d9a7c0f84ee5c09af8ecc37ac019c1c65d560484

commit d9a7c0f84ee5c09af8ecc37ac019c1c65d560484
Author:     Ulrich Müller <ulm@gentoo.org>
AuthorDate: 2020-01-13 09:49:55 +0000
Commit:     Ulrich Müller <ulm@gentoo.org>
CommitDate: 2020-01-13 09:52:32 +0000

    app-dicts/sword-geneva: Update LICENSE.
    
    Supposedly, this is in the public domain because copyright has expired.
    
    Bug: https://bugs.gentoo.org/703604#c5
    Package-Manager: Portage-2.3.84, Repoman-2.3.20
    Signed-off-by: Ulrich Müller <ulm@gentoo.org>

 app-dicts/sword-geneva/sword-geneva-1.1.ebuild | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)
Comment 8 Ulrich Müller gentoo-dev 2020-01-13 09:57:18 UTC
(In reply to Ulrich Müller from comment #6)
> I see. You may want to file a bug upstream, so that they add that
> information to the module. I simply went by the metadata (geneva.conf in the
> zipball) which doesn't say anything about the license.

Or rather, not license but copyright status.
Comment 9 Larry the Git Cow gentoo-dev 2020-02-05 09:40:40 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=7d66c43e896f9e676fd07b0fede7b0df438be284

commit 7d66c43e896f9e676fd07b0fede7b0df438be284
Author:     Ulrich Müller <ulm@gentoo.org>
AuthorDate: 2020-02-05 09:34:43 +0000
Commit:     Ulrich Müller <ulm@gentoo.org>
CommitDate: 2020-02-05 09:40:28 +0000

    app-dicts/sword-*: Remove last-rited packages.
    
    Bug: https://bugs.gentoo.org/703604
    Signed-off-by: Ulrich Müller <ulm@gentoo.org>

 app-dicts/sword-ab/Manifest                                |  1 -
 app-dicts/sword-ab/metadata.xml                            |  8 --------
 app-dicts/sword-ab/sword-ab-1.3.ebuild                     | 14 --------------
 app-dicts/sword-abs_essay_goodsam_swb/Manifest             |  1 -
 app-dicts/sword-abs_essay_goodsam_swb/metadata.xml         |  8 --------
 .../sword-abs_essay_goodsam_swb-1.0.ebuild                 | 14 --------------
 app-dicts/sword-br_en/Manifest                             |  1 -
 app-dicts/sword-br_en/metadata.xml                         |  8 --------
 app-dicts/sword-br_en/sword-br_en-1.1.ebuild               | 13 -------------
 app-dicts/sword-bulcarigradnt/Manifest                     |  1 -
 app-dicts/sword-bulcarigradnt/metadata.xml                 |  8 --------
 .../sword-bulcarigradnt/sword-bulcarigradnt-1.0.ebuild     | 13 -------------
 app-dicts/sword-bwe/Manifest                               |  1 -
 app-dicts/sword-bwe/metadata.xml                           |  8 --------
 app-dicts/sword-bwe/sword-bwe-1.0.ebuild                   | 13 -------------
 app-dicts/sword-chincvs/Manifest                           |  1 -
 app-dicts/sword-chincvs/metadata.xml                       |  8 --------
 app-dicts/sword-chincvs/sword-chincvs-1.0.ebuild           | 13 -------------
 app-dicts/sword-chincvt/Manifest                           |  1 -
 app-dicts/sword-chincvt/metadata.xml                       |  8 --------
 app-dicts/sword-chincvt/sword-chincvt-1.0.ebuild           | 13 -------------
 app-dicts/sword-chiun/Manifest                             |  1 -
 app-dicts/sword-chiun/metadata.xml                         |  8 --------
 app-dicts/sword-chiun/sword-chiun-2.0.ebuild               | 13 -------------
 app-dicts/sword-chiuns/Manifest                            |  1 -
 app-dicts/sword-chiuns/metadata.xml                        |  8 --------
 app-dicts/sword-chiuns/sword-chiuns-2.0.ebuild             | 13 -------------
 app-dicts/sword-czecep/Manifest                            |  1 -
 app-dicts/sword-czecep/metadata.xml                        |  8 --------
 app-dicts/sword-czecep/sword-czecep-1.4.ebuild             | 13 -------------
 app-dicts/sword-czekms/Manifest                            |  1 -
 app-dicts/sword-czekms/metadata.xml                        |  8 --------
 app-dicts/sword-czekms/sword-czekms-1.4.ebuild             | 13 -------------
 app-dicts/sword-czenkb/Manifest                            |  1 -
 app-dicts/sword-czenkb/metadata.xml                        |  8 --------
 app-dicts/sword-czenkb/sword-czenkb-1.1.ebuild             | 13 -------------
 app-dicts/sword-dbd/Manifest                               |  1 -
 app-dicts/sword-dbd/metadata.xml                           |  8 --------
 app-dicts/sword-dbd/sword-dbd-1.1.ebuild                   | 13 -------------
 app-dicts/sword-emtv/Manifest                              |  1 -
 app-dicts/sword-emtv/metadata.xml                          |  8 --------
 app-dicts/sword-emtv/sword-emtv-1.3.ebuild                 | 13 -------------
 app-dicts/sword-est/Manifest                               |  1 -
 app-dicts/sword-est/metadata.xml                           |  8 --------
 app-dicts/sword-est/sword-est-1.1.ebuild                   | 13 -------------
 app-dicts/sword-family/Manifest                            |  1 -
 app-dicts/sword-family/metadata.xml                        |  8 --------
 app-dicts/sword-family/sword-family-1.1.ebuild             | 13 -------------
 app-dicts/sword-finpr92/Manifest                           |  1 -
 app-dicts/sword-finpr92/metadata.xml                       |  8 --------
 app-dicts/sword-finpr92/sword-finpr92-1.1.ebuild           | 13 -------------
 app-dicts/sword-frecrl/Manifest                            |  1 -
 app-dicts/sword-frecrl/metadata.xml                        |  8 --------
 app-dicts/sword-frecrl/sword-frecrl-1.2.ebuild             | 13 -------------
 app-dicts/sword-hebmodern/Manifest                         |  1 -
 app-dicts/sword-hebmodern/metadata.xml                     |  8 --------
 app-dicts/sword-hebmodern/sword-hebmodern-1.1.ebuild       | 13 -------------
 app-dicts/sword-hunuj/Manifest                             |  1 -
 app-dicts/sword-hunuj/metadata.xml                         |  8 --------
 app-dicts/sword-hunuj/sword-hunuj-1.2.ebuild               | 13 -------------
 app-dicts/sword-icelandic/Manifest                         |  1 -
 app-dicts/sword-icelandic/metadata.xml                     |  8 --------
 app-dicts/sword-icelandic/sword-icelandic-1.1.ebuild       | 13 -------------
 app-dicts/sword-kekchi/Manifest                            |  1 -
 app-dicts/sword-kekchi/metadata.xml                        |  8 --------
 app-dicts/sword-kekchi/sword-kekchi-1.5.ebuild             | 13 -------------
 app-dicts/sword-korean/Manifest                            |  1 -
 app-dicts/sword-korean/metadata.xml                        |  8 --------
 app-dicts/sword-korean/sword-korean-1.1.ebuild             | 13 -------------
 app-dicts/sword-la_en/Manifest                             |  1 -
 app-dicts/sword-la_en/metadata.xml                         |  8 --------
 app-dicts/sword-la_en/sword-la_en-1.1.ebuild               | 13 -------------
 app-dicts/sword-latvian/Manifest                           |  1 -
 app-dicts/sword-latvian/metadata.xml                       |  8 --------
 app-dicts/sword-latvian/sword-latvian-1.1.ebuild           | 13 -------------
 app-dicts/sword-maori/Manifest                             |  1 -
 app-dicts/sword-maori/metadata.xml                         |  8 --------
 app-dicts/sword-maori/sword-maori-1.1.ebuild               | 13 -------------
 app-dicts/sword-romcor/Manifest                            |  1 -
 app-dicts/sword-romcor/metadata.xml                        |  8 --------
 app-dicts/sword-romcor/sword-romcor-1.2.ebuild             | 13 -------------
 app-dicts/sword-umgreek/Manifest                           |  1 -
 app-dicts/sword-umgreek/metadata.xml                       |  8 --------
 app-dicts/sword-umgreek/sword-umgreek-1.6.ebuild           | 13 -------------
 app-dicts/sword-xhosa/Manifest                             |  1 -
 app-dicts/sword-xhosa/metadata.xml                         |  8 --------
 app-dicts/sword-xhosa/sword-xhosa-1.1.ebuild               | 13 -------------
 87 files changed, 640 deletions(-)