Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 703208 - all stable keyworded samba ebuilds support only python2
Summary: all stable keyworded samba ebuilds support only python2
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's SAMBA Team
URL:
Whiteboard:
Keywords:
Depends on: CVE-2019-10197 704998
Blocks:
  Show dependency tree
 
Reported: 2019-12-17 11:29 UTC by hsk17
Modified: 2020-07-10 05:55 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hsk17 2019-12-17 11:29:07 UTC
trying to retire python2 on my system i came across the following issue:

all stable keyworded samba ebuilds only have "PYTHON_COMPAT=( python2_7 )".

is it possible to stabilize a samba ebuild supporting python3, including the then neccessary sys-libs/{ldb,talloc,tdb,tevent} ebuilds?


Reproducible: Always
Comment 1 Andreas Sturmlechner gentoo-dev 2019-12-17 11:48:54 UTC
A lot of stable packages are currently only supporting py2, newer versions will all be stabilised eventually. For samba, the next stabilisation will likely happen in bug 702928, I don't think we need a second bug requesting the same.
Comment 2 hsk17 2019-12-17 12:48:57 UTC
thanks.  but please keep in mind that stabilizing 4.9.17 will not help w.r.t. python3...
Comment 3 Andreas Sturmlechner gentoo-dev 2019-12-17 13:25:20 UTC
Why should 4.9.17 be stabilsed when security bug talks about <4.11.3 being affected.
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2019-12-17 13:31:07 UTC
(In reply to Andreas Sturmlechner from comment #3)
> Why should 4.9.17 be stabilsed when security bug talks about <4.11.3 being
> affected.

Because of bug #683148
Comment 5 Andreas Sturmlechner gentoo-dev 2019-12-17 14:03:40 UTC
ah, the joy of waf...