Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 703014 - net-libs/libtorrent-rasterbar-1.2.2-r1 needs patch to build with dev-libs/boost-1.72.0
Summary: net-libs/libtorrent-rasterbar-1.2.2-r1 needs patch to build with dev-libs/boo...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal with 2 votes (vote)
Assignee: Mikle Kolyada
URL:
Whiteboard:
Keywords: PATCH, PullRequest
: 703198 703218 (view as bug list)
Depends on:
Blocks: boost-1.72
  Show dependency tree
 
Reported: 2019-12-15 17:12 UTC by thunderrd
Modified: 2020-01-18 23:42 UTC (History)
14 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
upstream patch for libtorrent-rasterbar-1.2.2 to build with boost-1.72.0 (boost-1.72.0.patch,857 bytes, patch)
2019-12-15 17:14 UTC, thunderrd
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description thunderrd 2019-12-15 17:12:57 UTC
after dev-libs/boost update, net-libs/libtorrent-rasterbar fails to build with this error:

error: no type named ‘executor_type’ in ‘struct libtorrent::aux::socket_type’

I found the attached patch for this upstream, it applies and builds normally for me:

https://github.com/arvidn/libtorrent/commit/e4b812b50b0a.patch

Reproducible: Always

Steps to Reproduce:
1.update boost to 1.72.0
2.emerge of libtorrent-rasterbar-1.2.2-r1 fails
3.
Comment 1 thunderrd 2019-12-15 17:14:31 UTC
Created attachment 599664 [details, diff]
upstream patch for libtorrent-rasterbar-1.2.2 to build with boost-1.72.0
Comment 2 Chris 2019-12-15 19:11:11 UTC
Thank you. The patch resolves the issue.
Comment 3 edes 2019-12-16 13:51:29 UTC
Yes, the patch worked here too.
Comment 4 Ivan 2019-12-16 15:53:37 UTC
Patch worked just fine on ~amd64 with default/linux/amd64/17.1/desktop/plasma/systemd (stable) profile.

Thanks.
Comment 5 Craig Andrews gentoo-dev 2019-12-17 18:57:13 UTC
*** Bug 703198 has been marked as a duplicate of this bug. ***
Comment 6 Jason Chan 2019-12-19 23:10:04 UTC
Thank you, confirmed it works for me. It hangs on testing, although it doesn't fail any.
Comment 7 Mikle Kolyada (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2019-12-20 10:52:38 UTC
fixed in 1.2.3
Comment 8 Mikle Kolyada (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2019-12-20 10:54:15 UTC
*** Bug 703218 has been marked as a duplicate of this bug. ***
Comment 9 Vasco Gervasi 2019-12-20 11:40:21 UTC
Hi,
may I ask to bump libtorrent-rasterbar to 1.2.3 in the tree?

Thanks
Comment 10 Nick Soveiko 2020-01-18 23:42:45 UTC
net-libs/libtorrent-rasterbar-1.1.13-r1 suffers from the same bug, and it is a dependency of net-p2p/deluge-1.3.15-r3
since boost-1.72 is in stable now, libtorrent-rasterbar-1.1 is now broken