Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 70282 - dispatch-conf broken (python traceback) since portage upgrade
Summary: dispatch-conf broken (python traceback) since portage upgrade
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Tools (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 69147
  Show dependency tree
 
Reported: 2004-11-06 11:01 UTC by giggles1
Modified: 2005-02-28 09:29 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
dispatch-conf-typo.patch (dispatch-conf-typo.patch,635 bytes, patch)
2004-11-06 22:15 UTC, Jason Stubbs (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description giggles1 2004-11-06 11:01:58 UTC
Selecting "u" for "use new" results in this on both my amd and intel machines:

>> (1 of 2) -- /etc/conf.d/iptables
>> q quit, h help, n next, e edit-new, z zap-new, u use-new
   m merge, t toggle-merge, l look-merge:
Traceback (most recent call last):
  File "/usr/sbin/dispatch-conf", line 309, in ?
    d.grind (portage.settings ['CONFIG_PROTECT'])
  File "/usr/sbin/dispatch-conf", line 208, in grind
    self.replace(newconf, conf ['current'])
  File "/usr/sbin/dispatch-conf", line 222, in replace
    os.system((DIFF_CONTENTS % (curconf, newconf)) + '>>' + self.config["log-file"])
AttributeError: dispatch instance has no attribute 'config'


Reproducible: Always
Steps to Reproduce:
1.
2.
3.




laptop ~ # emerge info
Portage 2.0.51-r3 (default-linux/x86/2004.0, gcc-3.4.2, glibc-2.3.4.20041102-r0,
2.6.9-gentoo i686)
=================================================================
System uname: 2.6.9-gentoo i686 Intel(R) Pentium(R) 4 CPU 3.00GHz
Gentoo Base System version 1.6.5
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-2.15.92.0.2-r1,sys-devel/binutils-2.15.92.0.2-r2
Headers:  sys-kernel/linux26-headers-2.6.8.1-r1
Libtools: sys-devel/libtool-1.5.2-r6
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -fweb -ffast-math -march=pentium4 -ftracer -pipe -fomit-frame-pointer "
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown
/usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -fweb -ffast-math -march=pentium4 -ftracer -pipe
-fomit-frame-pointer  -fvisibility-inlines-hidden"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache distlocks fixpackages sandbox sfperms"
GENTOO_MIRRORS="ftp:///ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/
http://gentoo.binarycompass.org http://gentoo.ccccom.com
http://gentoo.llarian.net/ http://mirror.tucdemonic.org/gentoo/"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/ebuilds"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X Xaw3d aalib acpi alsa apm arts artswrappersuid atlas avi berkdb
bitmap-fonts bonobo cddb cdr crypt cups curl dga directfb dnd dv dvd dvdread
emacs encode esd ext-png ext-zlib f77 faad fam fbcon fbdev ffmpeg fftw flac
foomaticdb freetype fs gc gd gd-external gdbm ggi gif gimpprint gnomegphoto2 gpm
gstreamer gtk gtk2 gtkhtml imagemagick imap imlib imlib2 java javascript jdepend
jikes jp2 jpeg jpeg2k junit kde lcms libg++ libwww live mad mikmod mmx mmx2 mng
motif mozdomi mozilla moznocompose moznoirc moznomail mozsvg mozxmlterm mpeg
mplayer ncurses network nls nptl nptlonly offensive oggvorbis opengl oss pam
passfile pcmcia pcre pdflib perl pic plotutils png ppds python qt qtmt quicktime
readline ruby samba sdl slang spell sse sse2 ssl svg svga tcltk tcpd tetex
threads tiff transcode truetype type1 usb vim-with-x wifi wmf x86 xml xml2 xv
xvid zlib"
Comment 1 Andrew D. Keyser (aka Legoguy) 2004-11-06 15:26:19 UTC
Same here, 

Portage 2.0.51-r3 (default-x86-2004.2, gcc-3.4.2, glibc-2.3.4.20041102-r0, 2.6.9-rc4-love1 i686)
=================================================================
System uname: 2.6.9-rc4-love1 i686 Intel(R) Pentium(R) 4 CPU 3.20GHz
Gentoo Base System version 1.6.5
distcc 2.18 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-2.15.92.0.2-r1
Headers:  sys-kernel/linux26-headers-2.6.8.1-r1
Libtools: sys-devel/libtool-1.5.2-r6
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -ftracer -fprefetch-loop-arrays -pipe"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -ftracer -fprefetch-loop-arrays -pipe -fvisibility-inlines-hidden"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache distlocks sandbox"
GENTOO_MIRRORS="http://gentoo.osuosl.org http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X Xaw3d acpi aim alsa apache2 arts audiofile avi berkdb bitmap-fonts cairo cdparanoia cdr crypt cups dba dvd dvdr encode f77 faad flac flash foomaticdb freetype ftp gb gd gdbm gif gimp gimp-print gimpprint glx gnome gphoto2 gpm gstreamer gtk gtk2 gtkhtml hal icq imagemagick imlib jabber jack java joystick jpeg jpeg2k kde ladcca ldap libg++ libwww lzw-tiff mad mbox mhash mikmod mmx mng motif mozilla mpeg msn mysql ncurses nls nptl nptlonly nvidia offensive oggvorbis opengl pam pcmcia pdflib perl php png ppds python qt quicktime readline samba scanner sdl slang snmp socks5 spell sse ssl svg svga tcltk tcpd tga tiff truetype truetype-fonts trusted type1-fonts usb userlocales v4l v4l2 wavelan wmf wxwindows x86 xft xine xml xml2 xmms xprint xrandr xscreensaver xv yahoo zlib"
Comment 2 Ryan Stinnett 2004-11-06 18:07:11 UTC
For now, you can fix this by editing line 222 of dispatch-conf:

Original:
os.system((DIFF_CONTENTS % (curconf, newconf)) + '>>' + self.config["log-file"])

Corrected:
os.system((DIFF_CONTENTS % (curconf, newconf)) + '>>' + self.options["log-file"])
Comment 3 Jason Stubbs (RETIRED) gentoo-dev 2004-11-06 22:08:45 UTC
*** Bug 70264 has been marked as a duplicate of this bug. ***
Comment 4 Jason Stubbs (RETIRED) gentoo-dev 2004-11-06 22:15:52 UTC
Created attachment 43447 [details, diff]
dispatch-conf-typo.patch
Comment 5 Phil Richards 2004-11-08 03:42:41 UTC
Just as a matter of interest, seeing as bug #70264 (raised by me) was closed
as a duplicate of this bug, does this patch to dispatch-conf fix the *other*
failure that I mentioned - namely:

derisoft ~ # equery belongs /usr/sbin/dispatch-conf
[ Searching for file(s) /usr/sbin/dispatch-conf in *... ]
Traceback (most recent call last):
  File "/usr/bin/equery", line 1556, in ?
    cmd.perform(local_opts)
  File "/usr/bin/equery", line 370, in perform
    map(dumpToScreen, matches)
  File "/usr/bin/equery", line 360, in dumpToScreen
    s = pp.cpv(pkg.get_cpv())
AttributeError: 'str' object has no attribute 'get_cpv'

Or is that fixed by some other means?

Phil
Comment 6 Ryan Stinnett 2004-11-11 08:48:22 UTC
Phil: That's a separate bug in equery itself, not dispatch-conf.  Doesn't seem like a duplicate of this bug at all to me.  See http://forums.gentoo.org/viewtopic.php?t=241550 for Genone's confirmation of that bug, which has been fixed in CVS.  Also, that thread includes a temporary fix you can use.
Comment 7 Nicholas Jones (RETIRED) gentoo-dev 2005-02-28 09:29:48 UTC
Fixed and released a while ago.