Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 702694 - games-util/lutris-0.5.4 should RDEPEND on x11-libs/libnotify[introspection] - lutris: ValueError: Namespace Notify not available
Summary: games-util/lutris-0.5.4 should RDEPEND on x11-libs/libnotify[introspection] -...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-13 15:10 UTC by Alexey Mishustin
Modified: 2019-12-15 12:09 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Mishustin 2019-12-13 15:10:10 UTC
$ lutris
Traceback (most recent call last):
  File "/usr/lib/python-exec/python3.6/lutris", line 34, in <module>
    from lutris.gui.application import Application
  File "/usr/lib64/python3.6/site-packages/lutris/gui/application.py", line 51, in <module>
    from .lutriswindow import LutrisWindow
  File "/usr/lib64/python3.6/site-packages/lutris/gui/lutriswindow.py", line 29, in <module>
    from lutris.gui.widgets.services import SyncServiceWindow
  File "/usr/lib64/python3.6/site-packages/lutris/gui/widgets/services.py", line 5, in <module>
    from lutris.gui.widgets.notifications import send_notification
  File "/usr/lib64/python3.6/site-packages/lutris/gui/widgets/notifications.py", line 4, in <module>
    gi.require_version('Notify', '0.7')
  File "/usr/lib64/python3.6/site-packages/gi/__init__.py", line 129, in require_version
    raise ValueError('Namespace %s not available' % namespace)
ValueError: Namespace Notify not available

After adding USE flag introspection to x11-libs/libnotify and re-emerging x11-libs/libnotify the error is gone.

Reproducible: Always