Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 702368 - PYTHON_TARGETS: Remove python_targets_python3_7 python_single_target_python3_7 from use.stable.mask
Summary: PYTHON_TARGETS: Remove python_targets_python3_7 python_single_target_python3...
Status: RESOLVED DUPLICATE of bug 696084
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on: 701116
Blocks:
  Show dependency tree
 
Reported: 2019-12-09 17:36 UTC by Ulenrich
Modified: 2020-03-07 21:22 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ulenrich 2019-12-09 17:36:12 UTC
for amd64 python-3.7.5-r1 is stable! 
But profile mask states otherwise:
--- profiles/arch/amd64/use.stable.mask
# Mike Gilbert <floppym@gentoo.org> (2017-06-08)
# dev-lang/python:3.7 is not stable.
python_targets_python3_7
python_single_target_python3_7
---
(
I was disturbed on my unstable Gentoo, because putting some 
cate-gories/* stable
seemed to have unwanted outcome ignoring available pathon-3.7
)
Comment 1 Brian Evans Gentoo Infrastructure gentoo-dev 2019-12-09 17:42:51 UTC
(In reply to Ulenrich from comment #0)
> for amd64 python-3.7.5-r1 is stable! 
> But profile mask states otherwise:
> --- profiles/arch/amd64/use.stable.mask
> # Mike Gilbert <floppym@gentoo.org> (2017-06-08)
> # dev-lang/python:3.7 is not stable.
> python_targets_python3_7
> python_single_target_python3_7
> ---
> (
> I was disturbed on my unstable Gentoo, because putting some 
> cate-gories/* stable
> seemed to have unwanted outcome ignoring available pathon-3.7
> )

You must understand that *all* arches have to be stable before this is removed.
Comment 2 Ulenrich 2019-12-09 18:23:16 UTC
> You must understand that *all* arches have to be stable before this is removed.
Sorry, I was't aware of this policy
I can imagine a good reason for example with multilib 
when now python-3.7 is still unstable on x86
Comment 3 Ulenrich 2019-12-09 18:26:14 UTC
And a reason for app-office/libreoffice-bin-6.2.8.2
when a USE threads with python-3.6 is used
that doesn't exist with python-3.7 any more
Comment 4 Andreas Sturmlechner gentoo-dev 2020-03-07 21:21:05 UTC
*** Bug 696084 has been marked as a duplicate of this bug. ***
Comment 5 Andreas Sturmlechner gentoo-dev 2020-03-07 21:22:21 UTC

*** This bug has been marked as a duplicate of bug 696084 ***