Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 701398 - dev-util/bazel-1.2.0 failed on C++ compilation of rule '//third_party/grpc:gpr_base'
Summary: dev-util/bazel-1.2.0 failed on C++ compilation of rule '//third_party/grpc:gp...
Status: RESOLVED DUPLICATE of bug 693986
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Zac Medico
Keywords: PullRequest
Depends on:
Reported: 2019-11-28 16:46 UTC by Dale Lukas Peterson
Modified: 2019-12-09 06:21 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---

emerge info (bazel_emerge_info.txt,5.89 KB, text/plain)
2019-11-28 16:47 UTC, Dale Lukas Peterson
emerge -pqv (bazel_emerge_pqv.txt,70 bytes, text/plain)
2019-11-28 16:47 UTC, Dale Lukas Peterson
build log (bazel_build.log,110.88 KB, text/x-log)
2019-11-28 16:47 UTC, Dale Lukas Peterson
environment (bazel_environment.txt,110.64 KB, text/plain)
2019-11-28 16:48 UTC, Dale Lukas Peterson

Note You need to log in before you can comment on or make changes to this bug.
Description Dale Lukas Peterson 2019-11-28 16:46:30 UTC
Failed to emerge dev-util/bazel-1.2.0

Reproducible: Always

Steps to Reproduce:
1. emerge dev-util/bazel-1.2.0
Actual Results:  
Fails the emerge.

Expected Results:  
Built bazel.
Comment 1 Dale Lukas Peterson 2019-11-28 16:47:08 UTC
Created attachment 597676 [details]
emerge info
Comment 2 Dale Lukas Peterson 2019-11-28 16:47:26 UTC
Created attachment 597678 [details]
emerge -pqv
Comment 3 Dale Lukas Peterson 2019-11-28 16:47:44 UTC
Created attachment 597680 [details]
build log
Comment 4 Dale Lukas Peterson 2019-11-28 16:48:04 UTC
Created attachment 597682 [details]
Comment 5 indocomsoft 2019-12-05 09:38:08 UTC
I experience this issue as well. There was a patch that recently got merged into bazel, perhaps we can incorporate this patch?
Comment 6 indocomsoft 2019-12-05 10:35:38 UTC
I created a PR containing this patch at
Comment 7 Hank Leininger 2019-12-05 21:30:37 UTC
Thanks, that patch worked for me as well.
Comment 8 Dale Lukas Peterson 2019-12-09 04:28:47 UTC
This patch worked for me as well.
Comment 9 Larry the Git Cow gentoo-dev 2019-12-09 05:55:56 UTC
The bug has been closed via the following commit(s):

commit 27d3e4549dfcbc89442c54b4e5c602b274284203
Author:     Julius Putra Tanu Setiaji <>
AuthorDate: 2019-12-05 10:28:36 +0000
Commit:     Zac Medico <>
CommitDate: 2019-12-09 05:55:47 +0000

    dev-util/bazel: Add gRPC patch for glibc 2.30
    Package-Manager: Portage-2.3.80, Repoman-2.3.19
    Signed-off-by: Julius Putra Tanu Setiaji <>
    Signed-off-by: Zac Medico <>

 dev-util/bazel/bazel-1.2.0-r1.ebuild         | 113 +++++++++++++++++++++++++++
 dev-util/bazel/files/1.2.0-grpc-gettid.patch |  78 ++++++++++++++++++
 2 files changed, 191 insertions(+)
Comment 10 Zac Medico gentoo-dev 2019-12-09 06:21:48 UTC

*** This bug has been marked as a duplicate of bug 693986 ***