Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 701198 - net-libs/quiche-0.1.0: emake failed: error[E0658]: use of unstable library feature 'duration_float'
Summary: net-libs/quiche-0.1.0: emake failed: error[E0658]: use of unstable library fe...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Craig Andrews
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 694320
  Show dependency tree
 
Reported: 2019-11-26 10:52 UTC by Thomas Deutschmann
Modified: 2019-11-26 20:29 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,12.25 KB, text/plain)
2019-11-26 10:52 UTC, Thomas Deutschmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Deutschmann gentoo-dev Security 2019-11-26 10:52:11 UTC
Created attachment 597554 [details]
build.log

>>> Compiling source in /var/tmp/portage/net-libs/quiche-0.1.0/work/quiche-0.1.0 ...
 * abi_x86_32.x86: running multilib-minimal_abi_src_compile
   Compiling cc v1.0.45
   Compiling libc v0.2.62
   Compiling log v0.4.8
   Compiling spin v0.5.2
   Compiling cfg-if v0.1.10
   Compiling lazy_static v1.4.0
   Compiling untrusted v0.7.0
   Compiling ring v0.16.9
   Compiling cmake v0.1.42
   Compiling quiche v0.1.0 (/var/tmp/portage/net-libs/quiche-0.1.0/work/quiche-0.1.0-abi_x86_32.x86)
error[E0658]: use of unstable library feature 'duration_float'
   --> src/recovery.rs:374:43
    |
374 |                 self.rttvar = self.rttvar.mul_f64(3.0 / 4.0) +
    |                                           ^^^^^^^
    |
    = note: for more information, see https://github.com/rust-lang/rust/issues/54361

error[E0658]: use of unstable library feature 'duration_float'
   --> src/recovery.rs:375:49
    |
375 |                     sub_abs(srtt, adjusted_rtt).mul_f64(1.0 / 4.0);
    |                                                 ^^^^^^^
    |
    = note: for more information, see https://github.com/rust-lang/rust/issues/54361

error[E0658]: use of unstable library feature 'duration_float'
   --> src/recovery.rs:378:26
    |
378 |                     srtt.mul_f64(7.0 / 8.0) + adjusted_rtt.mul_f64(1.0 / 8.0),
    |                          ^^^^^^^
    |
    = note: for more information, see https://github.com/rust-lang/rust/issues/54361

error[E0658]: use of unstable library feature 'duration_float'
   --> src/recovery.rs:378:60
    |
378 |                     srtt.mul_f64(7.0 / 8.0) + adjusted_rtt.mul_f64(1.0 / 8.0),
    |                                                            ^^^^^^^
    |
    = note: for more information, see https://github.com/rust-lang/rust/issues/54361

error[E0658]: use of unstable library feature 'duration_float'
   --> src/recovery.rs:441:51
    |
441 |             cmp::max(self.latest_rtt, self.rtt()).mul_f64(TIME_THRESHOLD);
    |                                                   ^^^^^^^
    |
    = note: for more information, see https://github.com/rust-lang/rust/issues/54361

error: aborting due to 5 previous errors

For more information about this error, try `rustc --explain E0658`.
error: Could not compile `quiche`.

To learn more, run the command again with --verbose.
 * ERROR: net-libs/quiche-0.1.0::gentoo failed (compile phase):
 *   cargo build failed
Comment 1 Thomas Deutschmann gentoo-dev Security 2019-11-26 10:52:37 UTC
Portage 2.3.79 (python 3.6.9-final-0, default/linux/x86/17.0, gcc-9.2.0, glibc-2.29-r2, 4.19.82-gentoo-x86-pre3 i686)
=================================================================
System uname: Linux-4.19.82-gentoo-x86-pre3-i686-Intel-R-_Core-TM-_i7-3770K_CPU_@_3.50GHz-with-gentoo-2.6
KiB Mem:     6147172 total,   2899504 free
KiB Swap:     488276 total,    484180 free
Timestamp of repository gentoo: Tue, 26 Nov 2019 07:26:23 +0000
Head commit of repository gentoo: 251c1b90b8ea013e0ca4175ed66176e6d4608fa7

sh bash 4.4_p23-r1
ld GNU ld (Gentoo 2.32 p2) 2.32.0
app-shells/bash:          4.4_p23-r1::gentoo
dev-lang/perl:            5.28.2-r1::gentoo
dev-lang/python:          2.7.16::gentoo, 3.6.9::gentoo
dev-util/cmake:           3.14.6::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.41.2::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.16.1-r1::gentoo
sys-devel/binutils:       2.32-r1::gentoo
sys-devel/gcc:            9.2.0-r2::gentoo
sys-devel/gcc-config:     2.1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.19::gentoo (virtual/os-headers)
sys-libs/glibc:           2.29-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/gentoo.git
    priority: -1000

ABI="x86"
ABI_X86="32"
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
ACCEPT_PROPERTIES="*"
ACCEPT_RESTRICT="*"
ADA_TARGET="gnat_2018"
ARCH="x86"
BROOT=""
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=pentium4m -mtune=pentium4m -Wno-error=jump-misses-init -Wno-error=sign-compare"
CHOST="i686-pc-linux-gnu"
CHOST_x86="i686-pc-linux-gnu"
COLLISION_IGNORE="/lib/modules/*"
CONFIG_PROTECT="/etc /etc/stunnel/stunnel.conf /usr/share/config /usr/share/gnupg/qualified.txt"
CPU_FLAGS_X86="mmx mmxext sse sse2"
CXXFLAGS="-O2 -pipe -march=pentium4m -mtune=pentium4m -Wno-error=jump-misses-init -Wno-error=sign-compare"
DEFAULT_ABI="x86"
EDITOR="/usr/bin/mcedit"
ELIBC="glibc"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
EPREFIX=""
EROOT="/"
ESYSROOT="/"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs cgroup config-protect-if-modified distlocks downgrade-backup ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -march=i686 -pipe"
GCC_SPECS=""
GRUB_PLATFORMS="efi-32 pc"
GSETTINGS_BACKEND="dconf"
HOME="/root"
INFOPATH="/usr/share/gcc-data/i686-pc-linux-gnu/9.2.0/info:/usr/share/binutils-data/i686-pc-linux-gnu/2.32/info:/usr/share/info"
INPUT_DEVICES="libinput keyboard mouse"
IUSE_IMPLICIT="abi_x86_32 prefix prefix-guest prefix-stack"
KERNEL="linux"
L10N="en en-US de de-DE"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LC_MESSAGES="C"
LC_PAPER="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LIBDIR_x86="lib"
LINGUAS="en de"
LOGNAME="root"
MAIL="/var/mail/root"
MAKEOPTS="--jobs 5 --load-average 7.95"
MANPAGER="manpager"
MULTILIB_ABIS="x86"
NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml"
NOCOLOR="true"
OFFICE_IMPLEMENTATION="libreoffice"
OLDPWD="/tmp"
OPENCL_PROFILE="ocl-icd"
OPENGL_PROFILE="xorg-x11"
PAGER="/usr/bin/less"
PATH="/usr/lib/llvm/8/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin"
PHP_TARGETS="php7-1 php7-2 php7-3"
POSTGRES_TARGETS="postgres10 postgres11"
PWD="/tmp/stable"
PYTHONDONTWRITEBYTECODE="1"
PYTHON_SINGLE_TARGET="python3_6"
PYTHON_TARGETS="python2_7 python3_6"
QT_GRAPHICSSYSTEM="raster"
ROOT="/"
ROOTPATH="/usr/lib/llvm/8/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin"
RUBY_TARGETS="ruby24 ruby25"
SHELL="/bin/bash"
SHLVL="2"
SSH_TTY="/dev/pts/0"
SYSROOT="/"
TERM="tmux-256color"
TMUX="/tmp//tmux-0/default,5828,0"
TMUX_PANE="%2"
TWISTED_DISABLE_WRITING_OF_PLUGIN_CACHE="1"
USER="root"
USERLAND="GNU"
VIDEO_CARDS="vmware"
XDG_CONFIG_DIRS="/etc/xdg"
XDG_DATA_DIRS="/usr/local/share:/usr/share"
Comment 2 Thomas Deutschmann gentoo-dev Security 2019-11-26 10:55:40 UTC
# rustc -V
rustc 1.37.0
Comment 3 Craig Andrews gentoo-dev 2019-11-26 20:24:10 UTC
From https://github.com/cloudflare/quiche/issues/219 it appears rust 1.38 is required.
Comment 4 Craig Andrews gentoo-dev 2019-11-26 20:25:16 UTC
Also, https://github.com/cloudflare/quiche/blob/0.1.0/README.md says 1.38 is required as well.
Comment 5 Larry the Git Cow gentoo-dev 2019-11-26 20:29:11 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=7e893f5bd89ae144c9f443483799d1456496a9e1

commit 7e893f5bd89ae144c9f443483799d1456496a9e1
Author:     Craig Andrews <candrews@gentoo.org>
AuthorDate: 2019-11-26 20:26:12 +0000
Commit:     Craig Andrews <candrews@gentoo.org>
CommitDate: 2019-11-26 20:29:04 +0000

    net-libs/quiche: 0.1.0 requires rust 1.38
    
    Closes: https://bugs.gentoo.org/701198
    Package-Manager: Portage-2.3.79, Repoman-2.3.18
    Signed-off-by: Craig Andrews <candrews@gentoo.org>

 net-libs/quiche/quiche-0.1.0.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)