Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 701054 - =dev-libs/gjs-1.54.3 failed configuration phase (no working SpiderMonkey)
Summary: =dev-libs/gjs-1.54.3 failed configuration phase (no working SpiderMonkey)
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: https://bugs.gentoo.org/701052
Whiteboard:
Keywords: REGRESSION
Depends on: 703538
Blocks: gnome-3.30-stable
  Show dependency tree
 
Reported: 2019-11-24 09:29 UTC by Émeric Maschino
Modified: 2020-01-19 12:02 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,16.10 KB, text/plain)
2019-11-24 09:29 UTC, Émeric Maschino
Details
environment (environment,112.88 KB, text/plain)
2019-11-24 09:29 UTC, Émeric Maschino
Details
config.log (config.log,94.79 KB, text/plain)
2019-11-24 18:33 UTC, Émeric Maschino
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Émeric Maschino 2019-11-24 09:29:22 UTC
Created attachment 597384 [details]
build.log

Hi,

While stabilizing bug #685254, trying to emerge =dev-libs/gjs-1.54.3 failed during the configuration phase on ia64. Relevant part of build.log:

checking if a minimal SpiderMonkey program compiles and runs... no
configure: error: Check if you are using the recommended configuration for
SpiderMonkey. See the file org.gnome.Sdk.json.in in
https://gitlab.gnome.org/GNOME/gnome-sdk-images

This is a regression from =dev-libs/gjs-1.48.7.
This problem is no more with =dev-libs/gjs-1.56.2, but this last one requires me to upgrade from =gnome-base/gnome-shell-3.28.3 to at least =gnome-base/gnome-shell-3.30.2-r2, which I can't because of bug #701052.

Please let me know how I can help further.

Thanks,

     Émeric
Comment 1 Émeric Maschino 2019-11-24 09:29:45 UTC
Created attachment 597386 [details]
environment
Comment 2 Émeric Maschino 2019-11-24 09:30:18 UTC
emerge --info output:

Portage 2.3.76 (python 3.6.9-final-0, default/linux/ia64/17.0/desktop/gnome, gcc-9.2.0, glibc-2.29-r2, 4.19.82-gentoo ia64)
=================================================================
System uname: Linux-4.19.82-gentoo-ia64-Madison-with-gentoo-2.6
KiB Mem:    24983088 total,  21654480 free
KiB Swap:     499696 total,    499696 free
Timestamp of repository gentoo: Wed, 20 Nov 2019 00:45:01 +0000
Head commit of repository gentoo: 32068cf7204c8310cc646c916b2a0128becb79fd
sh bash 4.4_p23-r1
ld GNU ld (Gentoo 2.32 p2) 2.32.0
app-shells/bash:          4.4_p23-r1::gentoo
dev-lang/perl:            5.28.2-r1::gentoo
dev-lang/python:          2.7.16::gentoo, 3.6.9::gentoo
dev-util/cmake:           3.14.6::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.41.2::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.16.1-r1::gentoo
sys-devel/binutils:       2.32-r1::gentoo
sys-devel/gcc:            9.2.0-r2::gentoo
sys-devel/gcc-config:     2.1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.19::gentoo (virtual/os-headers)
sys-libs/glibc:           2.29-r2::gentoo
Repositories:

gentoo
    location: /var/db/repos/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts: 
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: yes

localrepo
    location: /var/db/repos/localrepo
    masters: gentoo

ACCEPT_KEYWORDS="ia64"
ACCEPT_LICENSE="@FREE"
CBUILD="ia64-unknown-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="ia64-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/var/cache/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org/"
LANG="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="fr"
MAKEOPTS="-j3"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa berkdb bindist branding bzip2 cairo cdda cdr cli colord crypt cups cxx dbus dri dts dvdr eds elogind encode evo exif fam flac fortran gdbm gif gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk ia64 iconv icu introspection ipv6 jpeg lcms ldap libnotify libsecret libtirpc mad mng mp3 mp4 mpeg nautilus ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pulseaudio readline sdl spell split-usr ssl startup-notification svg tcpd tiff tracker truetype udev udisks unicode upower usb vorbis wayland wxwidgets x264 xattr xcb xml xv xvid zlib" ADA_TARGET="gnat_2018" ALSA_CARDS="fm801" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput" KERNEL="linux" L10N="fr" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby24" USERLAND="GNU" VIDEO_CARDS="fbdev radeon r300" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 3 Mart Raudsepp gentoo-dev 2019-11-24 11:19:25 UTC
Provide this please to be able to look into it better:

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/dev-libs/gjs-1.54.3/work/gjs-1.54.3/config.log
Comment 4 Émeric Maschino 2019-11-24 18:33:04 UTC
Created attachment 597438 [details]
config.log
Comment 5 Émeric Maschino 2019-11-24 18:34:04 UTC
(In reply to Mart Raudsepp from comment #3)
> Provide this please to be able to look into it better:
> 
> !!! Please attach the following file when seeking support:
> !!! /var/tmp/portage/dev-libs/gjs-1.54.3/work/gjs-1.54.3/config.log

My bad, I totally forgot to attach the file :-S
Please have a look at attachment #597438 [details].
Comment 6 Émeric Maschino 2019-11-27 21:55:56 UTC
So from config.log, the simple conftest.cpp code snippet below is failing:

#include <js/Initialization.h>

int main ()
{
  if (!JS_Init()) exit(1);
  JS_ShutDown();

  return 0;
}

And indeed, recompiling it with the configure-generated command line

g++ -o conftest -O2 -pipe -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/lib/libffi-3.3_rc0/include -I/usr/include/gobject-introspection-1.0 -pthread -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/uuid -include /usr/include/mozjs-60/js/RequiredDefines.h -I/usr/include/mozjs-60 -I/usr/include/nspr  -Wl,-O1 -Wl,--as-needed conftest.cpp -lgirepository-1.0 -lffi -pthread -lgthread-2.0 -lgio-2.0 -lgobject-2.0 -lglib-2.0 -lmozjs-60

leads to a conftest binary failing to initialize JS.

Altering the above code snippet, calling JS_InitWithFailureDiagnostic() in place of JS_Init() returned the following error string at runtime:

js::jit::InitProcessExecutableMemory() failed

I'm not that comfortable with SpiderMonkey architecture/code/structure, but if jit means as in the past, there never was a working JS jit on ia64 and some other exotic arches.

As a check, replacing #include <js/Initialization.h> with #include <jsapi.h> in the above code snippet and recompiling using =dev-lang/spidermonkey-38.3.0 that's also installed on my system with the following command line

g++ -o conftest -O2 -pipe -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/lib/libffi-3.3_rc0/include -I/usr/include/gobject-introspection-1.0 -pthread -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/uuid -include /usr/include/mozjs-38/js/RequiredDefines.h -I/usr/include/mozjs-38 -I/usr/include/nspr  -Wl,-O1 -Wl,--as-needed conftest.cpp -lgirepository-1.0 -lffi -pthread -lgthread-2.0 -lgio-2.0 -lgobject-2.0 -lglib-2.0 -lmozjs-38

yields to a working conftest binary.

So, maybe the culprit is =dev-lang/spidermonkey-60.5.2_p0-r2 and not dev-libs/gjs. That being said, something has changed between =dev-libs/gjs-1.54.3 and =dev-libs/gjs-1.56.2, as the latter emerges successfully.
Comment 7 Agostino Sarubbo gentoo-dev 2019-12-27 17:22:03 UTC
I have the same issue, but I got success when I run the conftest manually:

ia64 (CHROOT) ~ $ g++ -o conftest -O2 -pipe -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/lib/libffi-3.3_rc0/include -I/usr/include/gobject-introspection-1.0 -pthread -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/uuid -include /usr/include/mozjs-60/js/RequiredDefines.h -I/usr/include/mozjs-60 -I/usr/include/nspr  -Wl,-O1 -Wl,--as-needed conftest.cpp -lgirepository-1.0 -lffi -pthread -lgthread-2.0 -lgio-2.0 -lgobject-2.0 -lglib-2.0 -lmozjs-60 ; echo $?
0
ia64 (CHROOT) ~ $
Comment 8 Agostino Sarubbo gentoo-dev 2019-12-27 17:27:02 UTC
I forgot to mention that confest return 0 or 1 randomly without any useful info:

ia64 (CHROOT) ~ $ ./conftest ;echo $?
1
ia64 (CHROOT) ~ $ ./conftest ;echo $?
0
ia64 (CHROOT) ~ $ ./conftest ;echo $?
0
ia64 (CHROOT) ~ $ ./conftest ;echo $?
1
ia64 (CHROOT) ~ $ ./conftest ;echo $?
1
ia64 (CHROOT) ~ $ ./conftest ;echo $?
0
ia64 (CHROOT) ~ $
Comment 9 Agostino Sarubbo gentoo-dev 2019-12-30 11:11:29 UTC
Since it fails randomly, I tried to emerge it in a while true statement and I got success:

ia64 (CHROOT) ~ $ qlop -mv | tail -1
2019-12-30T12:13:25 >>> dev-libs/gjs-1.54.3
ia64 (CHROOT) ~ $ 


@gnome
Can this bug be forwarded to upstream?
Comment 10 Émeric Maschino 2020-01-19 12:02:36 UTC
Pending resolution of bug #703538 (e.g. with patch proposed in https://bugs.gentoo.org/703538#c6), I can confirm that dev-libs/gjs (1.56.2 if it does matter) installed flawlessly.

It however fails to pass installed-tests/scripts/testCommandLine, but I'll report this issue in a separate BR as it's not related to this one.