Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 699876 - <dev-db/mysql-{5.7.29,8.0.19}: multiple vulnerabilities (CVE-2019-{2938,2974})
Summary: <dev-db/mysql-{5.7.29,8.0.19}: multiple vulnerabilities (CVE-2019-{2938,2974})
Status: IN_PROGRESS
Alias: None
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Security
URL:
Whiteboard: B3 [stable cve]
Keywords:
Depends on: CVE-2020-2570, CVE-2020-2572, CVE-2020-2573, CVE-2020-2577, CVE-2020-2579, CVE-2020-2580, CVE-2020-2584, CVE-2020-2588, CVE-2020-2589, CVE-2020-2627, CVE-2020-2660, CVE-2020-2679, CVE-2020-2686, CVE-2020-2694, CVE-2020-2759, CVE-2020-2761, CVE-2020-2762, CVE-2020-2763, CVE-2020-2765, CVE-2020-2768, CVE-2020-2770, CVE-2020-2774, CVE-2020-2779, CVE-2020-2780, CVE-2020-2790, CVE-2020-2804, CVE-2020-2806, CVE-2020-2853, CVE-2020-2875, CVE-2020-2892, CVE-2020-2893, CVE-2020-2895, CVE-2020-2896, CVE-2020-2897, CVE-2020-2898, CVE-2020-2901, CVE-2020-2903, CVE-2020-2904, CVE-2020-2921, CVE-2020-2922, CVE-2020-2923, CVE-2020-2924, CVE-2020-2925, CVE-2020-2926, CVE-2020-2928, CVE-2020-2930, CVE-2020-2933, CVE-2020-2934 709624
Blocks: CVE-2019-2938, CVE-2019-2974
  Show dependency tree
 
Reported: 2019-11-11 19:09 UTC by GLSAMaker/CVETool Bot
Modified: 2020-05-21 23:13 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description GLSAMaker/CVETool Bot gentoo-dev 2019-11-11 19:09:01 UTC
CVE-2019-2974 (https://nvd.nist.gov/vuln/detail/CVE-2019-2974):
  Vulnerability in the MySQL Server product of Oracle MySQL (component:
  Server: Optimizer). Supported versions that are affected are 5.6.45 and
  prior, 5.7.27 and prior and 8.0.17 and prior. Easily exploitable
  vulnerability allows low privileged attacker with network access via
  multiple protocols to compromise MySQL Server. Successful attacks of this
  vulnerability can result in unauthorized ability to cause a hang or
  frequently repeatable crash (complete DOS) of MySQL Server.

CVE-2019-2938 (https://nvd.nist.gov/vuln/detail/CVE-2019-2938):
  Vulnerability in the MySQL Server product of Oracle MySQL (component:
  InnoDB). Supported versions that are affected are 5.7.27 and prior and
  8.0.17 and prior. Difficult to exploit vulnerability allows high privileged
  attacker with network access via multiple protocols to compromise MySQL
  Server. Successful attacks of this vulnerability can result in unauthorized
  ability to cause a hang or frequently repeatable crash (complete DOS) of
  MySQL Server.
Comment 1 Sam James gentoo-dev Security 2020-03-19 20:59:20 UTC
@maintainer(s), please cleanup
Comment 2 Sam James gentoo-dev Security 2020-03-19 21:05:12 UTC
(In reply to sam_c (Security Padawan) from comment #1)
> @maintainer(s), please cleanup

sorry, no, please see bug 709624. waiting on ia64, ppc, arm64.
Comment 3 NATTkA bot gentoo-dev 2020-04-12 19:29:06 UTC
Resetting sanity check; package list is empty or all packages are done.