Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 699848 (CVE-2019-14853, CVE-2019-14859) - <dev-python/ecdsa-0.13.3: multiple vulnerabilities (CVE-2019-{14853,14859})
Summary: <dev-python/ecdsa-0.13.3: multiple vulnerabilities (CVE-2019-{14853,14859})
Status: IN_PROGRESS
Alias: CVE-2019-14853, CVE-2019-14859
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo Security
URL:
Whiteboard: B3 [stable?]
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-11 17:06 UTC by GLSAMaker/CVETool Bot
Modified: 2019-11-27 13:33 UTC (History)
4 users (show)

See Also:
Package list:
dev-python/ecdsa-0.14.1
Runtime testing required: No
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description GLSAMaker/CVETool Bot gentoo-dev 2019-11-11 17:06:53 UTC
CVE-2019-14853 (https://nvd.nist.gov/vuln/detail/CVE-2019-14853):
  A flaw was found in python-ecdsa. Unexpected and undocumented exceptions can
  be raised during signature decoding may lead to denial of service in some
  cases. All the versions between at least 0.5 and 0.13.2 are thought to be
  vulnerable.

CVE-2019-14859 (https://nvd.nist.gov/vuln/detail/CVE-2019-14859):
  A flaw was found in python-ecdsa before 0.13.3. The library is not verifying
  if the signatures actually use DER encoding for the signatures. This makes
  the signatures malleable and exposes use cases that further sign the
  signatures. In particular bitcoin.
Comment 1 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-11-11 17:15:48 UTC
I don't see any <-deps, so let's stabilize 0.14.1.
Comment 2 Luke-Jr 2019-11-11 19:54:16 UTC
(In reply to GLSAMaker/CVETool Bot from comment #0)
> CVE-2019-14853 (https://nvd.nist.gov/vuln/detail/CVE-2019-14853):
>   A flaw was found in python-ecdsa. Unexpected and undocumented exceptions
> can
>   be raised during signature decoding may lead to denial of service in some
>   cases. All the versions between at least 0.5 and 0.13.2 are thought to be
>   vulnerable.

What software is actually affected by this?

> CVE-2019-14859 (https://nvd.nist.gov/vuln/detail/CVE-2019-14859):
>   A flaw was found in python-ecdsa before 0.13.3. The library is not
> verifying
>   if the signatures actually use DER encoding for the signatures. This makes
>   the signatures malleable and exposes use cases that further sign the
>   signatures. In particular bitcoin.

Eh? DER signatures are always malleable last I checked...? Why the claim this affects Bitcoin? Bitcoin doesn't use Python, and does expect malleable signatures.
Comment 3 Agostino Sarubbo gentoo-dev 2019-11-12 10:07:41 UTC
x86 stable
Comment 4 Agostino Sarubbo gentoo-dev 2019-11-12 10:13:59 UTC
sparc stable
Comment 5 Agostino Sarubbo gentoo-dev 2019-11-12 15:09:19 UTC
ppc64 stable
Comment 6 Agostino Sarubbo gentoo-dev 2019-11-13 07:41:43 UTC
ppc stable
Comment 7 Agostino Sarubbo gentoo-dev 2019-11-13 07:45:57 UTC
amd64 stable
Comment 8 Rolf Eike Beer 2019-11-13 21:47:14 UTC
hppa stable
Comment 9 Agostino Sarubbo gentoo-dev 2019-11-14 11:58:05 UTC
ia64 stable
Comment 10 Matt Turner gentoo-dev 2019-11-22 16:23:20 UTC
alpha stable
Comment 11 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-11-27 13:33:38 UTC
arm stable