Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 699242 - x11-libs/gtk+-3.24.8 - ld: /usr/lib/libatk-bridge-2.0.so: error adding symbols: file in wrong format
Summary: x11-libs/gtk+-3.24.8 - ld: /usr/lib/libatk-bridge-2.0.so: error adding symbol...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: no-symlink-lib
  Show dependency tree
 
Reported: 2019-11-03 16:30 UTC by John Covici
Modified: 2019-11-17 22:07 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build log for gtk+3.24.8 (gtk-build.zip,108.25 KB, application/zip)
2019-11-03 16:39 UTC, John Covici
Details
emerge --info (emerge-info.txt,16.69 KB, text/plain)
2019-11-03 16:42 UTC, John Covici
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Covici 2019-11-03 16:30:01 UTC
can no longer compile x11-libs/gtk+ during last step of migration to 17.1 profile

Reproducible: Always

Steps to Reproduce:
followed steps in news item 63 for migration to 17.1 profile.  I started out with 17.0 and followed steps and got stuck in step 11 where I could no longer compile x11-libs/gtk+ 2.24 or 3.24.8.1.
2.
3.
Actual Results:  
cannot emerge those two packages as described above.

Expected Results:  
should be able to emerge x11-libs/gtk+
Comment 1 John Covici 2019-11-03 16:39:59 UTC
Created attachment 594960 [details]
build log for gtk+3.24.8
Comment 2 John Covici 2019-11-03 16:42:02 UTC
Created attachment 594962 [details]
emerge --info
Comment 3 John Covici 2019-11-03 16:50:22 UTC
A bit more information.  In order to even get this far with those two packages, I had to copy two .la files from /usr/lib64 to /usr, otherwise the compile was looking for them.  They are: libatspi.la and libatk.la .
Comment 4 Mart Raudsepp gentoo-dev 2019-11-17 22:07:45 UTC
There should be no such *.la files for years now. Not sure what's up with your system there.