Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 699228 - net-misc/mikutter-3.9.6 version bump - and please add IUSE ruby26
Summary: net-misc/mikutter-3.9.6 version bump - and please add IUSE ruby26
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Naohiro Aota
URL: https://mikutter.hachune.net/download/
Whiteboard:
Keywords:
Depends on:
Blocks: 560770
  Show dependency tree
 
Reported: 2019-11-03 13:14 UTC by Ulenrich
Modified: 2020-08-04 18:16 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
mikutter-386_to_396.patch (mikutter-386_to_396.patch,910 bytes, patch)
2019-11-03 13:58 UTC, Ulenrich
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ulenrich 2019-11-03 13:14:23 UTC
a neewer Version net-misc/mikutter-3.9.6
-----------------
I came to this version bump because I wanted to 
emerge net-misc/mikutter-3.8.6 
but have installed dev-lang/ruby-2.6.5
------------ which gives this error :
!!! The ebuild selected to satisfy "net-misc/mikutter" has unmet requirements.
- net-misc/mikutter-3.8.6::gentoo USE="libnotify -test" ABI_X86="(64)" RUBY_TARGETS="-ruby24 -ruby25"



Reproducible: Always
Comment 1 Ulenrich 2019-11-03 13:58:29 UTC
Created attachment 594952 [details, diff]
mikutter-386_to_396.patch

The version bump needs this simple patch to successfully emerge:
---
[ebuild  N     ] net-misc/mikutter-3.9.6::pmaci  USE="libnotify -test" RUBY_TARGETS="-ruby25 ruby26" 0 KiB

Total: 1 package (1 new), Size of downloads: 0 KiB

Would you like to merge these packages? [Yes/No] y
>>> Verifying ebuild manifests
>>> Emerging (1 of 1) net-misc/mikutter-3.9.6::pmaci
>>> Installing (1 of 1) net-misc/mikutter-3.9.6::pmaci
>>> Recording net-misc/mikutter in "world" favorites file...
Comment 2 Larry the Git Cow gentoo-dev 2020-08-04 18:16:00 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=f417257a3009152d20ec385fc6c467c5cd6cbac1

commit f417257a3009152d20ec385fc6c467c5cd6cbac1
Author:     Naohiro Aota <naota@gentoo.org>
AuthorDate: 2020-08-04 18:12:30 +0000
Commit:     Naohiro Aota <naota@gentoo.org>
CommitDate: 2020-08-04 18:14:51 +0000

    net-misc/mikutter: version bump and drop old
    
    This bump also added ruby26 support and moved to newer dev-ruby/json
    slot.
    
    Closes: https://bugs.gentoo.org/575186
    Closes: https://bugs.gentoo.org/699228
    Closes: https://bugs.gentoo.org/713480
    Package-Manager: Portage-2.3.103, Repoman-2.3.23
    Signed-off-by: Naohiro Aota <naota@gentoo.org>

 net-misc/mikutter/Manifest                         |  2 +-
 net-misc/mikutter/files/mikutter                   |  2 +-
 ...mikutter-3.8.6.ebuild => mikutter-4.0.6.ebuild} | 49 +++++++++++-----------
 net-misc/mikutter/mikutter-9999.ebuild             | 49 +++++++++++-----------
 4 files changed, 50 insertions(+), 52 deletions(-)