Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 698954 - >=dev-java/javatoolkit-0.6.1 breaks dev-java/oracle-javamail-1.5.6: ("-push-to-maven-init" does not exist in the project "JavaMail")
Summary: >=dev-java/javatoolkit-0.6.1 breaks dev-java/oracle-javamail-1.5.6: ("-push-t...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Java team
URL:
Whiteboard:
Keywords:
: 733844 (view as bug list)
Depends on:
Blocks: 699102
  Show dependency tree
 
Reported: 2019-10-30 20:28 UTC by Toralf Förster
Modified: 2020-11-05 21:48 UTC (History)
13 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.26 KB, text/plain)
2019-10-30 20:28 UTC, Toralf Förster
Details
dev-java:oracle-javamail-1.5.6:20191030-195347.log (dev-java:oracle-javamail-1.5.6:20191030-195347.log,2.41 KB, text/plain)
2019-10-30 20:28 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,133.54 KB, text/plain)
2019-10-30 20:28 UTC, Toralf Förster
Details
environment (environment,152.58 KB, text/plain)
2019-10-30 20:28 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,11.75 KB, application/x-bzip)
2019-10-30 20:28 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,1.33 KB, application/x-bzip)
2019-10-30 20:28 UTC, Toralf Förster
Details
Patch for javatoolkit (javatoolkit-sax_external_entities.patch,5.56 KB, patch)
2020-10-19 18:06 UTC, Arfrever Frehtes Taifersar Arahesis
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2019-10-30 20:28:26 UTC
 * ERROR: dev-java/oracle-javamail-1.5.6::gentoo failed (compile phase):
 *   eant failed
 * 

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop_gnome_systemd-20191027-182629

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.2.0 *

clang:
clang version 9.0.0 (tags/RELEASE_900/final)
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/9/bin
llvm:
9.0.0
Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *

java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.13.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

repository:
==> /var/db/repos/gentoo/metadata/timestamp.chk <==
Wed, 30 Oct 2019 18:45:58 +0000

emerge -qpvO dev-java/oracle-javamail
[ebuild  N    ] dev-java/oracle-javamail-1.5.6  USE="source -doc"
Comment 1 Toralf Förster gentoo-dev 2019-10-30 20:28:29 UTC
Created attachment 594590 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2019-10-30 20:28:32 UTC
Created attachment 594592 [details]
dev-java:oracle-javamail-1.5.6:20191030-195347.log
Comment 3 Toralf Förster gentoo-dev 2019-10-30 20:28:34 UTC
Created attachment 594594 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2019-10-30 20:28:37 UTC
Created attachment 594596 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2019-10-30 20:28:40 UTC
Created attachment 594598 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2019-10-30 20:28:43 UTC
Created attachment 594600 [details]
logs.tbz2
Comment 7 Miroslav Šulc gentoo-dev 2019-10-30 20:43:29 UTC
this is obviously caused by the new javatoolkit. just tested that, 0.3.0-r9 works fine, 0.6.1+ breaks oracle-javamail.
Comment 8 Sam James archtester gentoo-dev Security 2020-07-25 14:39:04 UTC
*** Bug 733844 has been marked as a duplicate of this bug. ***
Comment 9 charles17 2020-08-10 11:01:19 UTC
(In reply to Miroslav Šulc from comment #7)
> this is obviously caused by the new javatoolkit. just tested that, 0.3.0-r9
> works fine, 0.6.1+ breaks oracle-javamail.


But, is it really caused by javatoolkit? Or by something else?

ebuild /var/db/repos/gentoo/dev-java/oracle-javamail/oracle-javamail-1.5.6.ebuild clean unpack
 * oracle-javamail-1.5.6.zip BLAKE2B SHA512 size ;-) ...                                                                                                                                                                                                                                                                [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                                                                                                                                                                                    [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                                                                                                                                                                                  [ ok ]
 * Using: openjdk-8
>>> Unpacking source...
>>> Unpacking oracle-javamail-1.5.6.zip to /var/tmp/portage/dev-java/oracle-javamail-1.5.6/work
>>> Source unpacked in /var/tmp/portage/dev-java/oracle-javamail-1.5.6/work


Then, directly after unpacking:

grep -nir push-to-maven /var/tmp/portage/
/var/tmp/portage/dev-java/oracle-javamail-1.5.6/work/mbox.xml:216:    <target name="push-to-maven-prepare" depends="-push-to-maven-init, mboxjar"
/var/tmp/portage/dev-java/oracle-javamail-1.5.6/work/mbox.xml:217:        description="creates an image for the 'push-to-maven' goal">
/var/tmp/portage/dev-java/oracle-javamail-1.5.6/work/mbox.xml:226:    <target name="push-to-maven" depends="push-to-maven-prepare"
/var/tmp/portage/dev-java/oracle-javamail-1.5.6/work/build.xml:598:    <target name="push-to-maven-prepare" depends="-push-to-maven-init, jar, src"
/var/tmp/portage/dev-java/oracle-javamail-1.5.6/work/build.xml:599:        description="creates an image for the 'push-to-maven' goal">
/var/tmp/portage/dev-java/oracle-javamail-1.5.6/work/build.xml:608:    <target name="push-to-maven" depends="push-to-maven-prepare"
/var/tmp/portage/dev-java/oracle-javamail-1.5.6/work/ant-common.xml:155:<target name="-push-to-maven-init" description="define a task for pushing bits to the maven repository">
Comment 10 Miroslav Šulc gentoo-dev 2020-08-10 11:10:59 UTC
yes, and then rewrite breaks the build.xml. anyway, we have a guy who works on a gsoc project that would make packaging java packages much easier and it would also avoid rewriting build.xml files so it would solve many of our problems.
Comment 11 Larry the Git Cow gentoo-dev 2020-10-19 08:42:49 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=bb648cee79874097b2f6f1d020e14049757c8a71

commit bb648cee79874097b2f6f1d020e14049757c8a71
Author:     Georgy Yakovlev <gyakovlev@gentoo.org>
AuthorDate: 2020-10-19 08:33:03 +0000
Commit:     Georgy Yakovlev <gyakovlev@gentoo.org>
CommitDate: 2020-10-19 08:33:18 +0000

    dev-java/oracle-javamail: revbump, attempt to fix with new javatoolkit
    
    Bug: https://bugs.gentoo.org/698954
    Package-Manager: Portage-3.0.8, Repoman-3.0.2
    Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>

 .../oracle-javamail-1.5.6-r1.ebuild                | 45 ++++++++++++++++++++++
 1 file changed, 45 insertions(+)
Comment 12 Arfrever Frehtes Taifersar Arahesis 2020-10-19 18:06:37 UTC
Created attachment 667154 [details, diff]
Patch for javatoolkit

build.xml of dev-java/oracle-javamail-1.5.6 contains:

<!DOCTYPE project [
  <!ENTITY commonBuild SYSTEM "ant-common.xml">
]>
...
    &commonBuild;

And ant-common.xml contains necessary code.


Python xml.sax module by default does not expand external entities since
Python 3.6.7, 3.7.1 and 3.8.0:
https://bugs.python.org/issue17239
3.6: https://github.com/python/cpython/commit/582d188e6e3487180891f1fc457a80dec8be26a8
3.7: https://github.com/python/cpython/commit/394e55a9279d17240ef6fe85d3b4ea3fe7b6dff5
3.8: https://github.com/python/cpython/commit/17b1d5d4e36aa57a9b25a0e694affbd1ee637e45
Comment 13 Larry the Git Cow gentoo-dev 2020-11-05 21:26:02 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/proj/javatoolkit.git/commit/?id=5480034ddf29a050671aa22effdd1cefb1a97f55

commit 5480034ddf29a050671aa22effdd1cefb1a97f55
Author:     Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
AuthorDate: 2020-10-19 16:00:00 +0000
Commit:     Patrice Clement <monsieurp@gentoo.org>
CommitDate: 2020-11-05 21:05:44 +0000

    allow expanding external entities through SAX parser.
    
    Python xml.sax module by default does not expand external entities since
    Python 3.6.7, 3.7.1 and 3.8.0:
    https://bugs.python.org/issue17239
    3.6: https://github.com/python/cpython/commit/582d188e6e3487180891f1fc457a80dec8be26a8
    3.7: https://github.com/python/cpython/commit/394e55a9279d17240ef6fe85d3b4ea3fe7b6dff5
    3.8: https://github.com/python/cpython/commit/17b1d5d4e36aa57a9b25a0e694affbd1ee637e45
    
    build.xml files may contain external entities resolving to other .xml files
    in given package.
    
    Closes: https://bugs.gentoo.org/698954
    Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
    Signed-off-by: Patrice Clement <monsieurp@gentoo.org>

 src/py/javatoolkit/xml/SaxRewriter.py | 10 ++++----
 src/py/javatoolkit/xml/sax.py         | 44 +++++++++++++++++++++++++++++++++++
 src/py/xml-rewrite-2.py               | 17 ++++++++------
 3 files changed, 60 insertions(+), 11 deletions(-)
Comment 14 Larry the Git Cow gentoo-dev 2020-11-05 21:48:42 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d1252b96869bfea1a0326b55717db18cb775683e

commit d1252b96869bfea1a0326b55717db18cb775683e
Author:     Patrice Clement <monsieurp@gentoo.org>
AuthorDate: 2020-11-05 21:48:27 +0000
Commit:     Patrice Clement <monsieurp@gentoo.org>
CommitDate: 2020-11-05 21:48:38 +0000

    dev-java/javatoolkit: version bump.
    
    Bug: https://bugs.gentoo.org/698954
    Package-Manager: Portage-3.0.8, Repoman-3.0.2
    Signed-off-by: Patrice Clement <monsieurp@gentoo.org>

 dev-java/javatoolkit/Manifest                 |  1 +
 dev-java/javatoolkit/javatoolkit-0.6.4.ebuild | 28 +++++++++++++++++++++++++++
 2 files changed, 29 insertions(+)