Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 698726 - virtual/libudev-232-r1 drops sys-fs/eudev as a valid provider
Summary: virtual/libudev-232-r1 drops sys-fs/eudev as a valid provider
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: udev maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-28 08:18 UTC by Norman Back
Modified: 2019-10-29 14:58 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Norman Back 2019-10-28 08:18:20 UTC
virtual/libudev-232-r1 removes sys-fs/eudev 
Is eudev no longer supported?

Reproducible: Always

Steps to Reproduce:
1. emerge -1av virtual/libudev
2.
3.
Actual Results:  
portage attempts to unmask udev

Expected Results:  
virtual/libudev emerges with eudev
Comment 1 Norman Back 2019-10-28 08:19:14 UTC
emerge --info
Portage 2.3.76 (python 2.7.16-final-0, default/linux/amd64/17.1/desktop/plasma, gcc-8.3.0, glibc-2.29-r2, 5.3.7-gentoo x86_64)
=================================================================
System uname: Linux-5.3.7-gentoo-x86_64-AMD_Ryzen_9_3900X_12-Core_Processor-with-gentoo-2.6
KiB Mem:    65801772 total,  50731972 free
KiB Swap:   58720236 total,  58720236 free
Timestamp of repository gentoo: Mon, 28 Oct 2019 02:15:01 +0000
Head commit of repository gentoo: 765d55fb42a3ace7ca370355f9497e66dbfbd48a
sh bash 4.4_p23-r1
ld GNU ld (Gentoo 2.32 p2) 2.32.0
distcc 3.3.3 x86_64-pc-linux-gnu [disabled]
ccache version 3.7.4 [disabled]
app-shells/bash:          4.4_p23-r1::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.28.2-r1::gentoo
dev-lang/python:          2.7.16::gentoo, 3.6.9::gentoo
dev-util/ccache:          3.7.4::gentoo
dev-util/cmake:           3.14.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.41.2::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.13.4-r2::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.32-r1::gentoo
sys-devel/gcc:            8.3.0-r1::gentoo
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.19::gentoo (virtual/os-headers)
sys-libs/glibc:           2.29-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://datastoreone/gentoo-portage
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: yes
    sync-rsync-extra-opts: 
    sync-rsync-verify-max-age: 24

local
    location: /usr/local/portage
    masters: gentoo
    priority: 0

ikelos
    location: /var/lib/layman/ikelos
    masters: gentoo
    priority: 50

vmware
    location: /var/lib/layman/vmware
    masters: gentoo
    priority: 50

Installed sets: @kernels
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -mtune=amdfam10 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.3/ext-active/ /etc/php/cgi-php7.3/ext-active/ /etc/php/cli-php7.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=amdfam10 -mtune=amdfam10 -O2 -pipe"
DISTDIR="/mnt/portage.autofs/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y -j52 --load-average=52 --quiet-build=y"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch parallel-install pid-sandbox preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.leaseweb.com/gentoo/ http://mirror.bytemark.co.uk/gentoo/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo http://gentoo.modulix.net/gentoo/ http://gentoo.mirrors.ovh.net/gentoo-distfiles/"
LANG="en_GB.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_GB"
MAKEOPTS="-j52 --load-average=52"
PKGDIR="/mnt/portage.autofs/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git --exclude=lost+found/"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac accessibility acl acpi activities aes alsa amarok amd64 amr authdaemond avx bash-completion berkdb bluetooth bluray branding bzip2 cairo caps cdda cdr cli consolekit crypt cups cxx dbus declarative dri dts dv dvd dvdr dvdread emboss encode exif fam flac fma3 fma4 fortran gdbm gif glamor gpm gtk iconv icu ieee1394 ipv6 jpeg jumbo-build kde kipi kwallet lcms ldap libnotify libtirpc lm-sensors lm_sensors lock mad mmx mmxext mng mp3 mp4 mpeg multilib mysql ncurses network nls nptl ofx ogg opencl opengl openmp oss pam pango pcre pdf phonon plasma png policykit popcnt ppds pulseaudio qml qt3 qt5 readline samba sasl sdl seccomp semantic-desktop session spell split-usr sse sse2 sse3 sse4_1 sse4_2 sse4a ssl ssse3 startup-notification svg tcpd thunar tiff truetype udev udisks uk_bleb uk_rt unicode upower usb v4l v4l2 vdpau vorbis widgets wxwidgets x264 xattr xcb xcomposite xinerama xml xop xv xvid xvmc zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias cgi cgid slotmem_shm unixd access_compat authz_core socache_shmcb authn_core" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx fma3 fma4 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 xop" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-32 efi-64 pc multiboot mount" INPUT_DEVICES="evdev" KERNEL="linux" L10N="en en-GB" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby24 ruby25" SANE_BACKENDS="hp5590 hp net abaton agfafocus apple artec artec_eplus48u as6e avision bh canon canon630u canon_dr canon_pp cardscan coolscan coolscan2 coolscan3 dc210 dc240 dc25 dell1600n_net dmc epjitsu epson epson2 fujitsu genesys gt68xx hp3500 hp3900 hp4200 hp5400 hpljm1005 hpsj5s hs2p ibm kodak kvs1025 kvs20xx leo lexmark ma1509 magicolor matsushita microtek microtek2 mustek mustek_pp mustek_usb nec niash p5 pie pixma plustek plustek_pp pnm qcam ricoh rts8891 s9036 sceptre sharp sm3600 sm3840 snapscan sp15c st400 stv680 tamarack teco1 teco2 teco3 test u12 umax umax1220u umax_pp xerox_mfp" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Norman Back 2019-10-28 08:21:52 UTC
reverting to virtual/libudev-232 resolves the issue.
Comment 3 Ionen Wolkens 2019-10-28 08:46:20 UTC
This is fixed in virtual/libudev-r2 but isn't marked stable, bug #698698 is of interest in that regard.
Comment 4 needle 2019-10-28 08:51:17 UTC
Confirmed. This happens here as well
Comment 5 Anthony Basile gentoo-dev 2019-10-28 11:56:31 UTC
(In reply to Norman Back from comment #0)
> virtual/libudev-232-r1 removes sys-fs/eudev 
> Is eudev no longer supported?
> 

eudev is supported and will continue to be supported.  Please see bug #698698.  As arches are stabilized, I'll add them to virtual/libudev-232-r2 and that should fix this problem.
Comment 6 Anthony Basile gentoo-dev 2019-10-28 12:08:29 UTC
(In reply to Anthony Basile from comment #5)
> (In reply to Norman Back from comment #0)
> > virtual/libudev-232-r1 removes sys-fs/eudev 
> > Is eudev no longer supported?
> > 
> 
> eudev is supported and will continue to be supported.  Please see bug
> #698698.  As arches are stabilized, I'll add them to virtual/libudev-232-r2
> and that should fix this problem.

I just marked virtual/libudev-232-r2 stable for amd64 and x86. Can people confirm that the problem has been resolved on those two arches.
Comment 7 Manuel Mommertz 2019-10-28 13:23:35 UTC
For amd64 I can confirm that the problem is gone. Update just finished without any problems. Thanks!
Comment 8 Anton Bolshakov 2019-10-28 14:46:43 UTC
The current stable tree is broken. Please sync stabilization and do it at one go.
Comment 9 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-10-28 14:50:43 UTC
(In reply to Anton Bolshakov from comment #8)
> The current stable tree is broken. Please sync stabilization and do it at
> one go.

It is not broken.  It simply doesn't support eudev anymore.  This may change in the future but doesn't change the fact that eudev is barely alive.
Comment 10 Anthony Basile gentoo-dev 2019-10-28 16:45:45 UTC
(In reply to Michał Górny from comment #9)
> (In reply to Anton Bolshakov from comment #8)
> > The current stable tree is broken. Please sync stabilization and do it at
> > one go.
> 
> It is not broken.  It simply doesn't support eudev anymore.  This may change
> in the future but doesn't change the fact that eudev is barely alive.

eudev is being maintained.
Comment 11 Anton Bolshakov 2019-10-29 00:48:44 UTC
For users, it doesn't really mater if it's being maintained or not.
I run Gentoo on a server and the server update was broken today. To its worst, the error was related to system packages. I spent around an hour trying to figure out what's wrong.

Please do not break stable tree.
Comment 12 Mike Gilbert gentoo-dev 2019-10-29 02:16:48 UTC
virtual/libudev-232-r2 (and eventually -r3) are being stabilized, so closing this.
Comment 13 UlvHare 2019-10-29 07:05:18 UTC
(In reply to Mike Gilbert from comment #12)
> virtual/libudev-232-r2 (and eventually -r3) are being stabilized, so closing
> this.
Thank you very much!
It was a big trouble for me yesterday (https://forums.gentoo.org/viewtopic-t-1103396.html)

(In reply to Anthony Basile from comment #6)
> I just marked virtual/libudev-232-r2 stable for amd64 and x86. Can people
> confirm that the problem has been resolved on those two arches.
Yes. Confirm for amd64.

(In reply to Michał Górny from comment #9)
> (In reply to Anton Bolshakov from comment #8)
> > The current stable tree is broken. Please sync stabilization and do it at
> > one go.
> 
> It is not broken.  It simply doesn't support eudev anymore.  This may change
> in the future but doesn't change the fact that eudev is barely alive.
eudev is default, isn't it? Any alternatives for OpenRC?
Comment 14 Fabian Groffen gentoo-dev 2019-10-29 09:42:38 UTC
(In reply to Mike Gilbert from comment #12)
> virtual/libudev-232-r2 (and eventually -r3) are being stabilized, so closing
> this.

This is not stabilised on all platforms eudev is stable, so this is not fixed at all.  It still breaks my ppc64 stable deptree.

(In reply to Michał Górny from comment #9)
> (In reply to Anton Bolshakov from comment #8)
> > The current stable tree is broken. Please sync stabilization and do it at
> > one go.
> 
> It is not broken.  It simply doesn't support eudev anymore.  This may change
> in the future but doesn't change the fact that eudev is barely alive.

The deptree is broken, which basically is a (QA) violation.
Comment 15 Mike Gilbert gentoo-dev 2019-10-29 14:56:59 UTC
(In reply to Fabian Groffen from comment #14)

The deptree was never tehnically broken. sys-fs/udev could satisfy it, or an older version of virtual/libudev could be installed.

Portage just isn't able to figure out those solutions on its own.

Regardless, appropriate actions are being taken to remedy the problem, and there is nothing actionable on this bug report. Please do not re-open it again.
Comment 16 Mike Gilbert gentoo-dev 2019-10-29 14:58:38 UTC
(In reply to UlvHare from comment #13)
> eudev is default, isn't it? Any alternatives for OpenRC?

sys-fs/udev is there specifically for people using OpenRC.

sys-apps/systemd may also be used as a libudev provider with OpenRC, provided you disable the "sysv-utils" USE flag.