Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 698080 - dev-util/aruba-0.14.12 rekeywording
Summary: dev-util/aruba-0.14.12 rekeywording
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Keywording (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords: KEYWORDREQ
Depends on:
Blocks:
 
Reported: 2019-10-20 06:52 UTC by Hans de Graaff
Modified: 2020-04-12 18:33 UTC (History)
0 users

See Also:
Package list:
dev-ruby/activesupport-5.2.4.1 dev-ruby/activesupport-6.0.2.1 dev-ruby/addressable-2.7.0 dev-ruby/atomic-1.1.101 dev-ruby/childlabor-0.0.3-r1 dev-ruby/connection_pool-2.2.2 dev-ruby/crack-0.4.3-r2 dev-ruby/dalli-2.7.10-r1 dev-ruby/domain_name-0.5.20190701 dev-ruby/hashdiff-1.0.1 dev-ruby/hashie-3.6.0 dev-ruby/heredoc_unindent-1.2.0 dev-ruby/http-4.1.1 dev-ruby/httpclient-2.8.3 dev-ruby/http-cookie-1.0.3 dev-ruby/http-form_data-2.3.0 dev-ruby/http_parser_rb-0.6.0-r1 dev-ruby/i18n-1.8.2 dev-ruby/listen-3.2.1 dev-ruby/public_suffix-4.0.3 dev-ruby/rb-inotify-0.10.1 dev-ruby/safe_yaml-1.0.5 dev-ruby/test_declarative-0.0.6 dev-ruby/thor-0.20.3 dev-ruby/thread_safe-0.3.6 dev-ruby/tzinfo-1.2.6 dev-ruby/unf-0.1.4 dev-ruby/unf_ext-0.0.7.6 dev-ruby/webmock-3.8.3 dev-ruby/zeitwerk-2.3.0 dev-util/aruba-0.14.14
Runtime testing required: ---
stable-bot: sanity-check-


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hans de Graaff gentoo-dev 2019-10-20 06:52:51 UTC
Please test and rekeyword aruba due to a new dependency on dev-ruby/thor.
Comment 1 Stabilization helper bot gentoo-dev 2019-10-20 07:03:36 UTC
An automated check of this bug failed - repoman reported dependency errors (31 lines truncated): 

> dependency.bad dev-ruby/activesupport/activesupport-5.2.3.ebuild: DEPEND: ~alpha(default/linux/alpha/17.0) ['>=dev-ruby/listen-3.0.5:3[ruby_targets_ruby24]', '>=dev-ruby/listen-3.0.5:3[ruby_targets_ruby25]', '>=dev-ruby/listen-3.0.5:3[ruby_targets_ruby26]']
> dependency.bad dev-ruby/activesupport/activesupport-5.2.3.ebuild: DEPEND: ~alpha(default/linux/alpha/17.0/desktop) ['>=dev-ruby/listen-3.0.5:3[ruby_targets_ruby24]', '>=dev-ruby/listen-3.0.5:3[ruby_targets_ruby25]', '>=dev-ruby/listen-3.0.5:3[ruby_targets_ruby26]']
> dependency.bad dev-ruby/activesupport/activesupport-5.2.3.ebuild: DEPEND: ~alpha(default/linux/alpha/17.0/desktop/gnome) ['>=dev-ruby/listen-3.0.5:3[ruby_targets_ruby24]', '>=dev-ruby/listen-3.0.5:3[ruby_targets_ruby25]', '>=dev-ruby/listen-3.0.5:3[ruby_targets_ruby26]']
> dependency.bad dev-ruby/activesupport/activesupport-5.2.3.ebuild: DEPEND: ~alpha(default/linux/alpha/17.0) ['>=dev-ruby/listen-3.0.5:3[ruby_targets_ruby24]', '>=dev-ruby/listen-3.0.5:3[ruby_targets_ruby25]', '>=dev-ruby/listen-3.0.5:3[ruby_targets_ruby26]']
> dependency.bad dev-ruby/activesupport/activesupport-5.2.3.ebuild: DEPEND: ~alpha(default/linux/alpha/17.0/desktop) ['>=dev-ruby/listen-3.0.5:3[ruby_targets_ruby24]', '>=dev-ruby/listen-3.0.5:3[ruby_targets_ruby25]', '>=dev-ruby/listen-3.0.5:3[ruby_targets_ruby26]']
> dependency.bad dev-ruby/activesupport/activesupport-5.2.3.ebuild: DEPEND: ~alpha(default/linux/alpha/17.0/desktop/gnome) ['>=dev-ruby/listen-3.0.5:3[ruby_targets_ruby24]', '>=dev-ruby/listen-3.0.5:3[ruby_targets_ruby25]', '>=dev-ruby/listen-3.0.5:3[ruby_targets_ruby26]']
> dependency.bad dev-ruby/http/http-4.1.1.ebuild: DEPEND: ~alpha(default/linux/alpha/17.0) ['dev-ruby/http-form_data:2[ruby_targets_ruby24]', '>=dev-ruby/http_parser_rb-0.6.0[ruby_targets_ruby24]', '=dev-ruby/http_parser_rb-0.6*[ruby_targets_ruby24]', 'dev-ruby/http-form_data:2[ruby_targets_ruby25]', '>=dev-ruby/http_parser_rb-0.6.0[ruby_targets_ruby25]', '=dev-ruby/http_parser_rb-0.6*[ruby_targets_ruby25]', 'dev-ruby/http-form_data:2[ruby_targets_ruby26]', '>=dev-ruby/http_parser_rb-0.6.0[ruby_targets_ruby26]', '=dev-ruby/http_parser_rb-0.6*[ruby_targets_ruby26]', 'dev-ruby/certificate_authority[ruby_targets_ruby24]', 'dev-ruby/certificate_authority[ruby_targets_ruby25]', 'dev-ruby/certificate_authority[ruby_targets_ruby26]']
> dependency.bad dev-ruby/http/http-4.1.1.ebuild: RDEPEND: ~alpha(default/linux/alpha/17.0) ['dev-ruby/http-form_data:2[ruby_targets_ruby24]', '>=dev-ruby/http_parser_rb-0.6.0[ruby_targets_ruby24]', '=dev-ruby/http_parser_rb-0.6*[ruby_targets_ruby24]', 'dev-ruby/http-form_data:2[ruby_targets_ruby25]', '>=dev-ruby/http_parser_rb-0.6.0[ruby_targets_ruby25]', '=dev-ruby/http_parser_rb-0.6*[ruby_targets_ruby25]', 'dev-ruby/http-form_data:2[ruby_targets_ruby26]', '>=dev-ruby/http_parser_rb-0.6.0[ruby_targets_ruby26]', '=dev-ruby/http_parser_rb-0.6*[ruby_targets_ruby26]']
> dependency.bad dev-ruby/http/http-4.1.1.ebuild: DEPEND: ~alpha(default/linux/alpha/17.0/desktop) ['dev-ruby/http-form_data:2[ruby_targets_ruby24]', '>=dev-ruby/http_parser_rb-0.6.0[ruby_targets_ruby24]', '=dev-ruby/http_parser_rb-0.6*[ruby_targets_ruby24]', 'dev-ruby/http-form_data:2[ruby_targets_ruby25]', '>=dev-ruby/http_parser_rb-0.6.0[ruby_targets_ruby25]', '=dev-ruby/http_parser_rb-0.6*[ruby_targets_ruby25]', 'dev-ruby/http-form_data:2[ruby_targets_ruby26]', '>=dev-ruby/http_parser_rb-0.6.0[ruby_targets_ruby26]', '=dev-ruby/http_parser_rb-0.6*[ruby_targets_ruby26]', 'dev-ruby/certificate_authority[ruby_targets_ruby24]', 'dev-ruby/certificate_authority[ruby_targets_ruby25]', 'dev-ruby/certificate_authority[ruby_targets_ruby26]']
Comment 2 Stabilization helper bot gentoo-dev 2019-10-20 09:03:45 UTC
An automated check of this bug failed - repoman reported dependency errors (17 lines truncated): 

> dependency.bad dev-ruby/http/http-4.1.1.ebuild: DEPEND: ~alpha(default/linux/alpha/17.0) ['>=dev-ruby/http_parser_rb-0.6.0[ruby_targets_ruby24]', '=dev-ruby/http_parser_rb-0.6*[ruby_targets_ruby24]', '>=dev-ruby/http_parser_rb-0.6.0[ruby_targets_ruby25]', '=dev-ruby/http_parser_rb-0.6*[ruby_targets_ruby25]', '>=dev-ruby/http_parser_rb-0.6.0[ruby_targets_ruby26]', '=dev-ruby/http_parser_rb-0.6*[ruby_targets_ruby26]', 'dev-ruby/certificate_authority[ruby_targets_ruby24]', 'dev-ruby/certificate_authority[ruby_targets_ruby25]', 'dev-ruby/certificate_authority[ruby_targets_ruby26]']
> dependency.bad dev-ruby/http/http-4.1.1.ebuild: RDEPEND: ~alpha(default/linux/alpha/17.0) ['>=dev-ruby/http_parser_rb-0.6.0[ruby_targets_ruby24]', '=dev-ruby/http_parser_rb-0.6*[ruby_targets_ruby24]', '>=dev-ruby/http_parser_rb-0.6.0[ruby_targets_ruby25]', '=dev-ruby/http_parser_rb-0.6*[ruby_targets_ruby25]', '>=dev-ruby/http_parser_rb-0.6.0[ruby_targets_ruby26]', '=dev-ruby/http_parser_rb-0.6*[ruby_targets_ruby26]']
> dependency.bad dev-ruby/http/http-4.1.1.ebuild: DEPEND: ~alpha(default/linux/alpha/17.0/desktop) ['>=dev-ruby/http_parser_rb-0.6.0[ruby_targets_ruby24]', '=dev-ruby/http_parser_rb-0.6*[ruby_targets_ruby24]', '>=dev-ruby/http_parser_rb-0.6.0[ruby_targets_ruby25]', '=dev-ruby/http_parser_rb-0.6*[ruby_targets_ruby25]', '>=dev-ruby/http_parser_rb-0.6.0[ruby_targets_ruby26]', '=dev-ruby/http_parser_rb-0.6*[ruby_targets_ruby26]', 'dev-ruby/certificate_authority[ruby_targets_ruby24]', 'dev-ruby/certificate_authority[ruby_targets_ruby25]', 'dev-ruby/certificate_authority[ruby_targets_ruby26]']
Comment 3 Hans de Graaff gentoo-dev 2019-10-21 05:27:59 UTC
In addition to this list my suggestion would be to set mask tests for dev-ruby/http since that will pull in dev-ruby/certificate_authority and consequently a significant part of rails and its dependencies.
Comment 4 Stabilization helper bot gentoo-dev 2019-10-21 06:03:25 UTC
An automated check of this bug failed - repoman reported dependency errors (7 lines truncated): 

> dependency.bad dev-ruby/http/http-4.1.1.ebuild: DEPEND: ~alpha(default/linux/alpha/17.0) ['dev-ruby/certificate_authority[ruby_targets_ruby24]', 'dev-ruby/certificate_authority[ruby_targets_ruby25]', 'dev-ruby/certificate_authority[ruby_targets_ruby26]']
> dependency.bad dev-ruby/http/http-4.1.1.ebuild: DEPEND: ~alpha(default/linux/alpha/17.0/desktop) ['dev-ruby/certificate_authority[ruby_targets_ruby24]', 'dev-ruby/certificate_authority[ruby_targets_ruby25]', 'dev-ruby/certificate_authority[ruby_targets_ruby26]']
> dependency.bad dev-ruby/http/http-4.1.1.ebuild: DEPEND: ~alpha(default/linux/alpha/17.0/desktop/gnome) ['dev-ruby/certificate_authority[ruby_targets_ruby24]', 'dev-ruby/certificate_authority[ruby_targets_ruby25]', 'dev-ruby/certificate_authority[ruby_targets_ruby26]']
Comment 5 Stabilization helper bot gentoo-dev 2019-12-09 11:49:48 UTC
An automated check of this bug failed - repoman reported dependency errors (7 lines truncated): 

> dependency.bad dev-ruby/http/http-4.1.1.ebuild: DEPEND: ~alpha(default/linux/alpha/17.0) ['dev-ruby/certificate_authority[ruby_targets_ruby24]', 'dev-ruby/certificate_authority[ruby_targets_ruby25]', 'dev-ruby/certificate_authority[ruby_targets_ruby26]']
> dependency.bad dev-ruby/http/http-4.1.1.ebuild: DEPEND: ~alpha(default/linux/alpha/17.0/desktop) ['dev-ruby/certificate_authority[ruby_targets_ruby24]', 'dev-ruby/certificate_authority[ruby_targets_ruby25]', 'dev-ruby/certificate_authority[ruby_targets_ruby26]']
> dependency.bad dev-ruby/http/http-4.1.1.ebuild: DEPEND: ~alpha(default/linux/alpha/17.0/desktop/gnome) ['dev-ruby/certificate_authority[ruby_targets_ruby24]', 'dev-ruby/certificate_authority[ruby_targets_ruby25]', 'dev-ruby/certificate_authority[ruby_targets_ruby26]']
Comment 6 Stabilization helper bot gentoo-dev 2020-02-06 10:01:21 UTC
An automated check of this bug failed - repoman reported dependency errors (14 lines truncated): 

> dependency.bad dev-ruby/addressable/addressable-2.7.0.ebuild: BDEPEND: ~alpha(default/linux/alpha/17.0) ['dev-ruby/public_suffix:4[ruby_targets_ruby27(-)]']
> dependency.bad dev-ruby/addressable/addressable-2.7.0.ebuild: RDEPEND: ~alpha(default/linux/alpha/17.0) ['dev-ruby/public_suffix:4[ruby_targets_ruby27(-)]']
> dependency.bad dev-ruby/addressable/addressable-2.7.0.ebuild: BDEPEND: ~alpha(default/linux/alpha/17.0/desktop) ['dev-ruby/public_suffix:4[ruby_targets_ruby27(-)]']
> dependency.bad dev-ruby/http/http-4.1.1.ebuild: DEPEND: ~alpha(default/linux/alpha/17.0) ['dev-ruby/certificate_authority[ruby_targets_ruby24(-)]', 'dev-ruby/certificate_authority[ruby_targets_ruby25(-)]', 'dev-ruby/certificate_authority[ruby_targets_ruby26(-)]']
> dependency.bad dev-ruby/http/http-4.1.1.ebuild: DEPEND: ~alpha(default/linux/alpha/17.0/desktop) ['dev-ruby/certificate_authority[ruby_targets_ruby24(-)]', 'dev-ruby/certificate_authority[ruby_targets_ruby25(-)]', 'dev-ruby/certificate_authority[ruby_targets_ruby26(-)]']
> dependency.bad dev-ruby/http/http-4.1.1.ebuild: DEPEND: ~alpha(default/linux/alpha/17.0/desktop/gnome) ['dev-ruby/certificate_authority[ruby_targets_ruby24(-)]', 'dev-ruby/certificate_authority[ruby_targets_ruby25(-)]', 'dev-ruby/certificate_authority[ruby_targets_ruby26(-)]']
Comment 7 Matt Turner gentoo-dev 2020-03-18 06:13:55 UTC
Since all this is for just for sys-block/thin-provisioning-tools's USE=test and the package list seems to be much longer than stated, I'm just going to drop keywords on alpha.
Comment 8 Stabilization helper bot gentoo-dev 2020-03-18 07:02:07 UTC
An automated check of this bug failed - repoman reported dependency errors (2 lines truncated): 

> dependency.bad dev-ruby/http/http-4.1.1.ebuild: DEPEND: ~ia64(default/linux/ia64/17.0) ['dev-ruby/certificate_authority[ruby_targets_ruby24(-)]', 'dev-ruby/certificate_authority[ruby_targets_ruby25(-)]', 'dev-ruby/certificate_authority[ruby_targets_ruby26(-)]']
> dependency.bad dev-ruby/http/http-4.1.1.ebuild: DEPEND: ~ia64(default/linux/ia64/17.0/desktop) ['dev-ruby/certificate_authority[ruby_targets_ruby24(-)]', 'dev-ruby/certificate_authority[ruby_targets_ruby25(-)]', 'dev-ruby/certificate_authority[ruby_targets_ruby26(-)]']
> dependency.bad dev-ruby/http/http-4.1.1.ebuild: DEPEND: ~ia64(default/linux/ia64/17.0/desktop/gnome) ['dev-ruby/certificate_authority[ruby_targets_ruby24(-)]', 'dev-ruby/certificate_authority[ruby_targets_ruby25(-)]', 'dev-ruby/certificate_authority[ruby_targets_ruby26(-)]']
Comment 9 Stabilization helper bot gentoo-dev 2020-03-18 10:02:04 UTC
An automated check of this bug failed - repoman reported dependency errors (2 lines truncated): 

> dependency.bad dev-ruby/http/http-4.1.1.ebuild: DEPEND: ~ia64(default/linux/ia64/17.0) ['dev-ruby/certificate_authority[ruby_targets_ruby24(-)]', 'dev-ruby/certificate_authority[ruby_targets_ruby25(-)]', 'dev-ruby/certificate_authority[ruby_targets_ruby26(-)]']
> dependency.bad dev-ruby/http/http-4.1.1.ebuild: DEPEND: ~ia64(default/linux/ia64/17.0/desktop) ['dev-ruby/certificate_authority[ruby_targets_ruby24(-)]', 'dev-ruby/certificate_authority[ruby_targets_ruby25(-)]', 'dev-ruby/certificate_authority[ruby_targets_ruby26(-)]']
> dependency.bad dev-ruby/http/http-4.1.1.ebuild: DEPEND: ~ia64(default/linux/ia64/17.0/desktop/gnome) ['dev-ruby/certificate_authority[ruby_targets_ruby24(-)]', 'dev-ruby/certificate_authority[ruby_targets_ruby25(-)]', 'dev-ruby/certificate_authority[ruby_targets_ruby26(-)]']
Comment 10 NATTkA bot gentoo-dev 2020-04-06 15:06:12 UTC
Sanity check failed:

> nonsolvable depset(depend) keyword(~ia64) stable profile (default/linux/ia64/17.0) (5 total): solutions: [ dev-ruby/certificate_authority[ruby_targets_ruby25(-)], dev-ruby/certificate_authority[ruby_targets_ruby26(-)], dev-ruby/certificate_authority[ruby_targets_ruby24(-)] ]
Comment 11 NATTkA bot gentoo-dev 2020-04-07 03:09:40 UTC
Sanity check failed:

> nonsolvable depset(depend) keyword(~ia64) stable profile (default/linux/ia64/17.0) (5 total): solutions: [ dev-ruby/certificate_authority[ruby_targets_ruby24(-)], dev-ruby/certificate_authority[ruby_targets_ruby26(-)], dev-ruby/certificate_authority[ruby_targets_ruby25(-)] ]
Comment 12 NATTkA bot gentoo-dev 2020-04-07 15:13:32 UTC
Sanity check failed:

> nonsolvable depset(depend) keyword(~ia64) stable profile (default/linux/ia64/17.0) (5 total): solutions: [ dev-ruby/certificate_authority[ruby_targets_ruby25(-)], dev-ruby/certificate_authority[ruby_targets_ruby26(-)], dev-ruby/certificate_authority[ruby_targets_ruby24(-)] ]
Comment 13 NATTkA bot gentoo-dev 2020-04-08 03:17:21 UTC
Sanity check failed:

> dev-ruby/http-4.1.1
>   depend ~ia64 stable profile default/linux/ia64/17.0 (5 total)
>     dev-ruby/certificate_authority[ruby_targets_ruby24(-)]
>     dev-ruby/certificate_authority[ruby_targets_ruby25(-)]
>     dev-ruby/certificate_authority[ruby_targets_ruby26(-)]
Comment 14 Sergei Trofimovich gentoo-dev 2020-04-12 18:33:29 UTC
Dekeyworded ruby on ia64: https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=4e20c67fea47b985c710b493dc583bd0dd375611