Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 698062 - sys-apps/firejail: ffmpeg: error while loading shared libraries: libstdc++.so.6
Summary: sys-apps/firejail: ffmpeg: error while loading shared libraries: libstdc++.so.6
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks:
 
Reported: 2019-10-19 22:40 UTC by Dmitry Baranov
Modified: 2020-11-11 07:50 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (einfo.txt,6.05 KB, text/plain)
2019-10-19 22:42 UTC, Dmitry Baranov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Baranov 2019-10-19 22:40:36 UTC
youtube-dl https://www.youtube.com/watch?v=XXXXXXXXXXX
...
ERROR: ffmpeg: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

Reproducible: Always

Steps to Reproduce:
1. Download any video from youtube
2.
3.
Comment 1 Dmitry Baranov 2019-10-19 22:42:39 UTC
Created attachment 593340 [details]
emerge --info

emerge --info youtube-dl
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2019-10-20 09:46:10 UTC
This is not a problem in net-misc/youtube-dl: it merely tries to execute ffmpeg and does not control ffmpeg's linkage.
Comment 3 franklyfrank 2019-12-17 16:13:02 UTC
Is the reporter using firejail?
I've been having this exact same problem for a while now and just got around fiddling with it and in my case it seems to be caused by firejail.

Error occurs when sys-apps/firejail-0.9.60-r1 is present on system using default /etc/firejail/ffmpeg.profile and a symbolic link /usr/local/bin/ffmpeg pointing to /usr/bin/firejail (created via firecfg which creates symbolic links for firejail supported binaries). 

Error doesn't occur after deleting symbolic link /usr/bin/firejail causing ffmpeg to be ran without firejail sandboxing.

I've tried it once again with the ffmpeg symbolic link in place and with a blank ffmpeg.profile for firejail and it didn't change anything so my guess that youtube-dl does something that doesn't expect ffmpeg to be a symbolic link.
Comment 4 Dmitry Baranov 2020-01-04 11:26:56 UTC
This is really firejail related issue (/etc/firejail/youtube-dl.profile).
This bug was fixed since: https://github.com/netblue30/firejail/pull/3120/commits/b862701bb3c0ac2b2ad8f828ef4885697970f20f

@franklyfrank please approve this fix does not necessary for ffmpeg.profile.
Comment 5 Alexis Ballier gentoo-dev 2020-09-04 15:33:10 UTC
reassigning to firejail maintainer then
Comment 6 Hank Leininger 2020-10-15 23:20:03 UTC
Confirmed the current upstream version includes a fix for this; working on a PR to bump our version.
Comment 7 Larry the Git Cow gentoo-dev 2020-11-11 07:50:18 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=f23fe664f064159ec4460c36c114ff5858c3033b

commit f23fe664f064159ec4460c36c114ff5858c3033b
Author:     Hank Leininger <hlein@korelogic.com>
AuthorDate: 2020-10-14 17:36:50 +0000
Commit:     Joonas Niilola <juippis@gentoo.org>
CommitDate: 2020-11-11 07:50:10 +0000

    sys-apps/firejail: Version bump for CVEs, fixes, add proxy maintainer
    
    Version bump to address outstanding CVEs. Confirmed the current
    release includes the fixes for several open bugs, so closing those.
    
    Updated to address feedback in https://github.com/gentoo/gentoo/pull/17929
    
    Signed-off-by: Hank Leininger <hlein@korelogic.com>
    Closes: https://bugs.gentoo.org/698062
    Closes: https://bugs.gentoo.org/747859
    Closes: https://bugs.gentoo.org/747613
    Closes: https://bugs.gentoo.org/747859
    Bug: https://bugs.gentoo.org/736816
    Package-Manager: Portage-3.0.8, Repoman-3.0.2
    Closes: https://github.com/gentoo/gentoo/pull/17929
    Signed-off-by: Joonas Niilola <juippis@gentoo.org>

 sys-apps/firejail/Manifest               |  1 +
 sys-apps/firejail/firejail-0.9.64.ebuild | 83 ++++++++++++++++++++++++++++++++
 sys-apps/firejail/metadata.xml           | 10 +++-
 3 files changed, 93 insertions(+), 1 deletion(-)