Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 698056 - dev-db/mysql-8.0.18 has no USE=static required by virtual/mysql-5.6-r12
Summary: dev-db/mysql-8.0.18 has no USE=static required by virtual/mysql-5.6-r12
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Linux MySQL bugs team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-19 21:06 UTC by Keith Harrison
Modified: 2020-01-20 19:31 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Keith Harrison 2019-10-19 21:06:11 UTC
I cannot upgrade to mysql-8 because it does not have a static use flag required by virtual/mysql.

dev-db/mysqltuner depends on virtual/mysql

Reproducible: Always

Steps to Reproduce:
1. emerge -1pv =dev-db/mysql-8.0.18
Actual Results:  
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-libs/libedit-20190324.3.1::gentoo  USE="(split-usr) -static-libs" ABI_X86="32 (64) (-x32)" 510 KiB
[ebuild     U  ] dev-db/mysql-8.0.18:0/0::gentoo [5.7.27-r1:0/18::gentoo] USE="perl server -cjk -cracklib -debug -jemalloc -latin1 -libressl -numa -profiling -router% (-selinux) -tcmalloc -test (-client-libs%) (-experimental%) (-static%) (-static-libs%) (-systemtap%) (-yassl%)" ABI_X86="(-32%*) (-64%*) (-x32%)" 333 KiB

Total: 2 packages (1 upgrade, 1 new), Size of downloads: 843 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-db/mysql:0

  (dev-db/mysql-8.0.18:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =dev-db/mysql-8.0.18 (Argument)

  (dev-db/mysql-5.7.27-r1:0/18::gentoo, installed) pulled in by
    >=dev-db/mysql-5.6[embedded(-)?,server?,static?] required by (virtual/mysql-5.6-r12:0/18::gentoo, installed


See also: https://bugs.gentoo.org/697640
Comment 1 Thomas Deutschmann gentoo-dev Security 2020-01-20 19:31:38 UTC
Upstream removed the possibility to build static mysql, see https://dev.mysql.com/doc/refman/8.0/en/source-configuration-options.html#option_cmake_disable_shared