Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 696844 - sys-devel/clang-9.0.0 - CMake Error at CMakeLists.txt:116 (include): include could not find load file: VersionFromVCS
Summary: sys-devel/clang-9.0.0 - CMake Error at CMakeLists.txt:116 (include): include ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: Prefix Support (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Prefix
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks:
 
Reported: 2019-10-06 11:38 UTC by indocomsoft
Modified: 2019-12-22 08:28 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
clang-9.0.0 reading system's llvm cmake instead of gentoo prefix's (build.log,10.27 KB, application/octet-stream)
2019-10-06 11:47 UTC, indocomsoft
Details
emerge --info '=sys-devel/clang-9.0.0::gentoo' output (emerge-info.log,5.24 KB, text/plain)
2019-10-06 11:48 UTC, indocomsoft
Details
build.log (build.log,10.27 KB, text/plain)
2019-10-06 11:49 UTC, indocomsoft
Details

Note You need to log in before you can comment on or make changes to this bug.
Description indocomsoft 2019-10-06 11:38:19 UTC
I am using Gentoo Prefix on Ubuntu 16.04. Installing clang fails because the CMAKEDIR used during configuration is the system LLVM instead of Gentoo Prefix's LLVM. Seems like this is because in clang-9.0.0.ebuild, -DLLVM_CONFIG is not being passed anymore. Adding it fixes this issue

Reproducible: Always

Steps to Reproduce:
emerge -atv sys-devel/clang
Actual Results:  
Configuration failed, with errors from CMake unable to read from /usr/share/llvm-3.8/cmake/ which is strange given that it is not reading the LLVM Cmake from the Gentoo Prefix

Expected Results:  
Configuration phase succeeds
Comment 1 indocomsoft 2019-10-06 11:41:13 UTC
I can see from https://github.com/llvm-mirror/clang/blob/master/CMakeLists.txt#L17 that LLVM_CONFIG is being deprecated. Perhaps we should pass in LLVM_CMAKE_DIR or LLVM_CMAKE_PATH instead? (Sorry, a bit unfamiliar with the CMake syntax)
Comment 2 Jeroen Roovers gentoo-dev 2019-10-06 11:42:46 UTC
Please attach the entire build log to this bug report.
Comment 3 indocomsoft 2019-10-06 11:47:12 UTC
Created attachment 591968 [details]
clang-9.0.0 reading system's llvm cmake instead of gentoo prefix's
Comment 4 indocomsoft 2019-10-06 11:48:55 UTC
Created attachment 591970 [details]
emerge --info '=sys-devel/clang-9.0.0::gentoo' output
Comment 5 indocomsoft 2019-10-06 11:49:38 UTC
Created attachment 591972 [details]
build.log
Comment 6 indocomsoft 2019-10-06 11:51:02 UTC
I've attached the build log and the output of emerge --info.

Note that I am using Gentoo Prefix, on Ubuntu 16.04. On the Ubuntu side, LLVM 3.8.0 is installed, while on the Gentoo Prefix side, LLVM 9.0.0 is installed
Comment 7 Larry the Git Cow gentoo-dev 2019-12-22 08:28:55 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=74becb19ba7f7c46ae22e8a1ec6270e2caeaa725

commit 74becb19ba7f7c46ae22e8a1ec6270e2caeaa725
Author:     Julius Putra Tanu Setiaji <indocomsoft@gmail.com>
AuthorDate: 2019-12-18 13:59:05 +0000
Commit:     Michał Górny <mgorny@gentoo.org>
CommitDate: 2019-12-22 08:16:27 +0000

    sys-devel/clang: Set the correct LLVM_CMAKE_PATH on Gentoo Prefix
    
    Signed-off-by: Julius Putra Tanu Setiaji <indocomsoft@gmail.com>
    Closes: https://bugs.gentoo.org/696844
    Package-Manager: Portage-2.3.82, Repoman-2.3.20
    Closes: https://github.com/gentoo/gentoo/pull/14036
    Signed-off-by: Michał Górny <mgorny@gentoo.org>

 sys-devel/clang/clang-10.0.0.9999.ebuild | 1 +
 sys-devel/clang/clang-9.0.1.ebuild       | 1 +
 2 files changed, 2 insertions(+)