Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 696374 - net-misc/lldpd-1.0.3 with sys-libs/musl - priv.c:516:12: Fehler: »PATH_MAX« nicht deklariert (erstmalige Verwendung in dieser Funktion); meinten Sie »AF_MAX«?
Summary: net-misc/lldpd-1.0.3 with sys-libs/musl - priv.c:516:12: Fehler: »PATH_MAX« n...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Patrick McLean
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: missing-musl-includes
  Show dependency tree
 
Reported: 2019-10-05 08:12 UTC by Lloyd
Modified: 2020-06-11 02:59 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info and build.log in one file (2019-10-05_build-error-lldpd.txt,58.26 KB, text/plain)
2019-10-05 08:12 UTC, Lloyd
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lloyd 2019-10-05 08:12:30 UTC
Created attachment 591882 [details]
emerge --info and build.log in one file

Build net-misc/lldpd breaks with error: PATH_MAX is not declarated, do you mean AF_MAX?

System runs muscl not glibc. Maybe this infoamtion is importend.

emerge --info and build log is attached.
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2019-10-05 08:26:44 UTC
This was already fixed in net-misc/lldpd-1.0.4.
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2019-10-05 08:27:24 UTC
ChangeLog:
1.0.4 [2019-06-15 11:09:44 +0200]:
...
 - [b2eebb31fc21] priv: include limits.h for PATH_MAX (Sören Tempel)
Comment 3 Lloyd 2019-12-12 12:52:45 UTC
With version 1.0.4 I have no error. By setting "=net-misc/lldpd-1.0.4 ~amd64" to "/etc/portage/package.accept_keywords" it works. Version 1.0.4 is the current version, from upstream developer. Maybe the current version should be stable? The case is closed to me.
Comment 4 Sam James archtester gentoo-dev Security 2020-06-11 02:59:14 UTC
Let us know if this is still a problem.