Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 696046 - net-misc/cfengine-3.6.2-r1 : hashes.c:50:20: error: storage size of context isn t known
Summary: net-misc/cfengine-3.6.2-r1 : hashes.c:50:20: error: storage size of context i...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Sysadmin Bugs
URL:
Whiteboard:
Keywords: PMASKED
: 727852 731688 791619 831336 (view as bug list)
Depends on: 882759
Blocks: openssl-1.1 729788
  Show dependency tree
 
Reported: 2019-10-02 07:17 UTC by Toralf Förster
Modified: 2022-12-31 18:32 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.72 KB, text/plain)
2019-10-02 07:17 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,155.37 KB, text/plain)
2019-10-02 07:17 UTC, Toralf Förster
Details
environment (environment,100.77 KB, text/plain)
2019-10-02 07:17 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,10.78 KB, application/x-bzip)
2019-10-02 07:17 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,35.55 KB, application/x-bzip)
2019-10-02 07:17 UTC, Toralf Förster
Details
net-misc:cfengine-3.6.2:20191001-184409.log (net-misc:cfengine-3.6.2:20191001-184409.log,28.05 KB, text/plain)
2019-10-02 07:18 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,32.12 KB, application/x-bzip)
2019-10-02 07:18 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2019-10-02 07:17:43 UTC
      |  ^~~~~~~
hashes.c: In function ‘FileChecksum’:
hashes.c:50:20: error: storage size of ‘context’ isn’t known
   50 |         EVP_MD_CTX context;
      |                    ^~~~~~~
hashes.c:50:20: warning: unused variable ‘context’ [-Wunused-variable]

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop_gnome-20190928-082156

  -------------------------------------------------------------------

  Please see the tracker bug for details.

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.2.0 *

clang:
clang version 9.0.0 (tags/RELEASE_900/final)
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/9/bin
llvm:
9.0.0
Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.38.0 *
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.13.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

repository:
==> /var/db/repos/gentoo/metadata/timestamp.chk <==
Tue, 01 Oct 2019 17:47:07 +0000

emerge -qpvO net-misc/cfengine
[ebuild  N    ] net-misc/cfengine-3.6.2  USE="acl qdbm xml -examples -libvirt -masterfiles -mysql -postgres (-selinux) -tokyocabinet -vim-syntax"
Comment 1 Toralf Förster gentoo-dev 2019-10-02 07:17:46 UTC
Created attachment 591564 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2019-10-02 07:17:49 UTC
Created attachment 591566 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2019-10-02 07:17:52 UTC
Created attachment 591568 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2019-10-02 07:17:55 UTC
Created attachment 591570 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2019-10-02 07:17:58 UTC
Created attachment 591572 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2019-10-02 07:18:01 UTC
Created attachment 591574 [details]
net-misc:cfengine-3.6.2:20191001-184409.log
Comment 7 Toralf Förster gentoo-dev 2019-10-02 07:18:04 UTC
Created attachment 591576 [details]
temp.tbz2
Comment 8 Andreas Prieß 2020-02-06 17:24:18 UTC
The currently stable version net-misc/cfengine-3.3.9 also does _not_ compile with openssl-1.1*
Comment 9 Rolf Eike Beer archtester 2020-07-02 11:53:46 UTC
*** Bug 727852 has been marked as a duplicate of this bug. ***
Comment 10 Rolf Eike Beer archtester 2020-09-12 07:51:25 UTC
*** Bug 731688 has been marked as a duplicate of this bug. ***
Comment 11 Agostino Sarubbo gentoo-dev 2020-10-30 08:35:49 UTC
Dear treecleaner@:

I'm still able to reproduce this issue right now.

Since it has not been fixed for a long time, I'd suggest to evaluate if it is the case to remove this package from the tree. Thanks
Comment 12 Agostino Sarubbo gentoo-dev 2021-08-18 15:56:17 UTC
*** Bug 791619 has been marked as a duplicate of this bug. ***
Comment 13 Agostino Sarubbo gentoo-dev 2021-11-06 08:33:57 UTC
tinderbox has reproduced this issue with version 3.6.2-r1 - Updating summary.
Comment 14 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-01-17 08:22:16 UTC
*** Bug 831336 has been marked as a duplicate of this bug. ***
Comment 15 Larry the Git Cow gentoo-dev 2022-12-31 18:32:18 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=36937c9304bd89ee30e601e9e10f8ff7e638bc53

commit 36937c9304bd89ee30e601e9e10f8ff7e638bc53
Author:     Jakov Smolić <jsmolic@gentoo.org>
AuthorDate: 2022-12-31 18:13:40 +0000
Commit:     Jakov Smolić <jsmolic@gentoo.org>
CommitDate: 2022-12-31 18:30:50 +0000

    net-misc/cfengine: treeclean
    
    Closes: https://bugs.gentoo.org/875455
    Closes: https://bugs.gentoo.org/555214
    Closes: https://bugs.gentoo.org/690918
    Closes: https://bugs.gentoo.org/713670
    Closes: https://bugs.gentoo.org/666006
    Closes: https://bugs.gentoo.org/696046
    Closes: https://bugs.gentoo.org/796446
    Closes: https://bugs.gentoo.org/882759
    Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>

 net-misc/cfengine/Manifest                         |   2 -
 net-misc/cfengine/cfengine-3.6.2-r1.ebuild         | 156 ---------------------
 net-misc/cfengine/files/cf-execd.rc6               |  18 ---
 net-misc/cfengine/files/cf-monitord.rc6            |  17 ---
 net-misc/cfengine/files/cf-serverd.rc6             |  17 ---
 .../cfengine/files/cfengine-3.6.2-ifconfig.patch   |  11 --
 .../cfengine/files/cfengine-3.6.2-sysmacros.patch  |  19 ---
 net-misc/cfengine/metadata.xml                     |  34 -----
 profiles/package.mask                              |   5 -
 9 files changed, 279 deletions(-)