Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 695904 - sys-boot/refind-0.11.4: stabilisation request
Summary: sys-boot/refind-0.11.4: stabilisation request
Status: RESOLVED DUPLICATE of bug 687258
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Stéphane Veyret
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-30 11:56 UTC by Marek Szuba
Modified: 2019-11-05 16:57 UTC (History)
2 users (show)

See Also:
Package list:
sys-boot/refind-0.11.4
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marek Szuba gentoo-dev 2019-09-30 11:56:35 UTC
The install script provided by the current stable version (0.10.4-r2) does not understand the naming scheme of NVMe block devices, as a result of which new users (or people whose boot entries got clobbered) trying to install rEFInd on such a device get a cryptic "installation failed" message and have to resort to creating an appropriate EFI boot entry by hand.
Comment 1 Stéphane Veyret 2019-10-28 10:22:20 UTC
It looks like an upstream limitation. Judging by the content of the refind-install script, it seems to be corrected in more recent versions:

# 0.10.5  -- More improvement to handling of disks (other than /dev/[sh]d? disks).
# 0.10.4  -- Improved handling of disks (other than /dev/[sh]d? disks).

Shall the issue be closed?
Comment 2 Ben Kohler gentoo-dev 2019-11-05 16:57:29 UTC

*** This bug has been marked as a duplicate of bug 687258 ***