Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 695464 - dev-python/google-auth versus dev-python/google-auth-oauthlib
Summary: dev-python/google-auth versus dev-python/google-auth-oauthlib
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Zac Medico
Depends on:
Reported: 2019-09-23 16:08 UTC by Maurice Volaski
Modified: 2021-03-07 08:04 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Maurice Volaski 2019-09-23 16:08:30 UTC
It would seem that the ebuild google-auth supplies the package google-auth-oauthlib:

But when I tried using a package that required it, it claimed google-auth-oauthlib wasn't installed and I had to install it manaully with pip install google-auth-oauthlib. This worked.

Not sure if this is a bug or if these are two separate items (in which case, the latter needs an ebuild).
Comment 1 Maurice Volaski 2019-09-23 16:10:53 UTC
Now I can see they are not the same, versus

Can we please have an ebuild for the latter?
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2019-09-28 05:26:27 UTC
We already have both packages in the tree:

dev-python/google-auth ( )
dev-python/google-auth-oauthlib ( https :// )

Not sure what your question is.