Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 693442 (CVE-2019-11740, CVE-2019-11742, CVE-2019-11743, CVE-2019-11744, CVE-2019-11746, CVE-2019-11752, CVE-2019-9812, MFSA-2019-27) - <www-client/firefox-{60.9.0,68.1.0}: multiple vulnerabilities (MFSA-2019-27)
Summary: <www-client/firefox-{60.9.0,68.1.0}: multiple vulnerabilities (MFSA-2019-27)
Status: RESOLVED FIXED
Alias: CVE-2019-11740, CVE-2019-11742, CVE-2019-11743, CVE-2019-11744, CVE-2019-11746, CVE-2019-11752, CVE-2019-9812, MFSA-2019-27
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: Gentoo Security
URL: https://www.mozilla.org/en-US/securit...
Whiteboard: A2 [glsa+]
Keywords:
Depends on: 693512
Blocks:
  Show dependency tree
 
Reported: 2019-09-03 20:05 UTC by GLSAMaker/CVETool Bot
Modified: 2019-11-25 00:17 UTC (History)
1 user (show)

See Also:
Package list:
www-client/firefox-60.9.0 www-client/firefox-68.1.0 dev-util/cbindgen-0.9.1 net-libs/nodejs-8.12.0 arm64
Runtime testing required: ---
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description GLSAMaker/CVETool Bot gentoo-dev 2019-09-03 20:05:36 UTC
Incoming details.
Comment 1 Thomas Deutschmann gentoo-dev Security 2019-09-03 20:12:25 UTC
CVE-2019-11746: Use-after-free while manipulating video

Impact
    high

Description

A use-after-free vulnerability can occur while manipulating video elements if the body is freed while still in use. This results in a potentially exploitable crash.


CVE-2019-11744: XSS by breaking out of title and textarea elements using innerHTML

Impact
    high

Description

Some HTML elements, such as <title> and <textarea>, can contain literal angle brackets without treating them as markup. It is possible to pass a literal closing tag to .innerHTML on these elements, and subsequent content after that will be parsed as if it were outside the tag. This can lead to XSS if a site does not filter user input as strictly for these elements as it does for other elements.


CVE-2019-11742: Same-origin policy violation with SVG filters and canvas to steal cross-origin images

Impact
    high

Description

A same-origin policy violation occurs allowing the theft of cross-origin images through a combination of SVG filters and a <canvas> element due to an error in how same-origin policy is applied to cached image content. The resulting same-origin policy violation could allow for data theft.


CVE-2019-11752: Use-after-free while extracting a key value in IndexedDB

Impact
    high

Description

It is possible to delete an IndexedDB key value and subsequently try to extract it during conversion. This results in a use-after-free and a potentially exploitable crash.


CVE-2019-9812: Sandbox escape through Firefox Sync

Impact
    high

Description

Given a compromised sandboxed content process due to a separate vulnerability, it is possible to escape that sandbox by loading accounts.firefox.com in that process and forcing a log-in to a malicious Firefox Sync account. Preference settings that disable the sandbox are then synchronized to the local machine and the compromised browser would restart without the sandbox if a crash is triggered.


CVE-2019-11743: Cross-origin access to unload event attributes

Impact
    moderate

Description

Navigation events were not fully adhering to the W3C's "Navigation-Timing Level 2" draft specification in some instances for the unload event, which restricts access to detailed timing attributes to only be same-origin. This resulted in potential cross-origin information exposure of history through timing side-channel attacks.


CVE-2019-11740: Memory safety bugs fixed in Firefox 69, Firefox ESR 68.1, and Firefox ESR 60.9

Impact
    high

Description

Mozilla developers and community members Tyson Smith and Nathan Froyd reported memory safety bugs present in Firefox 68, Firefox ESR 68, and Firefox 60.8. Some of these bugs showed evidence of memory corruption and we presume that with enough effort that some of these could be exploited to run arbitrary code.
Comment 2 Stabilization helper bot gentoo-dev 2019-09-03 22:00:50 UTC
An automated check of this bug failed - repoman reported dependency errors (186 lines truncated): 

> dependency.bad www-client/firefox/firefox-68.1.0.ebuild: DEPEND: amd64(default/linux/amd64/17.0) ['>=dev-libs/nss-3.44.1', '>=dev-libs/nspr-4.21', '>=media-libs/harfbuzz-2.4.0:0=', '>=media-libs/libvpx-1.7.0:0=[postproc]', '>=dev-util/cbindgen-0.8.7']
> dependency.bad www-client/firefox/firefox-68.1.0.ebuild: RDEPEND: amd64(default/linux/amd64/17.0) ['>=dev-libs/nss-3.44.1', '>=dev-libs/nspr-4.21', '>=media-libs/harfbuzz-2.4.0:0=', '>=media-libs/libvpx-1.7.0:0=[postproc]']
> dependency.bad www-client/firefox/firefox-68.1.0.ebuild: DEPEND: amd64(default/linux/amd64/17.0/desktop) ['>=dev-libs/nss-3.44.1', '>=dev-libs/nspr-4.21', '>=media-libs/harfbuzz-2.4.0:0=', '>=media-libs/libvpx-1.7.0:0=[postproc]', '>=dev-util/cbindgen-0.8.7']
> dependency.bad www-client/firefox/firefox-68.1.0.ebuild: DEPEND: amd64(default/linux/amd64/17.0) ['>=dev-libs/nss-3.44.1', '>=dev-libs/nspr-4.21', '>=media-libs/harfbuzz-2.4.0:0=', '>=media-libs/libvpx-1.7.0:0=[postproc]', '>=dev-util/cbindgen-0.8.7']
> dependency.bad www-client/firefox/firefox-68.1.0.ebuild: RDEPEND: amd64(default/linux/amd64/17.0) ['>=dev-libs/nss-3.44.1', '>=dev-libs/nspr-4.21', '>=media-libs/harfbuzz-2.4.0:0=', '>=media-libs/libvpx-1.7.0:0=[postproc]']
> dependency.bad www-client/firefox/firefox-68.1.0.ebuild: DEPEND: amd64(default/linux/amd64/17.0/desktop) ['>=dev-libs/nss-3.44.1', '>=dev-libs/nspr-4.21', '>=media-libs/harfbuzz-2.4.0:0=', '>=media-libs/libvpx-1.7.0:0=[postproc]', '>=dev-util/cbindgen-0.8.7']
Comment 3 Stabilization helper bot gentoo-dev 2019-09-03 23:01:33 UTC
An automated check of this bug failed - repoman reported dependency errors (186 lines truncated): 

> dependency.bad www-client/firefox/firefox-68.1.0.ebuild: DEPEND: amd64(default/linux/amd64/17.0) ['>=media-libs/harfbuzz-2.4.0:0=', '>=media-libs/libvpx-1.7.0:0=[postproc]', '>=dev-util/cbindgen-0.8.7']
> dependency.bad www-client/firefox/firefox-68.1.0.ebuild: RDEPEND: amd64(default/linux/amd64/17.0) ['>=media-libs/harfbuzz-2.4.0:0=', '>=media-libs/libvpx-1.7.0:0=[postproc]']
> dependency.bad www-client/firefox/firefox-68.1.0.ebuild: DEPEND: amd64(default/linux/amd64/17.0/desktop) ['>=media-libs/harfbuzz-2.4.0:0=', '>=media-libs/libvpx-1.7.0:0=[postproc]', '>=dev-util/cbindgen-0.8.7']
> dependency.bad www-client/firefox/firefox-68.1.0.ebuild: DEPEND: amd64(default/linux/amd64/17.0) ['>=media-libs/harfbuzz-2.4.0:0=', '>=media-libs/libvpx-1.7.0:0=[postproc]', '>=dev-util/cbindgen-0.8.7']
> dependency.bad www-client/firefox/firefox-68.1.0.ebuild: RDEPEND: amd64(default/linux/amd64/17.0) ['>=media-libs/harfbuzz-2.4.0:0=', '>=media-libs/libvpx-1.7.0:0=[postproc]']
> dependency.bad www-client/firefox/firefox-68.1.0.ebuild: DEPEND: amd64(default/linux/amd64/17.0/desktop) ['>=media-libs/harfbuzz-2.4.0:0=', '>=media-libs/libvpx-1.7.0:0=[postproc]', '>=dev-util/cbindgen-0.8.7']
Comment 4 Stabilization helper bot gentoo-dev 2019-09-04 20:01:09 UTC
An automated check of this bug failed - repoman reported dependency errors (186 lines truncated): 

> dependency.bad www-client/firefox/firefox-68.1.0.ebuild: DEPEND: amd64(default/linux/amd64/17.0) ['>=media-libs/harfbuzz-2.4.0:0=']
> dependency.bad www-client/firefox/firefox-68.1.0.ebuild: RDEPEND: amd64(default/linux/amd64/17.0) ['>=media-libs/harfbuzz-2.4.0:0=']
> dependency.bad www-client/firefox/firefox-68.1.0.ebuild: DEPEND: amd64(default/linux/amd64/17.0/desktop) ['>=media-libs/harfbuzz-2.4.0:0=']
> dependency.bad www-client/firefox/firefox-68.1.0.ebuild: DEPEND: amd64(default/linux/amd64/17.0) ['>=media-libs/harfbuzz-2.4.0:0=']
> dependency.bad www-client/firefox/firefox-68.1.0.ebuild: RDEPEND: amd64(default/linux/amd64/17.0) ['>=media-libs/harfbuzz-2.4.0:0=']
> dependency.bad www-client/firefox/firefox-68.1.0.ebuild: DEPEND: amd64(default/linux/amd64/17.0/desktop) ['>=media-libs/harfbuzz-2.4.0:0=']
Comment 5 Thomas Deutschmann gentoo-dev Security 2019-09-04 22:48:37 UTC
www-client/firefox-60.9.0: x86, stable
Comment 6 Stabilization helper bot gentoo-dev 2019-09-05 14:01:04 UTC
An automated check of this bug failed - repoman reported dependency errors (12 lines truncated): 

> dependency.bad www-client/firefox/firefox-68.1.0.ebuild: DEPEND: arm64(default/linux/arm64/17.0) ['>=net-libs/nodejs-8.11.0']
> dependency.bad www-client/firefox/firefox-68.1.0.ebuild: DEPEND: arm64(default/linux/arm64/17.0/desktop) ['>=net-libs/nodejs-8.11.0']
> dependency.bad www-client/firefox/firefox-68.1.0.ebuild: DEPEND: arm64(default/linux/arm64/17.0/desktop/gnome) ['>=net-libs/nodejs-8.11.0']
> dependency.bad www-client/firefox/firefox-68.1.0.ebuild: DEPEND: arm64(default/linux/arm64/17.0) ['>=net-libs/nodejs-8.11.0']
> dependency.bad www-client/firefox/firefox-68.1.0.ebuild: DEPEND: arm64(default/linux/arm64/17.0/desktop) ['>=net-libs/nodejs-8.11.0']
> dependency.bad www-client/firefox/firefox-68.1.0.ebuild: DEPEND: arm64(default/linux/arm64/17.0/desktop/gnome) ['>=net-libs/nodejs-8.11.0']
Comment 7 Thomas Deutschmann gentoo-dev Security 2019-09-07 21:09:03 UTC
x86 stable
Comment 8 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-09-13 17:54:12 UTC
amd64 stable
Comment 9 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2019-09-22 23:19:30 UTC
arm64 stable (with a note that CFLAGS matter until bug  is addressed upstream GCC)
Comment 10 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2019-09-22 23:20:12 UTC
removing two bugs from DEPENDS as the arches in question have no impact on this bug.
Comment 11 GLSAMaker/CVETool Bot gentoo-dev 2019-11-25 00:17:43 UTC
This issue was resolved and addressed in
 GLSA 201911-07 at https://security.gentoo.org/glsa/201911-07
by GLSA coordinator Aaron Bauman (b-man).