Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 692802 - gui-libs/libhandy and media-libs/gsound keywording and app-crypt/seahorse rekeywording
Summary: gui-libs/libhandy and media-libs/gsound keywording and app-crypt/seahorse rek...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Keywording (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: KEYWORDREQ
: 733144 (view as bug list)
Depends on: 694484
Blocks:
  Show dependency tree
 
Reported: 2019-08-24 06:45 UTC by Mart Raudsepp
Modified: 2020-12-11 03:24 UTC (History)
2 users (show)

See Also:
Package list:
media-libs/gsound-1.0.2-r1 alpha gui-libs/libhandy-0.0.13 alpha app-crypt/seahorse-3.36.2 alpha
Runtime testing required: Yes
nattka: sanity-check+


Attachments
tatt-tests (ppc64) (gsound-692802.report,4.55 KB, text/plain)
2019-11-28 16:08 UTC, ernsteiswuerfel
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mart Raudsepp gentoo-dev 2019-08-24 06:45:31 UTC
epiphany now uses libhandy, to make things work better when resized to narrow widths, plus some other niceties from some widgets provided by libhandy that aren't actually good only for mobiles (better tabs arrow menu, etc).
Please keyword and re-keyword epiphany, or drop all epiphany keywords for your arch.
Comment 1 Mart Raudsepp gentoo-dev 2019-08-24 06:51:54 UTC
Note that gnome-control-center and others will also require libhandy in version bumps that we haven't done yet; so forget about dropping epiphany if you want to keep gnome-control-center too and just do it here for epiphany first.
Comment 2 Mart Raudsepp gentoo-dev 2019-08-24 06:54:56 UTC
You can test some of it with USE=examples, which will install /usr/bin/handy-0.0-demo with which to test the functionality. When you launch it, you can hit the back arrow on top left corner to get to the other examples instead of the welcome greeting.
For epiphany the main things are probably resizing the UI to narrow width (it should hide some stuff with animation in the headerbar), and the tab menu (the arrow on the righthand side of the open multiple tabs notebook row). There were other things, but I think just quickly clicking through the samples in the hand-0.0-demo is sufficient, if even that much.
Comment 3 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2019-08-25 01:10:51 UTC
arm64 keyworded
Comment 4 Mart Raudsepp gentoo-dev 2019-09-07 22:11:00 UTC
Adding gnome-contacts-3.32 as something that needs libhandy too now, and should be re-keyworded alongside libhandy.
This one has more keywords than CCed here, but will try to remember to sort that out with more CCes and per-arch package list for epiphany tomorrow.
Comment 5 Thomas Deutschmann gentoo-dev Security 2019-09-07 23:18:42 UTC
x86 keyworded
Comment 6 ernsteiswuerfel 2019-09-17 15:49:19 UTC
Looking good on ppc64.

# cat libhandy-692802.report 
USE tests started on Di 17. Sep 17:28:43 CEST 2019

FEATURES=' test' USE='' succeeded for =gui-libs/libhandy-0.0.9
USE='examples glade -gtk-doc -introspection -vala' succeeded for =gui-libs/libhandy-0.0.9
USE='examples -glade gtk-doc -introspection -vala' succeeded for =gui-libs/libhandy-0.0.9
USE='-examples glade gtk-doc -introspection -vala' succeeded for =gui-libs/libhandy-0.0.9
USE='examples glade gtk-doc -introspection -vala' succeeded for =gui-libs/libhandy-0.0.9
USE='-examples glade -gtk-doc introspection -vala' succeeded for =gui-libs/libhandy-0.0.9
USE='-examples -glade gtk-doc introspection -vala' succeeded for =gui-libs/libhandy-0.0.9
USE='examples glade gtk-doc introspection -vala' succeeded for =gui-libs/libhandy-0.0.9
USE='-examples glade -gtk-doc introspection vala' succeeded for =gui-libs/libhandy-0.0.9
USE='examples glade -gtk-doc introspection vala' succeeded for =gui-libs/libhandy-0.0.9
USE='-examples -glade gtk-doc introspection vala' succeeded for =gui-libs/libhandy-0.0.9
USE='examples -glade gtk-doc introspection vala' succeeded for =gui-libs/libhandy-0.0.9
USE='examples glade gtk-doc introspection vala' succeeded for =gui-libs/libhandy-0.0.9

FEATURES=' test' USE='' succeeded for =www-client/epiphany-3.32.5
USE='' succeeded for =www-client/epiphany-3.32.5

FEATURES=' test' USE='' succeeded for =gnome-extra/gnome-contacts-3.32.1
USE='-telepathy -v4l' succeeded for =gnome-extra/gnome-contacts-3.32.1
USE='telepathy -v4l' succeeded for =gnome-extra/gnome-contacts-3.32.1
USE='-telepathy v4l' succeeded for =gnome-extra/gnome-contacts-3.32.1
USE='telepathy v4l' succeeded for =gnome-extra/gnome-contacts-3.32.1
Comment 7 ernsteiswuerfel 2019-09-17 16:38:08 UTC
Looking good on ppc.

# cat libhandy-692802.report 
USE tests started on Di 17. Sep 18:01:53 CEST 2019

FEATURES=' test' USE='' succeeded for =gui-libs/libhandy-0.0.9
USE='examples -glade -gtk-doc -introspection -vala' succeeded for =gui-libs/libhandy-0.0.9
USE='-examples glade -gtk-doc -introspection -vala' succeeded for =gui-libs/libhandy-0.0.9
USE='-examples -glade gtk-doc -introspection -vala' succeeded for =gui-libs/libhandy-0.0.9
USE='examples glade gtk-doc -introspection -vala' succeeded for =gui-libs/libhandy-0.0.9
USE='examples -glade -gtk-doc introspection -vala' succeeded for =gui-libs/libhandy-0.0.9
USE='-examples glade -gtk-doc introspection -vala' succeeded for =gui-libs/libhandy-0.0.9
USE='examples glade -gtk-doc introspection -vala' succeeded for =gui-libs/libhandy-0.0.9
USE='examples -glade gtk-doc introspection -vala' succeeded for =gui-libs/libhandy-0.0.9
USE='-examples glade gtk-doc introspection -vala' succeeded for =gui-libs/libhandy-0.0.9
USE='examples glade gtk-doc introspection -vala' succeeded for =gui-libs/libhandy-0.0.9
USE='examples glade -gtk-doc introspection vala' succeeded for =gui-libs/libhandy-0.0.9
USE='-examples -glade gtk-doc introspection vala' succeeded for =gui-libs/libhandy-0.0.9

FEATURES=' test' USE='' succeeded for =www-client/epiphany-3.32.5
USE='' succeeded for =www-client/epiphany-3.32.5

FEATURES=' test' USE='' succeeded for =gnome-extra/gnome-contacts-3.32.1
USE='-telepathy -v4l' succeeded for =gnome-extra/gnome-contacts-3.32.1
USE='telepathy -v4l' succeeded for =gnome-extra/gnome-contacts-3.32.1
USE='-telepathy v4l' succeeded for =gnome-extra/gnome-contacts-3.32.1
USE='telepathy v4l' succeeded for =gnome-extra/gnome-contacts-3.32.1
Comment 8 Mart Raudsepp gentoo-dev 2019-09-20 06:58:58 UTC
re-purposing for keywording of gsound as well, as gnome-control-center-3.32 needs both that and libhandy keyworded to restore keywords.
Comment 9 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-10-11 17:29:46 UTC
*-fbsd is gone.
Comment 10 Thomas Deutschmann gentoo-dev Security 2019-11-26 11:00:18 UTC
x86 keyworded
Comment 11 Stabilization helper bot gentoo-dev 2019-11-26 11:01:36 UTC
An automated check of this bug failed - the following invalid arch is referenced in the atom list:

x86-fbsd
Comment 12 ernsteiswuerfel 2019-11-28 16:08:22 UTC
Created attachment 597672 [details]
tatt-tests (ppc64)

Looking good on ppc64.

Re-tested with new deps.
Comment 13 Sergei Trofimovich gentoo-dev 2019-11-28 22:15:58 UTC
commit 05edb1531c40d3d61ac1ff9338af7fc2c7667f97
Author: Rolf Eike Beer <eike@sf-mail.de>
Date:   Tue Nov 26 18:13:44 2019 +0100

    gnome-extra/gnome-contacts: keyworded 3.32.1 for sparc, bug #692802

commit d6ab94fe45b223facaffe486304d866efa0efe7a
Author: Rolf Eike Beer <eike@sf-mail.de>
Date:   Sat Sep 28 13:21:54 2019 +0200

    gui-libs/libhandy: keyworded 0.0.9 for sparc, bug #692802
Comment 14 Sergei Trofimovich gentoo-dev 2019-11-30 21:22:06 UTC
~ppc/~ppc64 keyworded thanks to ernsteiswuerfel!
Comment 15 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2019-12-08 04:16:51 UTC
arm64 keyworded
Comment 16 Émeric Maschino 2020-01-08 22:51:52 UTC
Hi,

Everything's fine on ia64, including tests:
=media-libs/gsound-1.0.2-r1
=gui-libs/libhandy-0.0.9
=gnome-extra/gnome-contacts-3.32.1
=gnome-base/gnome-control-center-3.32.2
=gnome-base/gnome-core-apps-3.32.2

It's noteworthy that for =gnome-base/gnome-control-center-3.32.2 to pass tests successfully, I had to keyword ia64 dev-python/dbusmock and enable xvfb USE flag for x11-base/xorg-server.

Thanks,

     Émeric
Comment 17 Mart Raudsepp gentoo-dev 2020-01-31 20:12:45 UTC
~ia64 done as per testing from Émeric
Comment 18 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2020-03-26 14:07:53 UTC
SuperH port disbanded.
Comment 19 Stabilization helper bot gentoo-dev 2020-03-29 16:59:39 UTC
An automated check of this bug failed - the following invalid arch is referenced in the atom list:

sh
Comment 20 Stabilization helper bot gentoo-dev 2020-03-29 18:02:35 UTC
An automated check of this bug succeeded - the previous repoman errors are now resolved.
Comment 21 NATTkA bot gentoo-dev 2020-04-25 20:20:58 UTC
Unable to check for sanity:

> no match for package: gnome-extra/gnome-contacts-3.32.1
Comment 22 NATTkA bot gentoo-dev 2020-04-25 20:41:17 UTC
Sanity check failed:

> gnome-extra/gnome-tweaks-3.34.0
>   rdepend ~alpha stable profile default/linux/alpha/17.0 (5 total)
>     >=gnome-base/gnome-shell-3.24
Comment 23 NATTkA bot gentoo-dev 2020-04-25 21:05:35 UTC
All sanity-check issues have been resolved
Comment 24 Sam James archtester gentoo-dev Security 2020-06-01 20:36:36 UTC
~arm added
Comment 25 NATTkA bot gentoo-dev 2020-06-07 20:21:13 UTC
Unable to check for sanity:

> no match for package: gnome-base/gnome-control-center-3.34.5
Comment 26 NATTkA bot gentoo-dev 2020-06-07 21:37:04 UTC
All sanity-check issues have been resolved
Comment 27 Mart Raudsepp gentoo-dev 2020-07-18 18:00:26 UTC
*** Bug 733144 has been marked as a duplicate of this bug. ***
Comment 28 NATTkA bot gentoo-dev 2020-07-19 09:03:15 UTC
Sanity check failed:

> gnome-extra/gnome-contacts-3.36.2
>   bdepend ~alpha stable profile default/linux/alpha/17.0 (5 total)
>     net-libs/gnome-online-accounts[vala]
>   depend ~alpha stable profile default/linux/alpha/17.0 (5 total)
>     >=gnome-extra/evolution-data-server-3.13.90:=[gnome-online-accounts]
>     net-libs/gnome-online-accounts:=
>   rdepend ~alpha stable profile default/linux/alpha/17.0 (5 total)
>     >=gnome-extra/evolution-data-server-3.13.90:=[gnome-online-accounts]
>     net-libs/gnome-online-accounts:=
> gnome-base/gnome-control-center-3.36.4
>   rdepend ~alpha stable profile default/linux/alpha/17.0 (5 total)
>     media-plugins/grilo-plugins:0.3[flickr,gnome-online-accounts]
Comment 29 Mart Raudsepp gentoo-dev 2020-07-19 09:12:13 UTC
Giving up on prefix and re-keywording of alpha for stuff that needs webkit-gtk too and what got dropped fully due to webkit
Comment 30 NATTkA bot gentoo-dev 2020-07-19 09:17:56 UTC
All sanity-check issues have been resolved
Comment 31 Matt Turner gentoo-dev 2020-12-11 03:24:33 UTC
alpha done

all arches done