Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 692478 - net-analyzer/net-snmp-5.8-r1 with dev-db/mysql-connector-c-8.* : snmptrapd_sql.c:202:8: error: unknown type name 'my_bool'
Summary: net-analyzer/net-snmp-5.8-r1 with dev-db/mysql-connector-c-8.* : snmptrapd_sq...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: Normal normal with 1 vote (vote)
Assignee: Netmon Herd
URL: https://sourceforge.net/p/net-snmp/bu...
Whiteboard:
Keywords:
: 710064 (view as bug list)
Depends on:
Blocks: mysql-8
  Show dependency tree
 
Reported: 2019-08-18 21:18 UTC by Conrad Kostecki
Modified: 2020-03-04 21:20 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,556.61 KB, text/plain)
2019-08-18 21:20 UTC, Conrad Kostecki
Details
patch to fix my_bool error (tind_v4.patch,319 bytes, patch)
2019-08-19 16:33 UTC, SpikyAtLinux
Details | Diff
Ebuild modified to apply the "my_bool" patch. (net-snmp-5.8-r3.ebuild,5.23 KB, patch)
2020-02-21 20:06 UTC, VSC55
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Conrad Kostecki gentoo-dev 2019-08-18 21:18:59 UTC
libtool: compile:  x86_64-pc-linux-gnu-gcc -I../include -I. -I../agent -I../agent/helpers -I../agent/mibgroup -I/usr/include/libnl3 -I../snmplib -I/usr/include/mysql -I/usr/include/libnl3 -march=native -mfpmath=sse,387 -mtune=intel -O3 -frecord-gcc-switches -fomit-frame-pointer -malign-data=abi -mtls-dialect=gnu2 -pipe -DNETSNMP_ENABLE_IPV6 -fno-strict-aliasing -DNETSNMP_REMOVE_U64 -march=native -mfpmath=sse,387 -mtune=intel -O3 -frecord-gcc-switches -fomit-frame-pointer -malign-data=abi -mtls-dialect=gnu2 -pipe -Ulinux -Dlinux=linux -D_REENTRANT -D_GNU_SOURCE -fwrapv -fno-strict-aliasing -pipe -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/lib64/perl5/5.30.0/x86_64-linux-thread-multi/CORE -c snmptrapd_sql.c  -fPIC -DPIC -o .libs/snmptrapd_sql.o
snmptrapd_sql.c:202:8: error: unknown type name 'my_bool'
  202 | static my_bool    _no_v3;
      |        ^~~~~~~
snmptrapd_sql.c: In function 'netsnmp_mysql_init':
snmptrapd_sql.c:455:5: warning: implicit declaration of function 'my_load_defaults' [-Wimplicit-function-declaration]
  455 |     my_load_defaults ("my", _sql.groups, &not_argc, &not_argv, 0);
      |     ^~~~~~~~~~~~~~~~
snmptrapd_sql.c:532:50: warning: assignment to '_Bool *' from incompatible pointer type 'int *' [-Wincompatible-pointer-types]
  532 |         _tbind[TBIND_v3_SECURITY_ENGINE].is_null = &_no_v3;
      |                                                  ^
make[1]: *** [Makefile:100: snmptrapd_sql.lo] Fehler 1
make[1]: Verzeichnis „/var/tmp/portage/net-analyzer/net-snmp-5.8-r1/work/net-snmp-5.8/apps“ wird verlassen
make: *** [Makefile:663: subdirs] Fehler 1
 * ERROR: net-analyzer/net-snmp-5.8-r1::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=net-analyzer/net-snmp-5.8-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-analyzer/net-snmp-5.8-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/net-analyzer/net-snmp-5.8-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-analyzer/net-snmp-5.8-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/net-analyzer/net-snmp-5.8-r1/work/net-snmp-5.8'
 * S: '/var/tmp/portage/net-analyzer/net-snmp-5.8-r1/work/net-snmp-5.8'

>>> Failed to emerge net-analyzer/net-snmp-5.8-r1, Log file:

>>>  '/var/tmp/portage/net-analyzer/net-snmp-5.8-r1/temp/build.log'

 * Messages for package net-analyzer/net-snmp-5.8-r1:

 * ERROR: net-analyzer/net-snmp-5.8-r1::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=net-analyzer/net-snmp-5.8-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-analyzer/net-snmp-5.8-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/net-analyzer/net-snmp-5.8-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-analyzer/net-snmp-5.8-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/net-analyzer/net-snmp-5.8-r1/work/net-snmp-5.8'
 * S: '/var/tmp/portage/net-analyzer/net-snmp-5.8-r1/work/net-snmp-5.8'
Comment 1 Conrad Kostecki gentoo-dev 2019-08-18 21:20:18 UTC
Created attachment 587374 [details]
build.log
Comment 2 SpikyAtLinux 2019-08-19 16:33:24 UTC
Created attachment 587426 [details, diff]
patch to fix my_bool error

Put the attached patch to /etc/portage/patches/net-analyzer/net-snmp

Regards
Comment 3 Conrad Kostecki gentoo-dev 2019-08-19 18:31:09 UTC
(In reply to SpikyAtLinux from comment #2)
> Created attachment 587426 [details, diff] [details, diff]
> patch to fix my_bool error
> 
> Put the attached patch to /etc/portage/patches/net-analyzer/net-snmp
> 
> Regards

Thanks! Patch works for me.
Comment 4 Larry the Git Cow gentoo-dev 2019-08-19 20:38:41 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=5fc1dd13d685e60d88b767b4ea589f7072bc842c

commit 5fc1dd13d685e60d88b767b4ea589f7072bc842c
Author:     Jeroen Roovers <jer@gentoo.org>
AuthorDate: 2019-08-19 20:36:02 +0000
Commit:     Jeroen Roovers <jer@gentoo.org>
CommitDate: 2019-08-19 20:38:37 +0000

    net-analyzer/net-snmp: Fix building against dev-db/mysql-connector-c-8.*
    
    Package-Manager: Portage-2.3.71, Repoman-2.3.17
    Fixes: https://bugs.gentoo.org/692478
    Signed-off-by: Jeroen Roovers <jer@gentoo.org>

 .../net-snmp/files/net-snmp-5.8-my_bool.patch      |  23 +++
 net-analyzer/net-snmp/net-snmp-5.8-r2.ebuild       | 199 +++++++++++++++++++++
 2 files changed, 222 insertions(+)
Comment 5 Bodo Graumann 2020-02-17 17:38:56 UTC
Got the exact same bug with net-snmp-5.8-r3 and mysql-connector-c-8.0.19, because the patch is not applied there.
Please reopen until -r4 or -r5 is stable.
Comment 6 nwlindale 2020-02-18 04:56:22 UTC
Not resolved/fixed. Still same bug with net-snmp-5.8-r3 and mysql-connector-c-8.0.19.
Comment 7 Jeff Gerhardt 2020-02-18 11:05:46 UTC
Same bug here as well, with mysql flag enabled.
Comment 8 Jeroen Roovers gentoo-dev 2020-02-18 17:02:37 UTC
*** Bug 710064 has been marked as a duplicate of this bug. ***
Comment 9 Neil Bothwick 2020-02-19 09:06:03 UTC
As a temporary workround

mkdir -p /etc/portage/patches/net-analyzer/net-snmp-5.8-r3
cp files/net-snmp-5.8-my_bool.patch /etc/portage/patches/net-analyzer/net-snmp-5.8-r3
Comment 10 Vasil Kanev 2020-02-19 09:33:18 UTC
(In reply to Neil Bothwick from comment #9)
> As a temporary workround
> 
> mkdir -p /etc/portage/patches/net-analyzer/net-snmp-5.8-r3
> cp files/net-snmp-5.8-my_bool.patch
> /etc/portage/patches/net-analyzer/net-snmp-5.8-r3

tnx Neil, it's working.
Comment 11 VSC55 2020-02-21 20:04:43 UTC
Hi, 
The ebuild of version 5.8-r3 has a bug. You are not applying the "net-snmp-5.8-my_bool.patch" patch.
Comment 12 VSC55 2020-02-21 20:06:21 UTC
Created attachment 614960 [details, diff]
Ebuild modified to apply the "my_bool" patch.
Comment 13 AstroFloyd 2020-02-24 09:22:54 UTC
Unmasking net-analyzer/net-snmp-5.8-r4 and updating works for me.  Thanks!
Comment 14 neil.stone 2020-03-04 21:20:32 UTC
Unmasking net-analyzer/net-snmp-5.8-r4 and updating works for me too