Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 692394 (CVE-2019-13917) - <mail-mta/exim-4.92.1-r1: ${sort} in configuration leads to privilege escalation (CVE-2019-13917)
Summary: <mail-mta/exim-4.92.1-r1: ${sort} in configuration leads to privilege escalat...
Status: RESOLVED FIXED
Alias: CVE-2019-13917
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: Gentoo Security
URL:
Whiteboard: A2 [glsa+ cve]
Keywords:
Depends on: CVE-2019-15846
Blocks:
  Show dependency tree
 
Reported: 2019-08-17 22:44 UTC by GLSAMaker/CVETool Bot
Modified: 2019-09-07 00:26 UTC (History)
1 user (show)

See Also:
Package list:
mail-mta/exim-4.92.1-r1
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description GLSAMaker/CVETool Bot gentoo-dev 2019-08-17 22:44:30 UTC
CVE-2019-13917 (https://nvd.nist.gov/vuln/detail/CVE-2019-13917):
  Exim 4.85 through 4.92 (fixed in 4.92.1) allows remote code execution as
  root in some unusual configurations that use the ${sort } expansion for
  items that can be controlled by an attacker (e.g., $local_part or $domain).
Comment 1 Thomas Deutschmann gentoo-dev Security 2019-09-06 15:38:26 UTC
New GLSA request filed.
Comment 2 GLSAMaker/CVETool Bot gentoo-dev 2019-09-07 00:25:21 UTC
This issue was resolved and addressed in
 GLSA 201909-06 at https://security.gentoo.org/glsa/201909-06
by GLSA coordinator Thomas Deutschmann (whissi).