Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 691756 - x11-terms/aterm-1.0.1-r3 : command.c:94:11: fatal error: sys/stropts.h: No such file or directory
Summary: x11-terms/aterm-1.0.1-r3 : command.c:94:11: fatal error: sys/stropts.h: No su...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Jaco Kroon
URL:
Whiteboard:
Keywords: PullRequest
: 708780 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-08-08 17:19 UTC by Toralf Förster
Modified: 2020-04-20 21:28 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.51 KB, text/plain)
2019-08-08 17:19 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,134.87 KB, text/plain)
2019-08-08 17:19 UTC, Toralf Förster
Details
environment (environment,88.46 KB, text/plain)
2019-08-08 17:19 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,17.26 KB, application/x-bzip)
2019-08-08 17:19 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,7.58 KB, application/x-bzip)
2019-08-08 17:19 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,23.63 KB, application/x-bzip)
2019-08-08 17:20 UTC, Toralf Förster
Details
x11-terms:aterm-1.0.1-r3:20190808-034043.log (x11-terms:aterm-1.0.1-r3:20190808-034043.log,12.29 KB, text/plain)
2019-08-08 17:20 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2019-08-08 17:19:44 UTC
/bin/sed -n -f ./makeprotos-sed thai.c > thai.pro
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H  -c -O2 -pipe -march=native -Wall -DNO_DEBUG_OUTPUT         -I. -I.. -I.  command.c
command.c:94:11: fatal error: sys/stropts.h: No such file or directory
   94 | # include <sys/stropts.h> /* for I_PUSH */
      |           ^~~~~~~~~~~~~~~
compilation terminated.

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_no-multilib_hardened-20190805-211951

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.1.0 *

Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7 (fallback)
  [3]   pypy (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.36.0 *



emerge -qpvO x11-terms/aterm
--- Invalid atom in /etc/portage/package.accept_keywords/00unstable: sys-libs/glibc-2.30
Comment 1 Toralf Förster gentoo-dev 2019-08-08 17:19:46 UTC
Created attachment 586170 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2019-08-08 17:19:49 UTC
Created attachment 586172 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2019-08-08 17:19:52 UTC
Created attachment 586174 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2019-08-08 17:19:54 UTC
Created attachment 586176 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2019-08-08 17:19:57 UTC
Created attachment 586178 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2019-08-08 17:20:00 UTC
Created attachment 586180 [details]
temp.tbz2
Comment 7 Toralf Förster gentoo-dev 2019-08-08 17:20:03 UTC
Created attachment 586182 [details]
x11-terms:aterm-1.0.1-r3:20190808-034043.log
Comment 8 Miroslav Šulc gentoo-dev 2019-12-08 09:12:14 UTC
the website says: "aterm is deprecated and in a maintenance mode only; there will be no further updates. Use rxvt-unicode instead." also nothing depends on it in the tree, so might be a last-rite adept...
Comment 9 Hanno Böck gentoo-dev 2020-02-16 19:35:25 UTC
*** Bug 708780 has been marked as a duplicate of this bug. ***
Comment 10 Sergei Trofimovich gentoo-dev 2020-02-17 20:31:26 UTC
Uses I_PUSH ioctl. Probably does not work.
Comment 11 Larry the Git Cow gentoo-dev 2020-03-26 21:33:17 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=1a5b3cab908c19c899a1c4710d80fa1a6b4dedb9

commit 1a5b3cab908c19c899a1c4710d80fa1a6b4dedb9
Author:     Andreas K. Huettel <dilfridge@gentoo.org>
AuthorDate: 2020-03-26 21:32:11 +0000
Commit:     Andreas K. Huettel <dilfridge@gentoo.org>
CommitDate: 2020-03-26 21:32:11 +0000

    package.mask: Mask x11-terms/aterm and x11-terms/xvt for removal
    
    Bug: https://bugs.gentoo.org/691756
    Bug: https://bugs.gentoo.org/691710
    Signed-off-by: Andreas K. Huettel <dilfridge@gentoo.org>

 profiles/package.mask | 6 ++++++
 1 file changed, 6 insertions(+)
Comment 12 Jaco Kroon 2020-03-27 11:51:38 UTC
From: http://www.afterstep.org/aterm.php

Latest Version 1.0.1 was released on August 1, 2007

aterm is deprecated and in a maintenance mode only; there will be no further updates. Use rxvt-unicode instead.
Comment 13 Larry the Git Cow gentoo-dev 2020-04-20 21:27:40 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=59f6d9714c8e46af940c43f9ae7a527386929c35

commit 59f6d9714c8e46af940c43f9ae7a527386929c35
Author:     Ilia Mirkin <imirkin@alum.mit.edu>
AuthorDate: 2020-04-14 17:35:21 +0000
Commit:     Matt Turner <mattst88@gentoo.org>
CommitDate: 2020-04-20 21:26:31 +0000

    x11-terms/aterm: add patch to remove streams functionality
    
    STREAMS were never supported in Linux, and have been removed from
    glibc-2.30. This causes aterm to no longer build.
    
    The included patch fixes the build by making the code follow the old
    paths, on the assumption that the ioctls never did anything to begin
    with.
    
    Practical testing with this patch has not revealed any obvious issues.
    
    Bug: https://bugs.gentoo.org/691756
    Signed-off-by: Ilia Mirkin <imirkin@alum.mit.edu>
    Signed-off-by: Matt Turner <mattst88@gentoo.org>

 x11-terms/aterm/aterm-1.0.1-r4.ebuild              | 90 ++++++++++++++++++++++
 .../aterm/files/aterm-1.0.1-remove-streams.patch   | 36 +++++++++
 2 files changed, 126 insertions(+)