Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 690106 - dev-util/omake-0.10.3 : (.text+<snip>): undefined reference to tgetent
Summary: dev-util/omake-0.10.3 : (.text+<snip>): undefined reference to tgetent
Status: RESOLVED DUPLICATE of bug 460386
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Team for the ML programming language family
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-17 19:51 UTC by Toralf Förster
Modified: 2019-07-17 20:18 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.19 KB, text/plain)
2019-07-17 19:51 UTC, Toralf Förster
Details
dev-util:omake-0.10.3:20190717-194626.log (dev-util:omake-0.10.3:20190717-194626.log,4.30 KB, text/plain)
2019-07-17 19:51 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,236.70 KB, text/plain)
2019-07-17 19:51 UTC, Toralf Förster
Details
environment (environment,74.42 KB, text/plain)
2019-07-17 19:51 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,18.51 KB, application/x-bzip)
2019-07-17 19:51 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,18.80 KB, application/x-bzip)
2019-07-17 19:51 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2019-07-17 19:51:43 UTC
ocamlc -safe-string -g -w -40  -custom -o omake_gen_parse.byte  unix.cma   omake_gen_parse.cmo
/usr/lib/gcc/x86_64-pc-linux-gnu/9.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: /usr/lib64/ocaml/libcamlrun.a(terminfo.o): in function `caml_terminfo_setup':
(.text+0x7b): undefined reference to `tgetent'
/usr/lib/gcc/x86_64-pc-linux-gnu/9.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: (.text+0x98): undefined reference to `tgetnum'
/usr/lib/gcc/x86_64-pc-linux-gnu/9.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: (.text+0xb1): undefined reference to `tgetstr'
/usr/lib/gcc/x86_64-pc-linux-gnu/9.1.0/../../../../x86_64-pc-linux-gnu/bin/ld: (.text+0xcb): undefined reference to `tgetstr'

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_hardened-libressl-20190713-133107

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.1.0 *

Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.36.0 *



emerge -qpvO dev-util/omake
[ebuild  N    ] dev-util/omake-0.10.3  USE="ncurses ocamlopt readline -doc -fam"
Comment 1 Toralf Förster gentoo-dev 2019-07-17 19:51:46 UTC
Created attachment 583340 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2019-07-17 19:51:48 UTC
Created attachment 583342 [details]
dev-util:omake-0.10.3:20190717-194626.log
Comment 3 Toralf Förster gentoo-dev 2019-07-17 19:51:51 UTC
Created attachment 583344 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2019-07-17 19:51:54 UTC
Created attachment 583346 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2019-07-17 19:51:56 UTC
Created attachment 583348 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2019-07-17 19:51:59 UTC
Created attachment 583350 [details]
temp.tbz2
Comment 7 Lars Wendler (Polynomial-C) gentoo-dev 2019-07-17 20:18:40 UTC

*** This bug has been marked as a duplicate of bug 460386 ***