Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 689626 - dev-erlang/fast_xml-1.1.34 : This BEAM file was compiled for a later version of the run-time system than 21.
Summary: dev-erlang/fast_xml-1.1.34 : This BEAM file was compiled for a later version...
Status: RESOLVED DUPLICATE of bug 661126
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-10 18:29 UTC by Toralf Förster
Modified: 2019-09-17 14:28 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.97 KB, text/plain)
2019-07-10 18:29 UTC, Toralf Förster
Details
dev-erlang:fast_xml-1.1.34:20190710-160102.log (dev-erlang:fast_xml-1.1.34:20190710-160102.log,4.22 KB, text/plain)
2019-07-10 18:29 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,201.12 KB, text/plain)
2019-07-10 18:29 UTC, Toralf Förster
Details
environment (environment,18.67 KB, text/plain)
2019-07-10 18:29 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,11.50 KB, application/x-bzip)
2019-07-10 18:29 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,4.66 KB, application/x-bzip)
2019-07-10 18:29 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,7.63 KB, application/x-bzip)
2019-07-10 18:29 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2019-07-10 18:29:13 UTC
=ERROR REPORT==== 10-Jul-2019::18:01:08.735291 ===
beam/beam_load.c(1871): Error loading module rebar:
  This BEAM file was compiled for a later version of the run-time system than 21.
  To fix this, please recompile this module with an 21 compiler.
  (Use of opcode 164; this emulator supports only up to 163.)


  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop_gnome-libressl-20190705-194634

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.1.0 *

Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7 (fallback)
  [3]   pypy (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.35.0 *
  [2]   rust-bin-1.36.0
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.12.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpvO dev-erlang/fast_xml
[ebuild  N    ] dev-erlang/fast_xml-1.1.34  USE="-test"
Comment 1 Toralf Förster gentoo-dev 2019-07-10 18:29:16 UTC
Created attachment 582452 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2019-07-10 18:29:19 UTC
Created attachment 582454 [details]
dev-erlang:fast_xml-1.1.34:20190710-160102.log
Comment 3 Toralf Förster gentoo-dev 2019-07-10 18:29:21 UTC
Created attachment 582456 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2019-07-10 18:29:24 UTC
Created attachment 582458 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2019-07-10 18:29:27 UTC
Created attachment 582460 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2019-07-10 18:29:29 UTC
Created attachment 582462 [details]
logs.tbz2
Comment 7 Toralf Förster gentoo-dev 2019-07-10 18:29:32 UTC
Created attachment 582464 [details]
temp.tbz2
Comment 8 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-09-12 13:51:47 UTC
This sounds like some weird erlang downgrade problem (?).
Comment 9 Toralf Förster gentoo-dev 2019-09-12 16:50:03 UTC
(In reply to Michał Górny from comment #8)
> This sounds like some weird erlang downgrade problem (?).

Indeed, /me wonders which package forced the downgrade b/c the tinderbox itself avoids a direct downgrade of a package.
Comment 10 Hanno Boeck gentoo-dev 2019-09-17 14:28:31 UTC

*** This bug has been marked as a duplicate of bug 661126 ***