Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 689368 - net-misc/iputils-20190515 USE=static - ld: attempted static link of dynamic object `/usr/lib64/libssl.so'
Summary: net-misc/iputils-20190515 USE=static - ld: attempted static link of dynamic o...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-06 17:13 UTC by Alpha Bravo
Modified: 2022-05-11 18:39 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (iputils-20190515+static_build.log,10.17 KB, text/plain)
2019-07-06 17:13 UTC, Alpha Bravo
Details
emerge --info iputils (iputils-20190515_emerge-info.txt,5.52 KB, text/plain)
2019-07-07 07:15 UTC, Alpha Bravo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alpha Bravo 2019-07-06 17:13:18 UTC
Created attachment 582064 [details]
build.log

On aarch64-unknown-linux-gnu net-misc/iputils-20190515 with USE="static" fails
to compile:
ld: attempted static link of dynamic object `/usr/lib64/libssl.so'
libssl.so is provided by dev-libs/openssl-1.1.0k[static-libs]
Comment 1 Jonas Stein gentoo-dev 2019-07-06 21:27:06 UTC
hank you for the report. Please recompile and 
paste the emerge info as described on
https://wiki.gentoo.org/wiki/Attach_the_logs_to_the_bug_ticket
The logs must be part of the ticket, but not on external websites.
We need to have all information at hand before ticket assignment, so that the maintainer can look after it in one session with minimal number of callbacks.
Please reopen this ticket (Status:unconfirmed) afterwards.
Comment 2 Alpha Bravo 2019-07-07 07:15:38 UTC
Created attachment 582094 [details]
emerge --info iputils
Comment 3 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2020-04-15 23:34:44 UTC
Hit this on arm64.
Comment 4 Rolf Eike Beer archtester 2020-04-16 07:33:18 UTC
Also happens with 20190709-r1 on sparc with:

USE='SECURITY_HAZARD arping -caps -clockdiff doc -filecaps -gcrypt idn ipv6 -nettle nls rarpd -rdisc ssl static -tftpd tracepath -traceroute6'
Comment 5 Thomas Deutschmann (RETIRED) gentoo-dev 2020-08-23 02:20:33 UTC
This bug will be obsolete with iputils-20200821 which removed deps on ssl (ssl was only used to pull in md5 which is now copied into iputils).
Comment 6 Rolf Eike Beer archtester 2021-05-10 06:36:58 UTC
Not really, the issue is just going to the next lib (net-misc/iputils-20210202):

/usr/lib/gcc/hppa2.0-unknown-linux-gnu/9.3.0/../../../../hppa2.0-unknown-linux-gnu/bin/ld: attempted static link of dynamic object `/usr/lib/libidn2.so'
Comment 7 Mike Gilbert gentoo-dev 2021-05-10 15:55:07 UTC
I would suggest dropping IUSE="static" from this package. These utilities would be of little use in a system recovery scenario, and I can't think of any other reason to have them linked staticly.
Comment 8 Mike Gilbert gentoo-dev 2022-05-11 18:39:02 UTC
Recent versions of iputils do no link with libssl.