Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 689312 - dev-libs/papi: assumes /usr/lib
Summary: dev-libs/papi: assumes /usr/lib
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
: 737106 (view as bug list)
Depends on:
Blocks: no-symlink-lib
  Show dependency tree
 
Reported: 2019-07-05 08:47 UTC by Phil Tooley
Modified: 2021-02-27 01:00 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
fixed papi 5.5.1 ebuild (papi-5.5.1.ebuild,815 bytes, text/plain)
2019-07-05 08:47 UTC, Phil Tooley
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Phil Tooley 2019-07-05 08:47:35 UTC
Created attachment 581944 [details]
fixed papi 5.5.1 ebuild

By default PAPI assumes that libpfm.a is found in ${EPREFIX}/usr/lib, which is no longer the case following the removal of this symlink in the 17.1 profile.

Fix is to provide --with-pfm-libdir="${EPREFIX}/usr/lib64" as in attached ebuild.

I have only attached the one ebuild as example but this bug appears to affect all versions in portage.
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2019-07-05 16:20:11 UTC
Comment on attachment 581944 [details]
fixed papi 5.5.1 ebuild

--- a/papi-5.5.1.ebuild
+++ b/papi-5.5.1.ebuild
@@ -28,6 +28,7 @@
                --with-shlib
                --with-perf-events
                --with-pfm-prefix="${EPREFIX}/usr"
+               --with-pfm-libdir="${EPREFIX}/usr/lib64"
        )
        autotools-utils_src_configure
 }


Um, what if your LIBDIR happens to be something other than "lib64"?


Please attach the entire failing build log to this bug report.
Comment 2 Sam James archtester gentoo-dev Security 2021-02-26 23:43:02 UTC
*** Bug 737106 has been marked as a duplicate of this bug. ***
Comment 3 Larry the Git Cow gentoo-dev 2021-02-27 01:00:25 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d700f2f88da0b2b461d18229baa97cac5e3ab9a9

commit d700f2f88da0b2b461d18229baa97cac5e3ab9a9
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2021-02-26 23:43:41 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-02-27 01:00:07 +0000

    dev-libs/papi: EAPI 7, fix libdir
    
    Closes: https://bugs.gentoo.org/689312
    Package-Manager: Portage-3.0.15, Repoman-3.0.2
    Signed-off-by: Sam James <sam@gentoo.org>

 dev-libs/papi/papi-5.5.1.ebuild | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)