Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 688894 - dev-java/openjfx-11.0.3_p1 : * gradle failed
Summary: dev-java/openjfx-11.0.3_p1 : * gradle failed
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Georgy Yakovlev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-28 16:48 UTC by Toralf Förster
Modified: 2020-04-29 21:05 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.68 KB, text/plain)
2019-06-28 16:48 UTC, Toralf Förster
Details
dev-java:openjfx-11.0.3_p1:20190628-151301.log (dev-java:openjfx-11.0.3_p1:20190628-151301.log,4.29 KB, text/plain)
2019-06-28 16:48 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,242.02 KB, text/plain)
2019-06-28 16:48 UTC, Toralf Förster
Details
environment (environment,152.57 KB, text/plain)
2019-06-28 16:48 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,19.94 KB, application/x-bzip)
2019-06-28 16:48 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2019-06-28 16:48:36 UTC
 * ERROR: dev-java/openjfx-11.0.3_p1::gentoo failed (compile phase):
 *   gradle failed
 * 

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1-desktop-plasma_20190621-192548

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-8.3.1
 [2] x86_64-pc-linux-gnu-9.1.0 *

Available Python interpreters, in order of preference:
  [1]   python3.7
  [2]   python3.6
  [3]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.35.0 *
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.12.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpvO dev-java/openjfx
[ebuild  N    ] dev-java/openjfx-11.0.3_p1  USE="media -debug -doc -source" CPU_FLAGS_X86="sse2"
Comment 1 Toralf Förster gentoo-dev 2019-06-28 16:48:39 UTC
Created attachment 581256 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2019-06-28 16:48:41 UTC
Created attachment 581258 [details]
dev-java:openjfx-11.0.3_p1:20190628-151301.log
Comment 3 Toralf Förster gentoo-dev 2019-06-28 16:48:44 UTC
Created attachment 581260 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2019-06-28 16:48:47 UTC
Created attachment 581262 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2019-06-28 16:48:50 UTC
Created attachment 581264 [details]
etc.portage.tbz2
Comment 6 Georgy Yakovlev gentoo-dev 2019-06-28 17:12:53 UTC
just for reference:

https://bugs.gentoo.org/651644
and
https://bugs.gentoo.org/648720

and https://github.com/gradle/gradle/issues/4426

I can't reproduce this but build system that depends on TERM value is not good.
I'll probably add a workaround by passing --console=plain if this gradle supports it.
Comment 7 Georgy Yakovlev gentoo-dev 2019-06-28 17:14:14 UTC
you have TERM=unknown

how do you launch the buildjob? I just want to follow workflow to understand where it goes wrong and sets this TERM.
Comment 8 Toralf Förster gentoo-dev 2019-06-28 17:37:30 UTC
(In reply to Georgy Yakovlev from comment #7)
> you have TERM=unknown
> 
> how do you launch the buildjob? I just want to follow workflow to understand
> where it goes wrong and sets this TERM.

Usually a shell script starts the chroot wrapper:

  https://github.com/toralf/tinderbox/blob/master/bin/start_img.sh#L64

which eventually starts the chroot image

  https://github.com/toralf/tinderbox/blob/master/bin/chr.sh#L138

which calls emerge

  https://github.com/toralf/tinderbox/blob/master/bin/job.sh#L1254

here:

  https://github.com/toralf/tinderbox/blob/master/bin/job.sh#L1122
Comment 9 Andreas Thalhammer 2019-10-06 11:07:14 UTC
I just hit the same bug.

dev-java/openjfx-11.0.3_p1 USE="media -debug -doc -source" CPU_FLAGS_X86="sse2"
dev-java/openjdk-11.0.4_p11 USE="alsa cups javafx* jbootstrap pch webstart -debug -doc -examples (-gentoo-vm) -headless-awt -nsplugin (-selinux) -source -systemtap"

It was easily solved by running
# TERM=xterm-color emerge -av dev-java/openjdk

Solution found at:
https://github.com/gradle/gradle/issues/5355

My TERM setting (I run all my emerges under Konsole in KDE/Plasma Desktop):
# echo $TERM
xterm-256color

Would it be possible to add a check in the ebuild and set TERM accordingly?
Comment 10 Joakim Tjernlund 2019-11-01 15:44:30 UTC
This is due to old ncurses-5.9 don't know xterm-256color
I have proposed to upgrade ncurses-compat in 
https://bugs.gentoo.org/698266
Comment 11 Joakim Tjernlund 2019-12-03 12:13:25 UTC
(In reply to Joakim Tjernlund from comment #10)
> This is due to old ncurses-5.9 don't know xterm-256color
> I have proposed to upgrade ncurses-compat in 
> https://bugs.gentoo.org/698266

Now that sys-libs/ncurses-compat-6.1_p20190609 is in the tree you could
retest and hopefully close this bug.
Comment 12 Mark Nowiasz 2020-01-21 06:47:33 UTC
I've also run into the bug. I've installed sys-libs/ncurses-compat-6.1_p20190609, but doesn't change a thing - gradle still doesn't compile:

    [mkdir] Created dir: /var/tmp/portage/dev-java/openjfx-11.0.3_p1/work/rt-11.0.3+1/apps/samples/3DViewer/build/empty
    [mkdir] Created dir: /var/tmp/portage/dev-java/openjfx-11.0.3_p1/work/rt-11.0.3+1/apps/samples/3DViewer/build/generated-sources/ap-source-output
    [javac] Compiling 143 source files to /var/tmp/portage/dev-java/openjfx-11.0    [javac] error: invalid flag: @/var/tmp/portage/dev-java/openjfx-11.0.3_p1/work/rt-11.0.3+1/build/compile.args
    [javac] Usage: javac <options> <source files>
    [javac] use --help for a list of possible options
Comment 13 Andreas Thalhammer 2020-01-26 13:27:03 UTC
Still present with todays openjfx update: less /var/tmp/portage/dev-java/openjfx-11.0.6_p2/temp/build.log


 * Package:    dev-java/openjfx-11.0.6_p2
 * Repository: gentoo
 * Maintainer: gyakovlev@gentoo.org java@gentoo.org
 * USE:        abi_x86_64 amd64 cpu_flags_x86_sse2 elibc_glibc kernel_linux media userland_GNU
 * FEATURES:   network-sandbox preserve-libs sandbox userpriv usersandbox
>>> Unpacking source...
>>> Unpacking openjfx-11.0.6_p2.tar.bz2 to /var/tmp/portage/dev-java/openjfx-11.0.6_p2/work
>>> Unpacking gradle-4.8-bin.zip to /var/tmp/portage/dev-java/openjfx-11.0.6_p2/work
'/var/tmp/portage/dev-java/openjfx-11.0.6_p2/distdir/lucene-sandbox-7.1.0.jar' -> '/var/tmp/portage/dev-java/openjfx-11.0.6_p2/temp/jars/lucene-sandbox-7.1.0.jar'
'/var/tmp/portage/dev-java/openjfx-11.0.6_p2/distdir/lucene-grouping-7.1.0.jar' -> '/var/tmp/portage/dev-java/openjfx-11.0.6_p2/temp/jars/lucene-grouping-7.1.0.jar'
'/var/tmp/portage/dev-java/openjfx-11.0.6_p2/distdir/lucene-queryparser-7.1.0.jar' -> '/var/tmp/portage/dev-java/openjfx-11.0.6_p2/temp/jars/lucene-queryparser-7.1.0.jar'
'/var/tmp/portage/dev-java/openjfx-11.0.6_p2/distdir/lucene-queries-7.1.0.jar' -> '/var/tmp/portage/dev-java/openjfx-11.0.6_p2/temp/jars/lucene-queries-7.1.0.jar'
'/var/tmp/portage/dev-java/openjfx-11.0.6_p2/distdir/lucene-core-7.1.0.jar' -> '/var/tmp/portage/dev-java/openjfx-11.0.6_p2/temp/jars/lucene-core-7.1.0.jar'
'/var/tmp/portage/dev-java/openjfx-11.0.6_p2/distdir/gunit-3.5.2.jar' -> '/var/tmp/portage/dev-java/openjfx-11.0.6_p2/temp/jars/gunit-3.5.2.jar'
'/var/tmp/portage/dev-java/openjfx-11.0.6_p2/distdir/antlr4-4.7.2-complete.jar' -> '/var/tmp/portage/dev-java/openjfx-11.0.6_p2/temp/jars/antlr4-4.7.2-complete.jar'
'/var/tmp/portage/dev-java/openjfx-11.0.6_p2/distdir/ST4-4.0.8.jar' -> '/var/tmp/portage/dev-java/openjfx-11.0.6_p2/temp/jars/ST4-4.0.8.jar'
>>> Source unpacked in /var/tmp/portage/dev-java/openjfx-11.0.6_p2/work
>>> Preparing source in /var/tmp/portage/dev-java/openjfx-11.0.6_p2/work/rt-11.0.6+2 ...
 * Applying disable-buildSrc-tests.patch ...
 [ ok ]
 * Applying glibc-compatibility.patch ...
 [ ok ]
 * Applying respect-user-cflags.patch ...
 [ ok ]
 * Applying use-system-swt-jar.patch ...
 [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-java/openjfx-11.0.6_p2/work/rt-11.0.6+2 ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/dev-java/openjfx-11.0.6_p2/work/rt-11.0.6+2 ...
 * gradle --info --stacktrace --no-build-cache --no-daemon --offline --gradle-user-home /var/tmp/portage/dev-java/openjfx-11.0.6_p2/temp/gradle_user_home --project-cache-dir /var/tmp/portage/dev-java/openjfx-11.0.6_p2/temp/gradle_project_cache zips --exclude-task javadoc
Initialized native services in: /var/tmp/portage/dev-java/openjfx-11.0.6_p2/temp/gradle_user_home/native

FAILURE: Build failed with an exception.

* What went wrong:
Could not open terminal for stdout: could not get termcap entry

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org
 * ERROR: dev-java/openjfx-11.0.6_p2::gentoo failed (compile phase):
 *   gradle failed
 * 
 * Call stack:
 *     ebuild.sh, line  125:  Called src_compile
 *   environment, line 3950:  Called egradle 'zips' '--exclude-task' 'javadoc'
 *   environment, line  841:  Called die
 * The specific snippet of code:
 *       "${gradle}" "${gradle_args[@]}" ${@} || die "gradle failed"
 * 
 * If you need support, post the output of `emerge --info '=dev-java/openjfx-11.0.6_p2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-java/openjfx-11.0.6_p2::gentoo'`.
!!! When you file a bug report, please include the following information:
GENTOO_VM=  CLASSPATH="" JAVA_HOME="/usr/lib64/openjdk-11"
JAVACFLAGS="" COMPILER=""
and of course, the output of emerge --info =openjfx-11.0.6_p2
 * The complete build log is located at '/var/tmp/portage/dev-java/openjfx-11.0.6_p2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-java/openjfx-11.0.6_p2/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-java/openjfx-11.0.6_p2/work/rt-11.0.6+2'
 * S: '/var/tmp/portage/dev-java/openjfx-11.0.6_p2/work/rt-11.0.6+2'
Comment 14 nE0sIghT 2020-02-10 15:59:10 UTC
The problem here is not in valid TERM variable, but in wrong (old) gradle (actually shipped with it native-platform-0.14 [1]).

Gradle 4.8 got shipped with lib/native-platform-*-ncurses[56]-0.14.jar - supporting both ncurses5 and ncurses6 systems. However it tryes to load ncurses5 libs first.

When sys-libs/ncurses-compat:5 is installed gradle loads ncurses5 libs that do not know newer TERM values like xterm-256color.

As a workaround we can:
1. DEPEND on sys-libs/ncurses:0/6
2. mv all lib/*ncurses6*.jar to lib/*ncurses5*.jar

[1] https://github.com/gradle/native-platform/tree/0.14
Comment 15 Larry the Git Cow gentoo-dev 2020-04-29 21:05:31 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a3613d5eee1cdaa0c8465a924818bb1348d39918

commit a3613d5eee1cdaa0c8465a924818bb1348d39918
Author:     Georgy Yakovlev <gyakovlev@gentoo.org>
AuthorDate: 2020-04-29 21:00:40 +0000
Commit:     Georgy Yakovlev <gyakovlev@gentoo.org>
CommitDate: 2020-04-29 21:05:01 +0000

    dev-java/openjfx: fix build with uncommon TERM, add -fcommon
    
    Closes: https://bugs.gentoo.org/719606
    Closes: https://bugs.gentoo.org/719958
    Closes: https://bugs.gentoo.org/688894
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>

 dev-java/openjfx/openjfx-11.0.7_p1.ebuild | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)