Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 688638 - sys-devel/clang-8.0.0 : [TEST] FAILED: test/CMakeFiles/check-clang
Summary: sys-devel/clang-8.0.0 : [TEST] FAILED: test/CMakeFiles/check-clang
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: LLVM support project
URL:
Whiteboard:
Keywords: TESTFAILURE
Depends on:
Blocks:
 
Reported: 2019-06-24 18:29 UTC by Toralf Förster
Modified: 2019-06-27 18:29 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.44 KB, text/plain)
2019-06-24 18:29 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,54.26 KB, text/plain)
2019-06-24 18:29 UTC, Toralf Förster
Details
environment (environment,183.98 KB, text/plain)
2019-06-24 18:29 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,12.07 KB, application/x-bzip)
2019-06-24 18:29 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,13.17 KB, application/x-bzip)
2019-06-24 18:30 UTC, Toralf Förster
Details
sys-devel:clang-8.0.0:20190624-034450.log.bz2 (sys-devel:clang-8.0.0:20190624-034450.log.bz2,332.32 KB, application/x-bzip)
2019-06-24 18:30 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2019-06-24 18:29:47 UTC
  Unsupported Tests  : 271
  Unexpected Failures: 96
FAILED: test/CMakeFiles/check-clang 
cd /var/tmp/portage/sys-devel/clang-8.0.0/work/x/y/cfe-8.0.0.src-abi_x86_32.x86/test && /var/tmp/portage/sys-devel/clang-8.0.0/temp/python2.7/bin/python /var/tmp/portage/sys-devel/clang-8.0.0/work/x/y/cfe-8.0.0.src-abi_x86_32.x86/./bin/llvm-lit -vv -j 1 --param clang_site_config=/var/tmp/portage/sys-devel/clang-8.0.0/work/x/y/cfe-8.0.0.src-abi_x86_32.x86/test/lit.site.cfg --param USE_Z3_SOLVER=0 /var/tmp/portage/sys-devel/clang-8.0.0/work/x/y/cfe-8.0.0.src-abi_x86_32.x86/test
ninja: build stopped: subcommand failed.
 * ERROR: sys-devel/clang-8.0.0::gentoo failed (test phase):

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1-desktop-gnome_libressl-abi32+64-test_20190621-191902

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-8.3.1
 [2] x86_64-pc-linux-gnu-9.1.0 *

Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7 (fallback)


java-config:
The following VMs are available for generation-2:
Available Java Virtual Machines:
  (none found)

emerge -qpvO sys-devel/clang
[ebuild  N    ] sys-devel/clang-8.0.0  USE="static-analyzer test xml -debug -default-compiler-rt -default-libcxx -doc -z3" ABI_X86="32 (64) (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -Lanai -MSP430 -Mips -PowerPC -Sparc -SystemZ -WebAssembly -XCore" PYTHON_TARGETS="python2_7"
Comment 1 Toralf Förster gentoo-dev 2019-06-24 18:29:50 UTC
Created attachment 580700 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2019-06-24 18:29:53 UTC
Created attachment 580702 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2019-06-24 18:29:55 UTC
Created attachment 580704 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2019-06-24 18:29:58 UTC
Created attachment 580706 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2019-06-24 18:30:01 UTC
Created attachment 580708 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2019-06-24 18:30:04 UTC
Created attachment 580710 [details]
sys-devel:clang-8.0.0:20190624-034450.log.bz2
Comment 7 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-06-24 18:44:06 UTC
How did you manage this?  Could you also try -8.0.9999 and -9999 for comparison?
Comment 8 Toralf Förster gentoo-dev 2019-06-24 19:39:05 UTC
(In reply to Michał Górny from comment #7)
> How did you manage this?  Could you also try -8.0.9999 and -9999 for
> comparison?

/me wonders, why this won't work:

mr-fox ~ # cat /etc/portage/package.unmask/clang
sys-devel/clang:8
sys-devel/llvm:8
~sys-devel/clang-8.0.9999
~sys-devel/clang-common-8.0.9999
~sys-devel/clang-runtime-8.0.9999
~sys-devel/llvm-8.0.9999
~sys-devel/llvm-common-8.0.9999

mr-fox ~ # cat /etc/portage/package.accept_keywords/clang
sys-devel/clang:8 **
sys-devel/llvm:8 **
~sys-devel/clang-8.0.9999 **
~sys-devel/clang-runtime-8.0.9999 **
~sys-devel/clang-common-8.0.9999 **
~sys-devel/llvm-8.0.9999 **
~sys-devel/llvm-common-8.0.9999 **

mr-fox ~ # emerge -upvt --backtrack=500 sys-devel/clang sys-devel/clang-common sys-devel/clang-runtime sys-devel/llvm-common sys-devel/llvm

These are the packages that would be merged, in reverse order:

Calculating dependencies  . ... done!
[ebuild     U *] sys-devel/llvm-common-8.0.9999::gentoo [8.0.0::gentoo] 0 KiB

Total: 1 package (1 upgrade), Size of downloads: 0 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

sys-devel/llvm:8

  (sys-devel/llvm-8.0.9999:8/8::gentoo, ebuild scheduled for merge) conflicts with
    ~sys-devel/llvm-8.0.0:8/8=[-debug,llvm_targets_AMDGPU,llvm_targets_BPF,llvm_targets_NVPTX,llvm_targets_X86,abi_x86_32(-),abi_x86_64(-)] required by (sys-devel/clang-8.0.0:8/8::gentoo, installed)
    ^               ^^^^^                                                                                                                  
    ~sys-devel/llvm-8.0.0:8=[-debug,llvm_targets_AMDGPU,llvm_targets_BPF,llvm_targets_NVPTX,llvm_targets_X86,abi_x86_32(-),abi_x86_64(-)] required by (sys-devel/clang-8.0.0:8/8::gentoo, installed)
    ^               ^^^^^                                                                                                                


!!! The following update(s) have been skipped due to unsatisfied dependencies
!!! triggered by backtracking:

sys-devel/clang:8
Comment 9 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-06-24 20:09:53 UTC
Maybe some deeper dependencies.
Comment 10 Toralf Förster gentoo-dev 2019-06-27 18:29:42 UTC
The issue happened at 2 other images too:
17.1_libressl-abi32+64-test_20190624-213954 and
17.1-systemd_libressl-test_20190623-103445

maybe libressl related?