Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 688432 - dev-lang/perl-5.28.2-r1 fails to build on armv5te with gcc-8.3.0-r1
Summary: dev-lang/perl-5.28.2-r1 fails to build on armv5te with gcc-8.3.0-r1
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-21 12:43 UTC by Christoph Junghans
Modified: 2019-09-15 20:49 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,57.16 KB, text/x-log)
2019-06-21 12:43 UTC, Christoph Junghans
Details
environment (environment,106.63 KB, text/plain)
2019-06-21 12:44 UTC, Christoph Junghans
Details
build-5.30.0.log (build-5.30.0.log,65.78 KB, text/x-log)
2019-07-21 14:18 UTC, Pierre-Olivier Mercier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Junghans gentoo-dev 2019-06-21 12:43:26 UTC
Created attachment 580284 [details]
build.log

Building perl-5.28.2-r1 with gcc-8.3.0-r1 on my armv5te fails with:

Can't locate ExtUtils/MakeMaker/version/vpp.pm in @INC (you may need to install the ExtUtils::MakeMaker::version::vpp module)

Compiling perl-5.28.2-r1 with gcc-7.3.0-r3 works fine.
Comment 1 Christoph Junghans gentoo-dev 2019-06-21 12:44:09 UTC
Created attachment 580286 [details]
environment
Comment 2 Andreas K. Hüttel gentoo-dev 2019-07-14 19:13:24 UTC
@everyone, 

as a data point when talking to upstream, could you please test if this failure still happens with perl-5.30.0 ?

You dont need to actually install perl-5.30.0 for that; it's enough if you run

ebuild /usr/portage/dev-lang/perl/perl-5.30.0.ebuild clean test
Comment 3 Pierre-Olivier Mercier 2019-07-21 14:17:36 UTC
I got the same error when compiling perl-5.30.0 with gcc-8.3.0-r1 (don't have gcc-7 anymore on my armv5 host to test).
Comment 4 Pierre-Olivier Mercier 2019-07-21 14:18:39 UTC
Created attachment 583926 [details]
build-5.30.0.log
Comment 5 James McMechan 2019-09-15 20:49:55 UTC
I have had some success with
EXTRA_ECONF="-Dd_u32align" emerge -av1 perl
from https://rt.perl.org/Public/Bug/Display.html?id=133803
Apparently gcc optimizes out the endian/alignment tests from ./configure
And the bug was rejected by gc as invalid since unaligned access has undefined behaviour.

I am more than slightly irked as the gcc people are engaged in such aggressive optimization that it has been breaking things for a while.
I would like to have a "C" compiler, one that does not require c++
or keep changing things that have worked for years because you can move it to undefined.