Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 688384 - dev-python/ipykernel-4.6.1-r2 with python3_7 - SyntaxError: invalid syntax ( in def expect(self, pattern, timeout=-1, searchwindowsize=-1, async=False): )
Summary: dev-python/ipykernel-4.6.1-r2 with python3_7 - SyntaxError: invalid syntax ( ...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Matthew Thode ( prometheanfire )
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-20 12:04 UTC by Guillaume Seren
Modified: 2019-07-10 18:29 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build_python3_7.log (build-python3_7.log,3.70 KB, text/plain)
2019-06-20 12:04 UTC, Guillaume Seren
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Guillaume Seren 2019-06-20 12:04:10 UTC
Created attachment 580218 [details]
build_python3_7.log

Hey there,
I have been trying to add the support for python3_7 on my system,
and I get this issue on ipykernel, see the traceback (complete log attached):
```
 * python3_7: running distutils-r1_run_phase distutils-r1_python_compile
python3.7 setup.py build -j 33
Traceback (most recent call last):  File "setup.py", line 91, in <module>
    from ipykernel.kernelspec import write_kernel_spec, make_ipkernel_cmd, KERNEL_NAME
  File "/var/tmp/portage/dev-python/ipykernel-4.6.1-r2/work/ipykernel-4.6.1/ipykernel/__init__.py", line 2, in <module>                                                                       
    from .connect import *  File "/var/tmp/portage/dev-python/ipykernel-4.6.1-r2/work/ipykernel-4.6.1/ipykernel/connect.py", line 13, in <module>                                                                           from IPython.core.profiledir import ProfileDir
  File "/usr/lib/python3.7/site-packages/IPython/__init__.py", line 48, in <module>    from .core.application import Application
  File "/usr/lib/python3.7/site-packages/IPython/core/application.py", line 25, in <module>
    from IPython.core import release, crashhandler  File "/usr/lib/python3.7/site-packages/IPython/core/crashhandler.py", line 28, in <module>
    from IPython.core import ultratb
  File "/usr/lib/python3.7/site-packages/IPython/core/ultratb.py", line 124, in <module>
    from IPython.utils import path as util_path
  File "/usr/lib/python3.7/site-packages/IPython/utils/path.py", line 18, in <module>
    from IPython.utils.process import system
  File "/usr/lib/python3.7/site-packages/IPython/utils/process.py", line 19, in <module>
    from ._process_posix import system, getoutput, arg_split, check_pid
  File "/usr/lib/python3.7/site-packages/IPython/utils/_process_posix.py", line 24, in <module>                                                                                               
    import pexpect
  File "/usr/lib/python3.7/site-packages/pexpect/__init__.py", line 75, in <module>
    from .pty_spawn import spawn, spawnu
  File "/usr/lib/python3.7/site-packages/pexpect/pty_spawn.py", line 14, in <module>
    from .spawnbase import SpawnBase
  File "/usr/lib/python3.7/site-packages/pexpect/spawnbase.py", line 224
    def expect(self, pattern, timeout=-1, searchwindowsize=-1, async=False):
                                                                   ^
SyntaxError: invalid syntax
```

I am trying to install the 5.1.0 to see if it fixe the issue.


Guillaume.
Comment 1 Guillaume Seren 2019-06-20 12:52:09 UTC
And the issue is the same ob te 5.1.0 version, just like on this issue:
https://bugs.gentoo.org/687948
Comment 2 Benda Xu gentoo-dev 2019-07-09 11:16:25 UTC
Hi Matthew, I see that you have added Python 3.7 support to ipykernel 4.6.1-r2 and 5.1.0, but not 4.8.2.  What is the rationale behind that, and could you please help on this bug?
Comment 3 Matthew Thode ( prometheanfire ) archtester Gentoo Infrastructure gentoo-dev Security 2019-07-09 15:36:44 UTC
Simply missed it, we could add py37 or stabilize 5.1.0 (which needs deps stabilized) or add it to 4.8.2.
Comment 4 Benda Xu gentoo-dev 2019-07-10 04:27:49 UTC
(In reply to Matthew Thode ( prometheanfire ) from comment #3)
> Simply missed it, we could add py37 or stabilize 5.1.0 (which needs deps
> stabilized) or add it to 4.8.2.

Mattew, I am wondering if you could reproduce the bug reported here.
Comment 5 Benda Xu gentoo-dev 2019-07-10 12:23:30 UTC
(In reply to Benda Xu from comment #4)
> (In reply to Matthew Thode ( prometheanfire ) from comment #3)
> > Simply missed it, we could add py37 or stabilize 5.1.0 (which needs deps
> > stabilized) or add it to 4.8.2.
> 
> Mattew, I am wondering if you could reproduce the bug reported here.

Sorry Matthew for mis-spelling.
Comment 6 Matthew Thode ( prometheanfire ) archtester Gentoo Infrastructure gentoo-dev Security 2019-07-10 18:29:43 UTC
I've installed it here,  What version of pexpect do you have?  I have 4.6.0 installed